Sync identifying many false problems

When Zotero syncs, starting a few days ago, it runs for a long time with "processing updated data from sync server"; then it comes up with 289 instances of items "changed in multiple locations". Since I have not changed anything except on my main computer, these are clearly false negatives; and when I click through a few of them the "local object" and "remote object" seem consistently to be identical. I could click though 289 resolutions, but I thought it would be worth noting the problem. For now I'm just canceling the sync.
  • Can you provide a Debug ID up to the first conflict? You can then submit the debug output and cancel.
  • I *think* I successfully submitted the debug output; I got an ID number of D1434864403.
  • I believe this should now be fixed in the latest 3.0 Branch dev XPI. There's no dev build of Standalone, but you can sync using the 3.0 dev XPI in Firefox if you share your existing data directory (which should be the default behavior on first run). Alternatively, you can wait for 3.0 Release Candidate 1, which should be out soon, but it'd be nice to confirm that this is fixed.

    (There might be multiple issues here. If you still have some conflicts that look to be erroneous using the dev XPI, provide another Debug ID.)
  • Tried installing the branch in Firefox 8 (Windows 7), but it doesn't work -- it's listed in the Add-Ons screen and the options do work, but no icon in status bar; from tools menu, get "There was an error starting Zotero" message. This is the first time I've installed an xpi; I just downloaded and dragged it into a Firefox window, which seemed to work until it didn't. Am I missing something?
  • edited January 4, 2012
    OK, now having done that failed xpi installation (and before I saw adamsmith's comment) I reinstalled 3.0b3 in Firefox, then started Standalone again. Something flashed by about updating; now when I sync I get a new error message ("Invalid response from server") and a new Report ID: 96749641.

    Now it's back to behaving as before, except that there are more (341) unreconciled items, which still seem to be identical.

    I am eager to test a solution, both to reassure Dan that the fix in the current branch is working, and to have a working sync for my group collaborators.
  • Close Standalone and reinstall the dev XPI in Firefox. If you get a startup error, follow the instructions adamsmith links to.
  • edited January 4, 2012
    OK, went through all the steps in the debug process linked by admasmith. It still doesn't start. The three error messages I get repeatedly, presumably for each time I tried to open zotero, are:

    Error: unterminated parenthetical
    Source File: chrome://zotero/content/xpcom/data/item.js
    Line: 3751, Column: 31
    Source Code:
    thisNote = thisNote.replace(/(\r\n?/g, "\n");

    Error: Error loading data/item.js
    Source File: file:///C:/Users/Charles/AppData/Roaming/Mozilla/Firefox/Profiles/mjyyhmpn.default/extensions/
    Line: 230

    [extra output removed — D.S.]
  • Oops, my mistake. Grab the latest dev XPI, which should fix that error.
  • edited January 4, 2012
    OK, that XPI worked -- that is, Zotero started properly in Firefox. But it didn't fully solve the sync problem. Now we're down to 88 unreconciled items -- which suggests, as you thought, that there were multiple issues, some of which have been solved but not all. The debug ID for this run is D81275515.

    (With just 88 of them now I could just run through them by hand easily enough -- shall I do that? I would like to get this running smoothly again, but I don't want to short-circuit your debugging process.)
  • That's not a valid Debug ID. Copy and paste—don't try to retype.
  • edited January 5, 2012
    I did copy-paste but must have missed some digits. Here is the debug ID for another run: D1631526320. (Now there are 98 unreconciled items.)
  • edited January 5, 2012
    So the remaining ones—at least the ones I can see in the debug output—appear to be legitimate conflicts. On some of them, the items in question are child items that appear to have changed parent items, which doesn't show up in the conflict resolution dialog. This shouldn't happen under normal usage, but it could if you merged a lot of duplicates (or otherwise moved around child items) and didn't sync right away, and then somehow your client needed to do a full sync, comparing all items in your library with the server. (That's rare but can happen in some situations, particularly with auto-sync off.) You can go through the remaining ones manually, and if you don't see a change you should choose the local one.

    Also, if you haven't emptied your trash, you should do so before syncing again.
  • edited January 5, 2012
    OK, it's strange because I went from having zero conflicts to 88 or 98 or 341 abruptly, without really doing anything. Maybe it's what you suggest here: that the client decided for some reason to do a full sync and so picked up some things that had accumulated over time. I'll go through them and reconcile them, and if I see any issues with that I'll let you know. (I have also found several hundred orphans -- attachments that are duplicated, with one of the duplicates not attached to a record. Maybe that's connected to this issue.)

    Thanks for your help.
  • Until the full sync goes through, any items you edit locally that already existed on the server will add to the count (because they'll have changed in both locations as far as Zotero is concerned).
  • Still problems: I went through the reconciliation process for 110 items, and clicked "Finish". Firefox froze for a long time, first with "processing updated data from sync server," then with no message for a while. Finally it came up with 97 more unreconciled items. I went through them; some of them were definitely ones I had dealt with the first time (I suppose it's possible there were duplicates, but on some of them at least I'm pretty sure not.) Then it froze for another long period (> 15 min) with "processing updated data from sync server". Eventually it came back with 97 items again -- I think the same ones (I know that some of them are the same, but of course I can't remember all). So I went through reconciliation again with debug on; it came back with 97 items again; I canceled sync. The Debug ID is D908967079.
  • Disable auto-sync in the Sync pane of the prefs and provide a Debug ID from just before accepting the last conflict.

    I assume you're getting an error of some sort and auto-sync is kicking in before you can see it.
  • edited January 6, 2012
    I'm not sure how to provide a debug ID just before accepting the last conflict. When the conflict resolution window is visible I can't get to the gear or tools. Should I accept all but the last one, then cancel sync, then submit the debug ID?

    (I do have auto-sync off; otherwise Firefox freezes for long periods every time a sync starts.)
  • This might be a little trickier on Windows (where more windows are modal), but can you not open a preferences window from another Firefox window before the sync starts and switch back to it to start the debug output logging?
  • edited January 6, 2012
    OK, did that. The Debug ID was D1658070364.

    Then some other things happened. I got a bunch of alerts in sequence after I finished the reconciliation. (A comment, since a lot of these errors refer to multiple computers: I am not using Zotero on multiple computers at this point. I did try a couple of months ago to sync another computer, but for lots of reasons -- including some Zotero issues, but also problems with Sugarsync -- I gave it up. At this point I am accessing only from one computer.) The alerts are detailed below.

    Then the sync seemed to start -- I saw the progress bar for the first time. It seemed to be uploading everything back to the server -- the popoup said "Downloads: none; Uploads 1,892,523kb remaining", not changing; the files kept changing. When the files reached "726/728" it stopped for a bit, then gave me the red exclamation point with the popup message "Empty response from server." The green arrow popup reads "Last sync: 49 minutes ago".

    The error messages that appeared after I finished the reconciliation were:

    "Zotero items in the collection '1.assignment 3' have been added and/or removed on multiple computers since the last sync. The following items have been added to the collection:

    [extra output removed — D.S.]
  • When did you stop the debug output? That just appears to show clicking through various conflicts, not anything that happens afterward.

    What happens now if you sync again?
  • And those error messages are simplified versions of what they really mean. In most cases they do refer to multiple computers, but not in your case.
  • Let's see... I stopped the debug output, as you asked, right before clicking on "Finish" at the end of the reconciliation. So the stuff afterwards was indeed not captured.

    When I sync now various things happen, none of them good. First it froze again with an "empty server response" message. The next time it stopped and gave me a yellow exclamation point and a message that my group storage was full. That's a different issue, I uploaded a set of things from a colleague a couple of weeks ago and somehow it must have just registered as too much. I'll need to clear that out, but that is creating a new problem: when I try to move some folders from the groups into my library, I get an error and am asked to restart Firefox.

    I'll keep working on that, maybe try using standalone?
  • Sorry, I was unclear. I meant a Debug ID that started immediately before the last conflict, so that I could see what was happening afterward.

    But it sounds like you're no longer getting the conflict resolution dialog, which means your data successfully synced and now it's just syncing your files.
    when I try to move some folders from the groups into my library, I get an error and am asked to restart Firefox.
    Can you provide a Report ID for this?
  • edited January 6, 2012
    And you should probably stay in Zotero for Firefox until we resolve this, since I might ask you to try another dev build.
  • I don't mean to multiply problems, but trying to solve my group storage overflow is turning out to be difficult as well. I tried moving some of the material that is no longer being used by a group back into My Library, but that led to frequent crashes. I couldn't figure out why: at one point it seemed like it didn't like moving PDFs that had no parent, but I don't think that was the only issue. I may have to just increase my group storage in order to get the other sync to work, but I'm going to stop for now!
  • edited January 6, 2012
    If there's a bug with copying between libraries we'd be happy to help try to fix it, but we'd need a Report ID.
  • edited January 7, 2012
    OK, then: tried to drag a folder from the group "Educational Taylorism" into "My Library", using Standalone; got error message "An error has occurred. Please restart Zotero." The Debug ID is D154480956.

    Previously I have tried dragging files, rather than a folder, and gotten the same error -- not every time, but often, with individual files and small and larger groups. Occasionally it has worked ok. I also tried it in Firefox rather than Standalone, with the same results. I can repeat any of those scenarios with debug if you want.
  • First, confirm that this happens with your other Firefox add-ons (including ZotFile) disabled, and provide another Debug ID if so.
  • Also be sure that dragging is the first activity after restarting Firefox, to make sure that's what's triggering the error.
Sign In or Register to comment.