bug report: Add citation dialog does not appear in Zotero 3.0b1/libreoffice 3.3.2


I'm runing libreoffice 3.3.2 under ubuntu maverick, with firefox 4.0 and zotero 3.0b1 (both standalone & firefox versions are installed). Zotero is working fine -- well, GREAT -- but the connectors don't seem to work at all. I get this output when I click on the 'add reference' icon running libreoffice from the command line:

ZoteroOpenOfficeIntegration: Service initialized
ZoteroOpenOfficeIntegration: Executing addCitation
ZoteroOpenOfficeIntegration: Comm initialized
ZoteroOpenOfficeIntegration: Iterating mainLoop
ZoteroOpenOfficeIntegration: Sending message "addCitation"
ZoteroOpenOfficeIntegration: Iterating mainLoop

but no dialog box appears to permit me to add a citation. Libreoffice doesn't freeze either, though, so I don't think I'm stuck in some kind of infinite loop, and there are no java processes left running, so I imagine the process just dies too soon. Please let me know if I cna help with debugging.

Updating to Libreoffice 3.4 isn't such a great option for me, as there are currently no packages available for ubuntu maverick and the unpackaged versions tend to wreak havoc on my system. Thanks much,

  • Have you checked to see if the add citation dialog appeared behind the LibreOffice window?
  • just tried minimizing all other windows to be sure; there isn't a dialog window anywhere. next step?
  • edited August 23, 2011
    Generate a report ID after clicking the add citation button. You might also try checking "Use classic Add Citation dialog" in Preferences->Cite.
  • Two report IDs, one from firefox, with zotero standalone NOT running:

    and one from standalone, which seems more informative:

    the content of hte latter is:
    [JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIServerSocket.init]" {file: "file:///home/matt/src/Zotero_linux-x86_64/extensions/zoteroOpenOfficeIntegration@zotero.org/components/zoteroOpenOfficeIntegration.js" line: 57}]

    line 57 appears to read:
    serv.init(19876, true, -1);

    I'm afraid my javascript isn't good enough to see where the error there would come from.

    the first report, btw, shows an empty chrome URI being requested; I htink that this happens the first couple of times the 'add citation' button is pressed, but I can't seem to get more than 2 inatances repeated, so maybe I'm wrong.
  • just fyi: I'm getting the same error with libreoffice 3.4.2, downloaded from the libreoffice website.
  • Have you tried closing both Firefox and Zotero Standalone, and then opening only one of them? I think this should work. There is a bug handing off LibreOffice integration between them; this will be fixed in the next release.
  • Hi Simon,

    THanks for hte hint. I've tried that several times now to no avail, closing all three (Zot SA, FF, and LO) and then oping LO & just one of the others. No combination gives me the citation pop up window. I will try logging out and rebooting but I find it unlikely that will make a difference! If it does I'll report back. Thanks again.
  • edited August 23, 2011
    If it still doesn't work, can you create another report ID and a debug ID, with only one of Standalone or Firefox running (and opened while the other was closed)? Thanks.
  • I had the same problem, suddenly out of the blue. For me, rebooting worked, as reported here.
Sign In or Register to comment.