Zotero Standalone Chrome connector doesn't work via proxy

I'm using Zotero Standalone with Chromium 10 and the connector. It works pretty well, but if I connect to e.g. ScienceDirect through a proxy server it no longer recognises the page as saveable. Zotero on firefox has no problem with this.

Cheers, Mark
  • Can you provide an example URL for a ScienceDirect page when accessed through the proxy?
  • I believe Dan or Simon said they didn't expect this to work yet.
  • Yes -- its probably still won't work yet, but I'm interested in seeing whether some cases can be handled by being more crafty with translator targets. I've opened a ticket on proxies in connectors (standalone): https://www.zotero.org/trac/ticket/1769
  • To be more specific - if I access a paper, e.g. http://dx.doi.org/10.1016/j.asr.2010.09.015 I see the icon to save it. But I need to go through a proxy to get the full text, so I switch on the proxy and reload, for example - and then I don't see the icon any more.

    If I switch proxies to get the PDF having first loaded the page, it seems the proxy info gets passed to zotero SA since I get a popup requesting the proxy login details from both zotero and chromium. But nothing got saved (although I thought it worked at least once).
  • When you access the doi.org page via your proxy, do you have a different URL?
  • In both cases the actual page I reach is:


    Interestingly, with the proxy on, the zotero icon doesn't load. But when I switch the proxy off again, the connector *does* recognise the page AND I can access the fulltext (I guess something is cached somewhere)...
  • I've noticed odd behavior with VPN and no-VPN and full text as well. My guess is session IDs-- your session is marked as being a subscriber or something.

    It looks like this isn't really translator-specific-- there are just issues with proxies and the connectors+standalone so far. That's a known issue, and a priority for final release of standalone.
  • I get a similar behavior, except I can still see the save to zotero icon when I go through my proxy, it just fails to import.


    first works fine, second fails. Both work in 2.1b4 on firefox4.

    error report: 1604007161
  • *sigh* just as I thought I could ditch Firefox for good ...

    Here are a couple more that doesn't work through my university proxy but does work when I connect directly (i.e. http://www.emeraldinsight.com.library.school.ca/... vs. http://www.emeraldinsight.com/...)

  • Playing around with grabbing a citation for this:
    Apologies for the many error reports - I'm not certain if some of the errors are reported multiple times. The actual error is the same in all, except for a few additions in some. I included them all in case grabbing a citation already in the library is part of the problem - likely a red herring, but the third error report below was just after successfully doing that.. I'm a bit confused about when the 'Report Errors ...' cache is cleared and whether zotero is able to resubmit the same errors multiple times...

    With chromium 10.10 on ubuntu 10.10 and zotero standalone 2.1a3
    First I grabbed a citation from the above url (ie: no proxy). It worked. I didn't check if zotero had any errors to report.

    Then I went to the same page through my uni proxy and tried again. Note that the citation already exists in my library at this point. This second attempt failed (no new, duplicate item, reported a problem) and this error was waiting to be reported:

    This was a second similar (failed) attempt (also via proxy):

    Next I tried again without the proxy. It succeeded (duplicate appeared in my library), but these errors were hanging around in zotero waiting to be reported:

    Then I deleted the citation(s) from my library and tried again (without the proxy), zotero grabbed it without an error ("Report Errors ..." greyed out).

    I deleted it again, then tried (with the proxy), I got this error and no new library item:

    Finally, I tried again without the proxy (i do want it in the library, after all :). Success, but again zotero had this to report:

    Hope that's helpful
  • Hello there,

    I am unable to retrieve citations from PNAS via zotero connector for Chrome (Chromium 11) through my universities proxy.
Sign In or Register to comment.