Neo-/LibreOffice Firefox could not load the component required

When trying to use the plugin in either Neo or Libre Office both of the suites report the same error messages:
"Firefox could not load the component required to communicate with your wordprocesser. Please ensure..."
Checked the paths for the extension, re-installed them multiple times for both suites – followed the steps on the troubleshooting page.
No other offending addons in FF. Since the snag happens in both office suites I assume its linked to the Java issue in OS X referred to in Simon's post in this thread. Tried the possible solution here to no avail (other than killing my NeoOffice).
Both of the suites at any stage consistently showed Zotero’s bar but, after two dialogues about the digital signature not being verfiable and my subsequent ok, I’m back with ‚could not load component..‘
Does the Plugin work for anybody with Neo or Libre? Any other ideas? The Debug ID is D489800493.
Use FF 4.0b9, Zotero 2.1b4, the ZotOOIntegration 3.1b1 NeoOffice 3.1.2/ LibreOffice 3.3. rc3 all on Mac OS 10.6.5.
thanks, kithairon
  • Possibly the same bug as here, although again, I'd need a report ID (not a debug ID) to be sure.
  • Thanks for the response. The Report ID is 1004575620 (Posted some more recent Debug output with the ID D219485381 in case this is of any use).

    Thinking that what you suggested to the Linux user in the thread you pointed me to might do the trick I installed the latest nightly build of FF (4.0b10pre) - without much luck. What I got was this:
    '[JavaScript Error: "this.javaObj is undefined" {file: "file:///Users/amw/Library/Application%20Support/Firefox/Profiles/0a4o0bkp.default/
    extensions/" line: 288}]' when calling method: zoteroIntegrationApplication::getActiveDocument]
    Hope this helps to shed some light on the matter.
    Thanks, kithairon
  • Try dragging Java SE 6 (32-bit) above Java SE 6 (64-bit) in /Applications/Utilities/Java Preferences. This works for me on a nightly build.
  • Same issue here
  • Tried Simon's suggestion. It works! The switching of the Java pref's priority from 64-bit to 32-bit did the job.FF 4.beta10pre and Zotero's latest plugin for NeoOffice can play nice. Thanks for the help,
  • I tried this too (FF 4 beta 9 + LibreOffice) and no luck. @kithairon did using Neo vs. Libre make a difference for you? Should I go back to Neo?

  • Beta 9 is not enough. You need a nightly build (beta10pre).
  • thanks! works perfectly!
  • This trick also worked for me on the Standalone Alpha (2.1a2) and OpenOffice (3.2.1) on a mac. Thanks :)
Sign In or Register to comment.