Tried to upgrade to 2.1 for Zotero standalone - ERROR

ERROR report ID: 1816041397

It was a long message, something about a database. Now I can't even start Zotero up. Will have to reinstall 2.0 for now in order to work on my projects.
  • You get this same error repeatedly when restarting Firefox? Are you running Standalone?
  • Close Firefox and check Task Manager to make sure there are no firefox.exe processes remaining. Then restart Firefox.
  • I'm getting this same error. Downloaded Standalone and tried to start it; was told that I had to update my database to 2.1b3 in Firefox first. Installed 2.1b3, but on restarting Firefox got a very long "could not update" error that had something to do with a problem with a table in the database. This happened twice, after an uninstall and reinstall. The error said it was sending a report to the developers, so...
  • We're working on it. No need for further reports.
  • What happened to kfitz is exactly what happened to me.
  • We'll have a fix in a few minutes.
  • Upgrade error should be fixed in 2.1b4, available now.
  • 2.1b4 works like a charm - amazing work !

  • Hi,
    just upgraded from 2.1b1 to 2.1b4 and have the same error.
    The Debug ID is D2137381467.

    Is there any chance to get access to the db again?
  • twk: Are you sure you're running 2.1b4? Make sure you don't still have 2.1b3.
  • Hi,
    I'm running 2.1b4 - if I try to update, there are no updates.
  • does it maybe make a difference that I'm running ubuntu?
  • Hi,
    I tried to convert the backup from yesterday and succeeded.
    Still don't know what the problem has been but in my case, I will now use the working DB.
    Thanks for the fast response,
This discussion has been closed.