2.1b1 zotero word integration could not complete installation

I just tried the 2.1b1 version of Zotero and have this problem:

zotero word integration could not complete installation because an error occured
ID: 300199773

This happened after i installed the new beta version of Zotero, with the new plugins. With MS Word I only have the "Add bibliography" option, and i always get the error message when i open a new window of firefox.

I tried to uninstall and reinstall zotero, as well as the plugins, but the problem persists.

The open office plugin seems to work fine.

Firefox version: 3.6.11
Mac os 10.6.4

Thank you !
  • I too have been getting this error, though it is happened with the upgrade from the MacWord 3.0b3 to the b4 version and I am using the current 2.0 version of Zotero.

    Firefox 3.6.11
    Mac OS 10.6.4
  • edited October 30, 2010
    Report ID 117884801

    Message received when opening Firefox:
    "Zotero Word integration could not complete installation"

    All the steps suggested in the Zotero webpage to correct the error were undertaken to the best of my abilities.

    Mac OSX 10.6.4
    Microsoft Word:mac 2008 v.12.2.7(100910)
    Zotero 2.0.9
    Zotero MacWord Integration 3.0b4

    Thank you !

    P.S. Despite this minor recent glitch, I have only words of praise for the Zotero software and its developers for a simply outstanding product that has been progressively and expeditiously filling a fundamental gap in a virtually ideal fashion - please continue the enhancements, improvements and development, the market is yours.
  • Zcience, nlunsford:
    This thread is about problems with the beta version of Zotero, which neither of you is using. Please start a new thread with your issue(s).
    For what it's worth "all the steps suggested.. were undertaken is not very helpful. Please list exactly what you have done so far to troubleshoot.
  • edited October 30, 2010
    This is probably the same issue as that reported in the beta, so staying on this thread should be okay. If you are running Zotero 2.0.9, try installing the Zotero MacWord Integration 3.0 Branch XPI (not the trunk). If this works, we'll push another release in the next few hours and you should install that manually.

    The original poster, who is using the 2.1b1, will need to try the Zotero MacWord Integration Trunk XPI.
  • ah, I just read the instructions. Since I'm on a german version of FF and Word, I guess, I should wait a little, right? Don't want to loose my database
  • Provided you install only the MacWord Integration 3.0 Branch XPI (not the Zotero 2.0 Branch XPI, or any of the trunk XPIs), your database won't be touched in any way. The only difference between this and the currently available MacWord plug-in is two lines in an install script.
  • I'm on the 2.1 beta already though. So I'll need to install the trunk, right?
  • You can also install the MacWord Integration Trunk XPI without worrying about your database. The code is significantly less well-tested than the MacWord Branch XPI, but there isn't any risk of corruption; the main danger is that it won't work. Alternatively, you can close Firefox, remove the contents of /Library/ScriptingAdditions, re-open Firefox and let the plug-in install, and then restore the contents of /Library/ScriptingAdditions.
  • Sweet. It worked. Thanks so much.
  • If the problem is with the Adobe Unit Types.osax ScriptingAdditions, updating to latest version fixed this, so you don't need to move the ScriptingAdditions out of the way:


    Jonathan Morgan
  • To adamsmith: my apologies, I will try to pay more attention to the thread and to be more descriptive in future occasions - I was somewhat desperate and frustrated not finding a much needed solution. Thank you for the advice.

    To Simon: I did not have the opportunity to explore the Branch approach you suggested, but the Zotero MacWord Integration 3.0b5 available today seems to have fix it.

    Thank you.
  • I installed the Zotero MacWord Integration Trunk XPI, and it works perfectly !

    thanks a lot, Simon !
  • edited November 2, 2010
    This thread is now closed. Any further installation issues not resolved by following the steps above should be reported in a new thread.
This discussion has been closed.