Item Type error - everything imports as web page when they are articles

In the past few weeks when I import journal articles into Zotero, they end up imported as web pages and then I need to manually search and fill in volume, issue, page number etc

I think it happens on both EBSCO and ProQuest. Neither of those two will import directly to Zotero for me so I need to first export them to a folder and then from folder view export them as a Reference citation. That always worked in the past - ie a journal article was captured as such but now they are always captured as web pages for some reason.
  • If the URLs generated on failing sites can be used by other people, please include them. If the URLs are session-dependent, please provide a link to the page where you start your search & your search terms, so that people could try to replicate this.
  • Not sure that I can. I access the databases from a VPN of my university - through the University through to the database supplier - each of whom has another level of authentication. So here is an example of a typical search but I doubt it helps. This problem is recent - but there have been updates to Firefox and Zotero. FYI I am not yet on Firefox 3.6 because I am not sure if all the issues have been ironed out with Zotero but should I in the first instance try that update?,
  • edited September 28, 2010
    As noksagt said:
    If the URLs are session-dependent, please provide a link to the page where you start your search & your search terms, so that people could try to replicate this.
    i.e. which database, which search terms?

    Edit: I don't think there ever were any issues with Zotero and Firefox 3.6 - on the contrary, there have been some issues with 3.5 in the past.
  • Are you using Zotero 2.0?
  • Let me try to respond:

    1. The databases I use are EBSCO Business Source Premier and ABI / INFORM (ProQuest) and these are accessed via my University's network. I am not sure if there is a built in "Athens" identification to further complicate matters.
    2. Search terms - almost any but most recently I was looked at articles using a variety of terms such as segmentation, customer selection, methods overall and in the Journal of Interactive Marketing for which I am preparing a manuscript.
    3. OK then I will upgrade to 3.6; I always wait for it to be stable as the discussion fora do have threads of people with some issues whenever FF gets updated
    4. I have the latest Zotero version and yes I do use the 2 series solution
  • New Firefox and now Zotero won't work, something about a python extension not working; that is why I hesitate with upgrades to firefox. I will look online to see what to do but if you are online now, it would be great if you point me to the right solution.
  • Thanks I have updated now; I forgot to first uninstall the old and then to remember that I needed to download within Firefox not Safari. I got there in the end.

    However I still have the problem. I tested with a download off ProQuest an article by E Malthouse titled: Ridge regression and direct marketing scoring models and it came up as a web page still
  • To complicate it more. Using the Ebsco database I do not have this problem. I can export a reference to folder and export again to Zotero. Today the function to export to Zotero from the icon in the addressbar works too. Normally it does not. With ProQuest I cannot export from addressbar (never could) because of a known translator error. If I move the reference to a folder and then export to Zotero it still comes up as a web page.

    I will use EBSCO as my first choice database! But still annoying.
  • I can confirm that Proquests RIS output fails in the way Stan describes -

    Specifically for you, Stan, I'd suggest you focus on figuring out why proquest isn't working for you - it does for me and noksagt. So try disabling other FF add-ons, restart FF and try again. If it still doesn't work, open a new thread with a Report ID for the failing Proquest translator, including a specific list of search terms you used.

    For the rest of us - I think figuring out how the RIS translator fails would be good because it seems like potentially a more general problem - and I can't for the life of it track down what makes it fail. The RIS looks clean and even if I change some lines to make it look more like Zotero's own RIS it still imports as a website, although the entries clearly begin with
    TY - JOUR
  • edited September 28, 2010
    The translator does not like the blankline that ProQuest has after the TY line. Editing the translator to trim whitespace of the TY-tagged values fixes the type detection.
  • The updated translator (with a small tweak) is now available. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.

    Thanks to noksagt for the patch.
  • Thanks to everyone - albeit I can not really understand fully the conversation! But what I takeout is that the translator built into Zotero should now read the ProQuest output "better" and if I update my Zotero in 24 hours, I should have another go.

    FYI I have no add ons, and the only non Zotero related extension is "screen grab"

    Your help is much appreciated. After midnight now in London so I will close down.
  • if I update my Zotero in 24 hours, I should have another go.
    Reread my previous message. You can update manually whenever you want.
  • And please note that this merely fixes the import of RIS files generated at ProQuest.

    As adamsmith reminded you: there is a ProQuest-specific translator that works for him and works for me. Because it does not work for you, we should still troubleshoot that issue.
  • Updated manually and that seems to resolve the problem. In ProQuest, I exported a journal reference to the folder and from folder to Zotero and now, Zotero categorises it correctly as a journal article rather than a web page. Thanks.

    I cannot export the reference directly to Zotero from the little icon on the right hand side of the addressbar - I get an error message that this is a known translator issue. I have always had this and, when I brought it up a year or two ago, Dan suggested it is due to the particular nature of the proxy I use from my University.

    So we have restored the functioning to where it was and that is great. It is but a small inconvenience to have the added step of exporting references via a folder.
  • Interesting new twist on this. I did a search on EBSCO that generated two items, when I click on the icon in the address bar, it automatically downloads the citation of the first - no list appears allowing me to choose which.

    The search was in EBSCO global, for author Mccarty and publication "Journal of Business Research"; that generates articles from 2007 and 2004
Sign In or Register to comment.