recommended webdav services

Hi all, I know there have been a number of old threads on this topic but I need to find a new webdav provider as it looks like will no longer be able to support my zotero habit.
So I'm after some recommendations.
Preferably free and 2gig but I'm ready to bite the payment bullet if there are no other options.
  • I take it Zotero storage is not an option?
  • Sure it is. It just doesn't have the 'prefereably free' tag.
  • Well, to partially answer my own question, and to help out all the other mydrive orphans out there. I'm currently testing icloud (slight shudder at the whole 'i' thing, but what can you do?)

    Good news is that they offer 3GB free.
    ''twas a bit fiddly to set up though. I created a zotero folder in the documents folder and so the url for the zotero preferences looks like this:

    Only downside so far, is that they don't use https and they don't appear to be the speediest kids on the block. But it's not like I'm moving secret documents, just way too many pdfs ...

    Will report back once the sync is finished. Just for others info. I had nearly 6,000 files in my zotero folder when mydrive changed their options - so if this goes through on icloud hopefully most people will be OK (and as Dan pointed out on the other thread, limiting the number of files per folder isn't part of the webdav spec - though I remember the reason I moved to mydrive was that an older provider put this limitation in place)

    Fingers crossed.
  • I just set up a WebDAV server using only PHP 5 on a Synology network file server that I have.

    I followed the installation directions at:

    I'm using dyndns, and passing port 443 through my router so that I can directly access the https WebDAV server from the outside world. It took a lot more fiddling around to get the router properly configured than to set up the WebDAV server.

    It's working fine for me, albeit a bit slow, as expected.

    Note: I tried the Zotero PHP WebDAV server listed at , but that was nothing but trouble. I think the problem was that it was built for PHP 4. PEAR (a PHP library) also includes an unsupported WebDAV implementation (that's what the zotero link above uses), but SabreDAV seems to be a fully compliant and supported PHP WebDAV server.

    More info:
    Synology network file server: DS209, see
    WebDAV implementation I installed: SabreDAV, see
  • Well, I've got three computers synced now so I'm cautiously reporting success. Also, I think it may not be as slow as I first feared - I forget just how long it takes to upload that much data over wireless but now it's up there, all subsequent syncs have been fast.
    So here's hoping that icloud don't suddenly introduce a folder limiation.
  • Thanks for testing this out Jon.
  • edited September 2, 2010
    Why did you put the zotero folder inside the Documents folder? I'm trying to sync now, with my zotero folder at the same level as the Documents folder (which I think is the root-most level I can reach). It seems to be working (4% complete)...
  • I was mucking about with their web interface (which frankly is horrible) and for some reason which I completely forget, it seemed easier / obvious to put it there. So hopefully it doesn't / shouldn't matter. Plus it was about three in the morning, so reasons were a little thin on the ground :)
  • edited September 2, 2010
    Indeed, their interface is a bit confusing. I think they're trying to offer services (using applications on their servers?) beyond what MyDrive offered and they feel that this in-browser "virtual desktop" approach is the most appropriate.

    Edit: What you need to do (dear future readers) is click on where it says 'Cloud Drive' at the top, near the left. This will take you to a place where you can right-click and select 'New > Folder' (name it 'zotero').

    It was pretty easy to follow in your footsteps though, so thanks for posting this information!

    MyDrive is dead! Long live iCloud!!
  • I just let zotero create the zoterofolder in the root level. What is the reason for manually copying the zotero folder?
  • I don't understand your question, asplundj... who suggested that you should manually copy the zotero folder?
  • sorry I meant creating not copying
  • Oh, well if Zotero creates the folder itself, then there's no need to create the folder manually. :D In that case, just enter into Zotero (replacing my_profile_name) with your username and away you go.
  • For some reason not working for me. When I try to verify server through zotero it just comes up with username or password not accepted by server. Checked both, and they work to log into icloud through browser. I might be doing something stupid but can't see what. Any suggestions welcomed... or other straightforward, free webDav. Thanks
  • Is the drop-down menu in Zotero preferences set to HTTP or HTTPS? Apparently (I haven't checked), this service only works for HTTP.
  • HTTP, really not sure what is going on, checked the username and password again but still coming up with server not accepting...
  • You sure you changed "my_profile_name" in to your actual username? I can't think of anything else... Failing that, offers 1 GB free?
  • If you created your own zotero folder, make sure it's all lower case - as I think I had this problem and that was the reason. If you haven't created your own zotero folder, it might be worthwhile doing so and seeing if that helps
  • Thanks for both suggetions. Eventually just got annoyed and decided to sign up for the zotero account, though slightly worried that I would use up the space over the next year. Good news is that both works great (so far) and, must be something to do with the compression they use, is taking up considerably less space than it did on the server.
  • Just tried today Webdav from iCloud.
    It DOES work for me, and I have successfully switched from to on multiple computers.
    In zotero preferences:
    ("zotero" folder previously created manually inside "xios" folder)
  • i had also problems to set up icloud, particularly because what seans_potato_biz recommended above
    "Edit: What you need to do (dear future readers) is click on where it says 'Cloud Drive' at the top, near the left. This will take you to a place where you can right-click and select 'New > Folder' (name it 'zotero')."
    did not work for me in firefox. The webpage simply did not react. What DID however work was to click on the square cloud button at the bottom left and open from there the file browser and then create a new folder. I needed to create a new folder from icloud to make it work. Setting up the folder through zotero preferences did not work, as in EdF's case.
  • I cannot successfully 'verify' the icloud server.

    My zotero sync preferences are: (with '/zotero' always thereof course)

    I get the failure both with the zotero folder created manually or not there.

    One thing of possible interest: When I use Firefox to log my icloud account it never progresses after the 'Starting icloud' screen. This works fine in IE.

    My zotero debugging log says this:
    (3)(+0007170): Verifying storage

    (3)(+0000001): Getting WebDAV password

    (3)(+0000002): HTTP OPTIONS for http://petervermont:********

    (3)(+0000264): Server: nginx/0.7.67
    Date: Mon, 13 Sep 2010 13:59:58 GMT
    Content-Type: text/html;charset=ISO-8859-1
    WWW-Authenticate: Digest realm="", domain="/", qop="auth",nonce="pzCK+4hmonKbC+3pD8buzbgtrv8", algorithm=MD5
    Cache-Control: must-revalidate, no-cache, no-store, proxy-revalidate
    Content-Length: 1298
    Connection: Keep-Alive

    (3)(+0000000): <html>
    <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/>
    <title>Error 401 Unauthorized</title>
    <h2>HTTP ERROR: 401</h2>
    <p>Problem accessing /petervermont/xios/zotero/. Reason:
    <pre> Unauthorized</pre></p>
    <hr /><i><small>Powered by Jetty://</small></i>
  • You could try typing your webdav URL
    directly in the browser address bar and authenticate yourself this way.
    Then try again "Verify server" from Zotero.
  • Thank you for your suggestion.

    I have tried that and it brings up an auth dialog. I put in username and password and the auth dialog shows up again. This happens repeatedly until finally I hit cancel and then I see 'Error 401 unauthorized'.

    Of course this makes it seem that I don't know my credentials but the webdataQT.exe app provided by iCloud to mount my drive on windows works just fine with those same credentials.
  • Trying now, weeks later, to set up the WebDav syncing on my laptop, I am confronted with an error upon clicking verify:

    "SSL certificate error connecting to %S. Load your WebDAV URL in the browser for more information."

    Apparently, according to another thread on this forum (, the way to resolve this is to load the address in the browser. However, this is not possible, as suggested by PeterVemont above. I have the same issue of repeated authorisation dialogues. The same credentials log me into their fancy interface, though.
  • If you guys have access to a network file server with HTML/PHP web server interface, you should try the SabreDAV WebDAV software I posted above. I've been using it for a few weeks now without any trouble. I have synced my library to 2 different servers and synced the same library to 2 different computers - everything is going smoothly.

  • @seans_potato_biz

    That sounds like an ssl error.

    icloud does not support https so try http instead.

    This did not fix the problem for me but did change from the SSL error to a different error: "Permission Denied: The WebDAV server did not accept the username and pasword you entered. Please check your file sync settings or contact your server administrator"
  • Is it possible to use Microsofts SkyDrive instead?

    (Sorry, if this is a stupid question...:-)
  • It appears that my problem has something to do with the firewall at work which is at DHMC (Dartmouth Hitchcock Medical Center). Mentioned that so some fellow sufferer might find this thread via Google!

    I successfully connected and synced with WebDAV from home. In addition if I use a VPN over to the college network which is far more open, I can successfully use WebDAV from my work computer.

    One oddity is that I can successfully use icloud's webDavQT.ext to mount my cloud drive from within the work network.
  • One oddity is that I can successfully use icloud's webDavQT.ext to mount my cloud drive from within the work network.
    Zotero requires support for some requests in the WebDAV specification that some WebDAV servers apparently don't implement or don't implement correctly. It's possible that the network setup is disrupting some of the request types that Zotero needs, but that not all WebDAV clients employ -- webDavQT.ext may just not use those request types. Glad to hear that connecting to the target network via VPN fixes things.

    SkyDrive may work if it supports WebDAV -- does it?
Sign In or Register to comment.