[Zotero 7 Beta] Word could not communicate with Zotero - Win 10

I get this error when I try to add a citation or click on any other button.
But then, simply going to Zotero and back to Word fixes the problem.

Steps to reproduce:
1) Open Zotero
2) Open an empty Word document
3) Click on ZoteroAdd/Edit Citation
→ I get this error:
https://s3.amazonaws.com/zotero.org/images/forums/u265723/nhfglt8a3yv7800q5bud.png
4) Click Ok
5) Go to Zotero by clicking on its icon in the taskbar
6) Go to Word by clicking on its icon in the taskbar
7) Click on Add/Edit Citation
→ This time it works as expected:
https://s3.amazonaws.com/zotero.org/images/forums/u265723/8ryztm4o49smpacrc23p.png

I have tried following the troubleshooting steps, including deleting the Zotero.dotm and reinstalling it manually from the Settings:
https://www.zotero.org/support/word_processor_plugin_troubleshooting
But it is just partially broken.

The Debug ID is: D31909667.
Zotero 7.0.0-beta.84+71f83c0a3 (64-bit)
Windows 10
Microsoft Office Professional Plus 2019
  • This is the same problem I'm having. I didn't realize that simply refocusing Zotero would fix it.

    https://forums.zotero.org/discussion/115060/zotero-7-beta-word-processor-plugin-breaking-on-windows-11
  • Good to know that you can also get it to work by refocusing Zotero, thanks,
    It took me some time to realise that it was "partially" working, after trying to remove the other plugins in Word, and many other things.
  • @mjthoraval @bennett.smith After "fixing" it by going to Zotero, does it become broken again after a while? Or does it only become "broken" again by restarting Zotero?
  • It can be broken again by switching to Firefox.

    Firefox 126.0.1 (64-bit
  • edited 15 days ago
    @adomasven: A bit more testing:
    - If I close Firefox, I do not see the problem anymore.
    - I have disabled all the plugins in Firefox and removed the Zotero Connector in Firefox → It still produces the same error when Firefox is opened.
    - Same problem with Firefox Developer Edition 127.0b9 (64-bit)
  • @mjthoraval @bennett.smith This should now be fixed in the current Beta. You might need to manually reinstall the Word plugin if you have Word open when you restart Zotero after an update. Could you test and see if it now works correctly for you?
  • edited 14 days ago
    @adamasven
    I updated the Beta build of Zotero this morning, and only then started having this issue. Then this was happening to me as well. I see you've done some pulling on Github recently, but I confess being very noob to that whole GitHub thing ... so rather than play all day, I am leaving my code solution here, for you to review as a potential adjustment. I had been having the same issues as others above, but then it changed from "connection" error to "mismatch" error when I installed the new version of the Word "plugin".

    What I did before adjusting code:
    Remove Zotero.dotm from startup dir
    Clear Zotero plugins js and the other troubleshooting details on the Zotero site related to this.

    System:
    Win 11 64 // Office 64 / Zotero Beta 7.0.0-beta.86_569225897 64 bit

    The error indicates "Type Mismatch" and points to:
    ThWnd
    in this line of the FindZoteroWindow() Subroutine:
    ThWnd = FindWindowEx(0, ThWnd, "MozillaWindowClass", vbNullString)

    The following VBA code adjustments worked (but, I'm a GenX hacker ... not a proper coder ... so while this WORKS for me, I don't profess that it is correct for others and that it won't break things elsewhere.) The following were my changes to the Zotero.dotm VBA code that made it all work again. Primarily, shifting to LongPtr in the variable declaration section worked. I did make changes to the FindZoteroWindow subroutine, but I'm not actually sure if the final version is different in any significant way.

    [Code removed. A.V.]
  • Thank you @chirdon. We already have a fix and will deploy it shortly. Sorry for the botched release!
  • Hey, no sweat here @adomasven . I just found a solution and didn't want to "have a solution" and not share. Instability and regressions are part of the fun of beta versions ... lol.
  • This is fixed in beta 87.
Sign In or Register to comment.