[Z7 Beta] Loading the outline takes very long and sometimes crashes the reader

Hi, in the more recent betas I've noticed that opening the outline view feels quite sluggish for longer PDFs. I quite often see the spinning wheel for more than 20 seconds when opening it.

When opening the outline view in the left-hand pane before the PDF is fully loaded it also crashes the left-hand pane and the reader toolbar at the top. I can reproduce this reliably with at least some bigger PDFs.

DebugID: D1221498447

The end result looks quite similar to what I described here: https://forums.zotero.org/discussion/114835/z7-beta-annotation-pane-and-toolbar-turn-blank-after-trying-to-change-page-number#latest

I've also captured a video: https://imgur.com/a/wsMJ1P0
  • I have the same issue, debugID: 343638877
    7.0.0-beta.84+71f83c0a3 (64-bit)
  • Please send the problematic PDF files to support@zotero.org with a link to this thread.
  • edited 11 days ago
    I just sent you a file that leads to the crash. Thanks for looking into it!
  • But can you still reproduce that in the latest beta?
  • I just did and it doesn't seem to crash any more - thank you!
  • With version 7.0.0-beta.85+c0c00a00e (64-bit), I also find that displaying the outline takes a long time (sometimes over a minute), even when the PDF already has an outline in it. Is the automatic outline creation being performed even if the PDF contains an outline?

    Debug ID: D1369890212
  • @warwickmm Please send the PDF file.
  • Sent. Thanks.
  • errorID: 1922824356
    7.0.0-beta.87+f59a4da7f (64-bit)

    Now it seems to crash a bit faster instead of taking so long to load.

    It seems to only happen when the file in question has no actual document outline AND the file is more than maybe 20 MB? I can reproduce it on a 63 MB document, and I can make it stop happening by editing the file in Acrobat and manually adding at least 1 bookmark position.
  • @mgwientjes Could you send the file that is causing the crash?
Sign In or Register to comment.