Files not syncing between desktop and iPad

This discussion was created from comments split from: WebDav Zotero 7.
  • edited March 19, 2024
    yeah, i'm having the same problem.

    I had setup a Zotero 7 WebDav a couple weeks ago to syncronize files between my desktop and ipad, it worked fine back then.
    But now after a couple weeks it just does not syncronize files via WebDav between my mac and my ipad any more.
    I did updated iOS in both desktop and ipad a week ago or so.

    The error in my ipad is
    `Error: The attached file could not be found.`
    I can see the given file in WebDav correctly uploaded from desktop to webdav as described in [1].
    The ipad and desktop veryfies the connection with WEbDAv just fine.
    Zotero online library sees the attached file but does not open the attached file.
    So don't know what is wrong here.

    Please help, thanx

  • edited March 20, 2024
    (Please start new threads for new issues — the thread you posted to isn't related. I've moved this to a new thread.)

    WebDAV file downloads were broken in the iOS app briefly. Update to 1.0.30.

    If you're still having trouble, follow the steps on Files Not Syncing and provide the requested info, which you haven't done.
  • So i did more debugging.

    I set up WebDAV sync in my iPhone, which has Zotero (v.1.0.15 Build 2), and there it works.
    I can succesfulyy download the attached pdf and see it in Zotero.
    My iPad has Zotero (v. 1.0.29 Build 244) and there it does not work.
    Both devices have the same WebDAV configuration.
    My iMac has Zotero (v. 7.0.0-beta.68+c31a40c74).

    The Debug ID that my iPad gave when i tried to open an attached file from the WebDAV is: D2084504717.
    The message displayed in my iPad is after failing to dowload the attached pdf is:
    "Error The attached file could not be found".

    Let me know what could i do?
    Maybe install the previous version of zotero in my iPad, cuz i did updated Zotero recently.

    Thanx for your help !
  • @stefaniecg, please update to the latest version 1.0.30, that fixes the issue. Let us know if after that you keep having problems.
  • It's working after updating iPad app.
    Thank u so much !
Sign In or Register to comment.