Z. in google docs not working

edited February 26, 2024
Report ID: 69611025
When trying to add citation or modify them, or add bibliography it doesn't open the pop up in Zotero but it opens the "insert link" option in google docs and does' do anything.
Happened after I copy pasted one of my texts from one document to another and tryin to add again citations that were unlinked. Tried restarting, removing and reinstalling add on and zotero and everything. I'm using Opera.
  • It seems that Google servers are experiencing some issues. This will likely resolve on its own, but we are monitoring the situation.
  • edited February 26, 2024
    Just as an update, there appears to be a widespread outage affecting all sorts of plugins across Google Workspace (Docs, Sheets, etc.). Unfortunately we can't do anything here, but I would assume Google will fix this quickly.

    (This isn't related to the recent problems some people were experiencing due to a change in Google Docs that required Zotero Connector updates. This is just an unrelated server-side problem affecting many products that Google will need to fix.)
  • According to Google this has been mostly resolved for the last few hours:
    We believe the issue is mostly resolved for impacted services. Our engineers have implemented a new mitigation to prevent recurrence of this issue and are showing signs of recovery.

    We are investigating a few reports of triggers/API related errors which may be impacting a small number of users.
    From "Multiple Workspace products experiencing intermittent failures due to an Apps Script issue":

    https://support.cloud.google.com/portal/system-status?product=WORKSPACE

  • Report ID: 149998814

    I had the same problem as radeghast a week ago. This day it worked, then, by yesterday, it doesn't work anymore: when trying to add citation or modify them, or add bibliography, sometimes it doesn't open the pop up in Zotero, nothing appears anymore, other times, the pop-up appears and I add the citation but while it adds the citation to the document, an error message appears and the citation fails.
  • I am having the same problem - I have been trying to add citations since Monday and I have the same struggles; whether working in Chrome or Firefox.
  • edited March 3, 2024
    I'm going to offer a thought. Over the past year I've used Google Docs to collaborate on two major projects. When it works, it offers a great experience. However, both times we ran into serious problems. We did not use Zotero with GDocs. Google Docs can be a mess on its own. If I must collaborate with others to interactively author a manuscript, I'll reluctantly use it again. I much prefer the stability of LibreOffice and the ease of using Zotero with LO.

    edit: In the middle of each of the 2 projects, the GDocs user interface changed. That alone was frustrating. When the writing, commenting, and editing interface changes in the middle of a writing project it can be really annoying.
  • I continue to have major issues with Zotero in google docs, including both in Chrome and Firefox. I'm using zotero 6.0.35 on MacOS and reinstalled the connector to ensure I was using the latest version.

    Still zotero hangs when adding citations and the only way to resolve is to refresh the page and restart zotero. This has been happening the last ~2 weeks.

    I sometimes also get messages that someone else is editing my the doc. I typically have to refresh the page once or twice for this message to disappear.

    Zotero also broke when copying and pasting a large chunk of text, causing all the citations to become unlinked. Rather frustrating experience overall.

    Is there any indication of ongoing issue with Zotero and Gdocs?
  • I'm having an issue with Zotero in Google Docs also (doc already had previous Zotero citations from a few weeks ago, so it's been working previously). I just confirmed my browser extension (Firefox) is updated to fix the recent issues Google caused (version 5.0.120). I can make a separate post if desired, but figured I'd comment here since this is a current/relevant thread
  • I'm struggling with google docs and zotero as well. I have done an update on zotero and that is working fine but I don't have the zotero link on word. Any advice?
  • edited March 13, 2024
    Same problem! Zotero 6.0.35 on Mac using Safari. Zotero hangs on the red loading bar when attempting to add citations. More info here:

    https://forums.zotero.org/discussion/112647/zotero-stuck-on-zotero-is-updating-your-document-please-wait-when-used-with-google-docs#latest

    Very frustrating, used to work SO good!
  • edited 29 days ago
    Is there any indication of ongoing issue with Zotero and Gdocs?
    Yes, all the recent problems with Google Docs have been due to a redesign that Google rolled out that unfortunately has made it much harder for Zotero to integrate properly. We've fixed most of the problems in recent versions of the Zotero Connector, but we're still working to debug some intermittent issues that can occur. We hope to have something to test shortly and will post here when we do.

    For now, you may have slightly better luck with Zotero Connector 5.0.121 for Firefox or 5.0.120 for Safari, but you may still need to occasionally reload Google Docs and try again.
  • OK, we've pushed a new Zotero Connector beta (5.0.122beta1) for Firefox that we're hoping will fix most of the remaining problems people were seeing.

    If you've still been having trouble and you're able to test in Firefox, please try that and let us know how it works for you.
  • @dstillman

    I've been testing the beta connector in Firefox for most of the day and haven't run into any of the reported issues so far - most importantly, for me, I haven't had the issue I'm having in Chrome where sections of the document become unselectable with the cursor. Hopefully this means the issues have been resolved!
  • I've also been using the Firefox beta connector for the past day or so and I am having way fewer problems - the citation dialog box now always pops up as expected and works pretty smoothly (a bit slow but not bad). Yay! The updates are so appreciated!!

    I still on occasion have the issue where I can't select text with my cursor, but much, much less frequently. One thing I'm not sure if others are experiencing - when I add a citation, after I click "ok" or "cancel" on the citation dialog, the Zotero window (in addition to the citation dialog) disappears, and I have to cmd + tab to bring back the window (usually I am looking at an open pdf for a reference). Anyone else having this issue?
  • We've released Zotero Connector 5.0.122 for Chrome, Firefox, and Edge with the latest fixes.
  • So far, so good on 5.0.122 for Chrome. Will be doing more thorough testing today.
Sign In or Register to comment.