trouble with python / MSword add-on after update to firefox 3.6

I posted an an error-issue 255234435

My problem: After updating firefox to version 3.6 (from 3.5.7) the Zotero MSword add-on does not work and the pythonext is greyed out. Installation of the newest pythnext from the zotero webpage seems to hang in the "to be installed after restart" queu even after several restarts.

Zotero worked fine with MSWord 2004 and OpenOffice 3.1. on my MAC Book Pro under Mac OS X 10.6 (Snow Leopard) and Firefox 3.5.7 Today I updated Firefox to 3.6. In that process Zotero updated the openoffice add on to 3.0a6 some other add ons are greyed out. During the restart of Firefox the Zotero Word add-on Ö(3.0.a7) gave the errormassage described in the python troubleshooting. First I thougt it was a problem because my MSword program was open during the Firefox update, so I closed the program but that did not help. Than I realised, that the pythonextension was greyd out. It was the the pythonext-2.6.1 version. I uninstalled that version and restarted the Firefox. Than I got the Word add-on message that pythonext is missing as described in the troubleshooting article. (Note: I did not get the message that python is uninstalled incomplete as statet in the troublshooting article). Than I tried to install the pythonext 2.6.2 from the zotero page. Restarted Firefox but the Pythonext is still greyed out and tells that it needs a restart of Firefox to be fully installed. I tried this several times including to restart the whole Mac OS but still the pythonext seems to hang in the "to be installed" modus.
Anybody has any idea how to complete installation?

  • edited January 24, 2010
    Dear Dan,

    thanks for the quick response! I tried to delete the cache but it did not help. After restarting firefox the zotero-word add on was greyed out and the python disappeared. With the update button the zotero-word add on was activated again and the message that it need python appeared. Then I installed the python add-on from the zotero site and it hangs again after restart in the "will be installed after restart queue". I tried it the other way round: delete the three cache files again, than first install python add-on. But this time the python add-on did not install at all. Then I tried to restart the whole computer after installing the zotero-MSword-add-on but after installing the python-add-on again it was stuck in the install-queue.

    I don't know if it is more a problem of firefox. Maybee I try to post a message there.

    Another maybe important information: I work under a "normal" account i.e. not as administrator. Normally if a program needs in the installation process administrator rights it pop up a window to give the administrator name and pw and to run it under that allowance. But with the other add-ons I don't have problems like that. (And it would not help to install the zotero add-ons while logged in as admin because than the add-ons would not be avaible to me while working in the normal account since the add-ons are in the profil-archive that is specific to every account.

    I posted an new report id: 365550995 for maybe it helps

    Thanks for any help
  • Delete the files again, along with compreg.dat and xpti.dat.

    You can also try a new Firefox profile.
  • Dear Dan,

    thanks again for the tip. I am sorry to say that it did not help. I also tried to delete the compatibility.ini as well but that did not work either.
    What I nocticed is, that when I delete the files not only the zotero-word-add-on is greyed out but all the add-ons that need a "compatibility update" while the add-ons that where just updated to a new version number prevail active. Don't know if that helps.
  • Did you click Find Updates to ensure you have the latest compatibility information?

    And again, you can try a new Firefox profile if you're still having trouble.
  • I am having similar problems to Olaf. Upgraded to 3.6 on Snow Leopard and python won't even show in the extensions. I have disabled compatibility checking and still it won't work. I have tried making a new profile with no luck. And I have followed the suggestions to delete the extensions cache files. Again, nothing.

    Any other things to try?

    Thanks in advance.
  • edited January 26, 2010
    You're installing the version of PythonExt from the installation page?

    You shouldn't need to disable compatibility checking as long as you have Firefox set to check for updates to extensions.

    Report ID?
  • Thanks, Dan

    Yes, PythonExt from installation page. It loads but after restart is no where to be found and error report reminds need for Python.

    Report ID: 18463646

    Tried rc1 (was using trunk.xpi) and same problem. Reinstated compatibility check, and same problem.

    Again, thanks.
  • And you get the same problem in a fresh profile? Does it initially say PythonExt has been installed and tell you to restart Firefox?
  • Dan:

    Fresh profile will not work. I install Python 2.6.2...0920 and python disappears on restart and a notice saying I require python 2.5 or later appears. In other words, exact same problem across profiles.

    Using OS X 10.6.2, Word 2008, Firefox 3.6 and Zotero 2.0 rc1

  • Yes, but what happens before the restart?
  • Error-ID 1743914518
    HI Dan,
    I also tried to install zotero in a brand new firefox profil. And same problem like goldberghiller. I tried to first install zotero main plugin. than I tried
    1. install first python but it did not appear. than MSwordplug in. And got after restart the error message python missing. Tired again install python but it did not appear in the add-in manager.
    2. I deleted the whole testprofil. Made a new one and tried it the other way round. First zotero main. Than MSword plug in. Got the error-message that python is missing. Than Tried to install python but it did not work out either.
    I used the fresh zotero 2.0rc1 and the plug ins from the zotero site:

    any further suggestions?
  • Sorry, but we really need specifics here. What happens immediately after you install the PythonExt XPI, before you restart Firefox? Tell us exactly what you see on the screen.
  • Dan:

    Before the restart python seems to install, pending restart. After restart, it is as though it was never there. It is not grayed out, it is not shown with a red exclamation point, it is just not there.

    And I have to click through a note saying python must be installed.
  • Dan:

    Looks normal: "Restart Firefox to complete your changes" and "PythonExt Restart to complete the installation."
  • Hi Dan,

    I just tried the same from within my administration account - just in case the problem is for that I work with an normal (non administrativ rights) account. But seems to be the same. Send in the ID: oops did not think about that copy-paste does not work between two accounts - sorry dont know the error-id but it seemd to be the same.

  • Hi Dan,

    With me it is the same as with goldberghiller. First appears the PythonExt as if it is installed and just needs the restart from Firefox. After restart it just has dissapeard. But the MSword Plug in that had been grayed out before now is not greyed out. When I try to insert a citation from within MSword (in my case 2004 version) I got an error because missing connection to firefox.

    Thanks for your pacience
  • Hi Dan,

    the above said is with the new profile. In my old profile the pythonExt appears in the add-on mannager with the notice that it will be installed when firefox will be restarted. But after restart nothing changes on that.

  • edited February 3, 2010
    OK. You can ignore the post-restart error, then, since that's expected if PythonExt isn't installed. The only issue is that PythonExt isn't in Firefox's list of installed extensions after restart.

    Just to eliminate a possible Firefox compatibility-checking bug, try installing this XPI:

    [link removed]

    If that doesn't fix the problem, it might help to observe the 'extensions' directory within the Firefox profile directory before, during, and after the restart. Do you see a directory? A staged-xpis directory?

    It might also help to view debug output during the restart. (Do this for the Firefox instance when you first install PythonExt, and then you should also see output for the restarted session.) This isn't really related to the Zotero extension itself, so you can skip Step 1—starting Firefox from Terminal is enough. There may not be much (or anything) in there, though.
  • Hi Dan,

    thanks for all your help!! I tried the new xpi but have the same problem.
    I found an directory but empty. And a staged-xpi directory within which there ist a directory in that there is a tmp.xpi

    The debug stuff I try tomorrow because I need to get up in less than 6 hours for work and need some sleep now - sorry. Hope you advance with the problem with goldberghiller.
  • Might be worth deleting and staged-xpis manually and trying again, though they may just reappear.
  • Dan:

    New python didn't work any differently. staged-xpis is empty after restart.

    Thanks again.
  • Debug output?
  • Debug D1452373508

  • Dear all:

    I had similar problems ever since I started using Firefox 3.6 beta. Now that I found Dan's solution of deleting Firefox's extension cache files, it worked for me. The first launch after I deleted the necessarily files needed a restart to apply a compatibility patch. Upon restarting Firefox again, all the extensions worked. Thanks. :)

    By the way, I'm now using Firefox 3.6 final, running on Mac OS X Leopard with Word 2008.
  • goldberghiller: See what I said regarding debug output above. We need real-time debug output in Terminal for this, not a Debug ID, and we don't need output from Zotero itself.
  • edited January 27, 2010
    Sorry, Dan. Here is the debug output:

    [debug output removed — D.S.]
  • OK, nothing relevant in there.

    We'll keep investigating, but at this point my best suggestion would be to revert to Firefox 3.5, since this appears to be a problem in 3.6.
  • Thanks for all your help. I did revert to 3.5.7 and all works as before.
  • Hi there,
    for your information: I ran into the same problems. After upgrading to Firefox 3.6 the wordplugin was broken. I was able to install the phytonExt, but it didnt appear in the addon-manager. After unsuccessful trying the options mentioned above (deleting files, creating a new profile etc.) I downgraded to Firefox 3.5.7. Now the Wordplugin is working.
    My System:
    Mac OS X 10.5.8
    Zotero 2.Orc1
    PhytonExt 2.6.20090920
    Zotero MacWord Integration 3.0a7
    Word 2008 for Mac 12.2.3

Sign In or Register to comment.