Some books can't be found by ISBN

edited September 2, 2023
I've noticed that some international edition of books can't be found when using "Add Item(s) by Identifier" feature.

For example this book https://www.pearson.de/principles-of-chemistry-a-molecular-approach-ebook-global-edition-9781292348940
which has the following ISBNs (copied from the inner cover of the book):

ISBN 10: 1-292-34888-7
ISBN 13: 978-1-292-34888-9
eBook ISBN 13: 978-1-292-34894-0


The US edition's ISBN is 978-0-13-489574-1 and Zotero can identifies it just fine.
  • edited September 3, 2023
    Zotero searches several resources to identify a book by its ISBN. However some publishers register ISBNs with registrars that do not make their listings available to software such as Zotero. If the registrar doesn't have a suitable API and some other entity such as WorldCat or the US Library of Congress, etc. hasn't happened to include the record; Zotero will not be able to capture the metadata associated with the book.

    Enter ISBN into the forum search field (above) to find additional discussions on this problem.
  • Generally speaking, ISBNs for international editions of text books will rarely work. They're poorly captured in library catalogs (Zotero doesn't actually rely on publisher-provided metadata for ISBNs at all).
  • I'm also having a surprising number of fails.
    It isn't throwing an error, but I feel like I haven't gotten something to work for a few weeks now,

    >> and today, it is something from 2017 , so I feel like that is a good example.
    Are we just using databases that are going stale and need to find some new apis?

    So here is the specific 2017 example.
    "Design Thinking for the Greater Good"
    ebook ISBN: 9780231545853

    << zotero == "not found"
    >> WorldCat == no problem , https://www.worldcat.org/search?q=9780231545853
  • Yeah, that URL should work (and does for me), so that's a more specific issue.
    Could we get a debug ID for trying to add that ID https://www.zotero.org/support/debug_output

    That said, we've seen some pretty gnarly ways OpenWorldcat keeps locking people out, so it's becoming a less reliable fallback option for books not listed in any of the other catalogs we look at.
  • (Which will affect ebooks more often than other books; the print book ISBN is in the Library of Congress, so that imports fine)
  • I tried to run it again after turning on logging . . . haven't done it in a while so hopefully the correct process. :)

    Report ID : 726529424
  • No, debug output as linked, not error report ID
  • Ah -- how about this (or I can just paste in the text)

    D2005108346
  • I recently installed the Zotero app on my iphone as I would like using the ISBN bar code scanning feature to add items. It worked very well with books in English, but I noticed that searches fail concerning books printed outside the USA. For example this one: ISBN 9788829700783 (book in Italian) and this one:ISBN 9781504800808 (in English, but published in UK)
    So I searched both on WorldCat and Google Books using their ISBN, and found the right books. Then I tried adding the same books using the "Add Item by Identifier" on the desktop Zotero version and it worked fine. I suspect the iphone Zotero app uses only the Library of Congress database while the desktop one uses also WorldCat. If so, why?
  • edited 12 days ago
    @adamsmith I'm having the same issue as @moore.709 Here is my logging output after enabling logging and click "Add from identifier" with the same ISBN 9780231545853 as above (I also submitted it with ID D919540677):

    [removed — D.S.]

    continued in the next comment...
  • edited 12 days ago
    [removed additional output — D.S.]
    (1)(+0000001): HTTP GET https://www.worldcat.org/api/search?q=bn:978-0-231-54585-3 failed with status code 403

    (3)(+0000001): Translate: Could not find a result using Open WorldCat
    System info:

    version => 6.0.35, platform => Linux x86_64, oscpu => Linux x86_64, locale => en-US, appName => Zotero, appVersion => 6.0.35, extensions => ZotFile (5.1.2, extension), Zutilo Utility for Zotero (3.10.0, extension), Zotero Citation Counts Manager (1.3.0, extension), Zotero LibreOffice Integration (6.0.4.SA.6.0.35, extension), Better BibTex for Zotero (6.7.203, extension)
  • edited 12 days ago
    @cheflo: Please don't post full debug output here, just Debug IDs. We'll excerpt relevant parts.

    Same answer as above — you're being blocking by WorldCat's anti-bot measures. We're always doing what we can to make this work, but ISBN lookup that depends on WorldCat might not work, depending on how many items you've tried to add, your IP address and/or geographical location, etc. That ISBN works for me.

    You should be able to save from the WorldCat website as an alternative.
  • Thanks for posting the explanation @dstillman, that is helpful! I can confirm that it seems like the geographical location was the culprit. I'm in Europe, and after using a VPN to change to a American IP, Zotero does find the book (interestingly a Canadian IP did not work).

    And sorry for posting the full output, I thought this is what adamsmith asked for when he said "debug output as linked", but I must have misunderstood.
  • There's something wrong, though, with the K10+ search. The ISBN has 5 hits in the K10+ catalogs and we just seem to be constructing the request incorrectly so that it returns the number of search results, not the actual search results.

    (Specifically https://sru.k10plus.de/opac-de-627?version=1.1&operation=searchRetrieve&query=pica.isb=9780231545853 AND pica.mat%3DB&maximumRecords=1 doesn't work but
    https://sru.k10plus.de/opac-de-627?version=1.1&operation=searchRetrieve&query=pica.isb=9780231545853&maximumRecords=1 does )

    @AbeJellinek -- I'm buried currently, so if there's any way you can take a look?
Sign In or Register to comment.