Import from Mendeley failing to complete

Thanks to all who provided instructions how to migrate a Mendeley library to Zotero 6: Can anyone point me to existing info to troubleshoot the following bug?

After syncing new "private notes" from their desktop app 1.19 to the Mendeley server became erratic starting in January 2022 and eventually stopped altogether a few months later. Since the library has >15'000 entries with thousands of PDFs, I first imported into Zotero the sqlite file of a re-installed 1.18 version of the Mendeley desktop app: This worked for only about 12'000 entries that I had downloaded until end of May 2019, their PDFs and highlightings, and for the main notes (though not for those in "Private notes" fields). Trying to add missing items, I next imported also from the Mendeley server, but only 200 of about 3000 additional references were added to Zotero (and without any private notes that had still synced to the Mendeley server). Re-launching "Import from Mendeley..." again triggered the progress bar for about 5 hours, but then it stalled after 90% and no items were added to the library at this stage. So I tried once more, with exactly the same outcome.

Is my only option to abort the stalled import and try to manually export the missing items from Mendeley and import them e.g. as .ris files, without their PDFs, notes and highlightings?
  • What do you mean by "private notes"?

    Can you provide a Debug ID for an online import attempt that stalls? (You can use the "View Output" option to see if it's actually still doing anything.)
  • Thanks for the quick reply! Notes in Mendeley can be added to a "General notes" field at the top, or as Private Notes within a PDF (in their new Reference Manager app, they call the latter "Annotations").

    And to obtain a Debug ID from the Help menu, do you suggest to quit Zotero first? As is, the progress bar of the Importing has been stalled for hours, and no menu in Zotero is shown in the menu bar except "Zotero", where it seems I could only use the Quit command. The menus "File" and "Window" are greyed out and disappear a second after I select the Zotero app icon or the stalled Import window.
  • OK, so just PDF annotations. Zotero imports PDF annotations from Mendeley.

    Yes, you might as well restart and repeat with the View Output window open.
  • Thanks - the ID is D356133922.
  • edited February 7, 2023
    This debug doesn't include the import process, you need to start debugging before beginning the import (you can cancel current import and restart it) and only click submit once the process resulted in error or appears stalled for a long time.
  • Thank you - so I relaunched the import once again: It unfortunately takes 4-5 hrs each time until reaching the 90% where the progress bar stalls, and another hour to verify that it stalled. To try to retrieve a Debug ID, I pressed the Esc key first to close the Import window and then tried to activate View Output in the help menu, but this triggered the never-ending rainbow wheel. It seems my only option is to force quit Zotero?
  • By the way: The "Cancel" button does not interrupt my Import progress bar. In fact, it does nothing at all.
  • Since nothing happened, I finally force quit and restarted Zotero. The new Debug ID is D777258952.
  • edited February 7, 2023
    I'm not quite sure what you're doing here, but that Debug ID is empty too. See the instructions again, and see tnajdek's specific instructions above.
  • Hmm... My Debug Output dialog window contained 10 lines, including (on line 5): "No unprocessed full-text content found", which made me wonder whether the 3000 references that are not imported are for some reason not found by Zotero?
  • No, that's totally unrelated. We need debug output for an actual import attempt.
  • I did follow the instruction of tnajdek. My only issue was that I did not quite see how to best quit the stalled Import (the Cancel button did nothing).
  • The View Output window is a separate window. You can switch to it and submit the output even if you can't cancel the import. On Windows, you should be able to just click on it. On macOS, you can use Cmd-` (backtick) to switch between app windows.
  • edited February 7, 2023
    Thanks, your help is greatly appreciated. Reproducing the stalling of the Import to then produce again a new Debug Output will take again >5 hours (tomorrow). And in the previous attempts, as long as the Import dialog window was open, I could not find a way to make the Help menu visible and open an Output window. I use a Mac and will try Cmd- next time.

    In the meantime: Could it be that completing the log for the latest Debug ID simply took a while? Because now, my Debug Output window shows many more lines (Debug ID D140989525). Is there a way to know when the compilation of a Debug Output View is finished?
  • Again, you can open View Output first, run the import, and then switch to that window. And it's Cmd-` — that is, Command plus the key above Tab.
  • edited February 8, 2023
    Thanks: With the View Output started in advance, a Debug Output window did indeed keep track of the import, but slowed it down: Instead of 90% in 4-5 hrs, only two thirds of the progress bar were filled after 12 hrs, and then Zotero froze (with a rainbow color wheel turning, and with the app icon going unresponsive).

    When I clicked Cmd+Shift`, the Import progress window disappeared (normal? Or because my keyboard requires to add the Shift key to type backtick ` ?), and I was able to select Zotero again, and the "Submit" button in the Debug Output window became responsive and triggered its own progress bar. But that on its own seems to take forever. If it finally shows a Debug ID, I will post it here.

    Since each step is so slow: Can Zotero pick up where it left in case I have to interrupt internet access to move between workplaces? Thanks for your patient advice...
  • edited February 8, 2023
    You can also just copy as much as possible starting from the bottom of the View Output window, paste into TextEdit, save and ZIP the text file, and send it to us at with a link to this thread. We just need to see some of the output at the bottom to have any idea what's happening.
  • You can also just log debug output to a file instead, which wouldn't slow it down as much and would work even if Zotero crashed or froze:
  • edited February 8, 2023
    No luck: The bottom of the View Output window still continued to add lines, so I set the laptop to not go asleep or start a screen saver, or disconnect in any other way from the WiFi connection to the internet while I was in meetings. But after I returned, Zotero was frozen, and the progress bar in the Debug Output window was replaced by an error message: “Error submitting output”.
  • edited February 8, 2023
    I have not yet tried to log the debug output to a file (as it would take again >5 hrs, I suppose). Instead, I simply left Zotero open. And after waiting another while, the "Submit…" button of the Debug Output became responsive again, but the progress bar again stalled. I sent a screenshot from the bottom of the Debug Output window (as far as it let me scroll down).
  • We'll need the text file, sorry.

    You should leave View Output closed, since that will likely slow things down. You can check the size of the text file in Finder to make sure it's going up.
  • Also, are you leaving "Download new items only; don't update previously imported items" checked? You should.
Sign In or Register to comment.