Files not found after Mendeley import

This discussion was created from comments split from: Files not found after Mendeley import.
  • dear all, I am having exactly the same problem, even though storage should not be a problem because I upgraded (thinking that syncing again would solve the problem, but it did not). Could you here summarize the steps to take? if importing from Mendeley is not the problem and I can save hours, then I'll appreciate a straight answer to solve the issue. Also, I have the same problems with a shared group folder full of papers. My colleagues have already synced their Zotero but I still can't access any of the pdfs! Thanks!
  • There's a lot going on in this thread -- could you specify what, exactly, your problem is and what you have checked and what you have done to try to fix it?
  • edited January 23, 2023
    @adamsmith exactly, there's a lot going on in this thread. I have exactly the same problem reported in this thread "The attached file could not be found at the following path:"
    I synced again my library and upgraded my storage, but the problem remains. My documents aren't there and then when I click on "locate", Zotero shows hundreds of folders with strange code names (path would be user/Zotero/storage/weirdly named folders). Obviously, when I go to the folder where I have the pdf and choose it, then Zotero updates that file, and then I can open the pdf in Zotero, but I can't do this for every single paper I have...
    Why is this problem happening?
  • (it's always better to start a new thread for a new issue)

    It's hard to determine from your messages whether there is a problem with Mendeley import or with syncing. Does this happen on the same computer that you did Mendeley import on, or another one? Also Can you confirm that these files are present online in your Mendeley Reference Library?

    Also when you say:
    Obviously, when I go to the folder where I have the pdf and choose it, then Zotero updates that file, and then I can open the pdf in Zotero, but I can't do this for every single paper I have...
    When you use "Show File" that takes you to `/user/Zotero/storage/KEY` (where KEY is 8 letters/digit) is a PDF file there or is the folder empty?
  • Hello @tnajdek, thanks for your efforts in helping with this topic.

    1) this is another computer where I do not have Mendeley installed. I simply synced my library from Zotero and logged in to my Mendeley account. I did this once and it all worked fine, but then my computer had a problem, was formatted, and did the whole process again. This time is when I am not finding my papers in pdf. I haven't tried syncing everything again cuz it takes several hours, and from the original thread in this post, Mendeley syncing was not a cause.

    2) Yes, when I use "Locate file" it takes me to a list of folders with letters and numbers; the folder where the "Locate" takes me is empty, and when clicking on other folders I see that many are indeed empty.

    I hope this gives a better idea of the problem and a potential solution. Thanks!
  • edited January 27, 2023
    Just to clarify terminology: when we refer to "syncing" we mean Zotero syncing. Importing from Mendeley is a different process and it will always take much longer than syncing with Zotero servers.

    If your missing PDFs can be located in a web library (link at the top of this page), then what you need is to sync. If not, you might need to re-import from Mendeley and then let Zotero sync so that you don't need to do it in the future.

    If you encounter problems with syncing on importing, we will need a debug output from that particular operation.

    Also, from what you're saying, it's possible that you've previously imported from Mendeley and synced, but did not have enough Zotero storage to sync all files to Zotero servers (there is a warning in Zotero when this happens). If that's indeed the case and you would like to store these files on Zotero servers, you'd need to upgrade Zotero storage (after you re-import them from Mendeley).
  • edited October 9, 2023
    Hello guys @tnajdek @dstillman @adamsmith,
    I am back because I still have the problem that my pdfs are not found in Zotero after importing my library from Mendeley. I upgraded my storage to Unlimited now, and I would like to re-import everything, however I am afraid that my shared folders and new added papers will be affected. Can you advise me on how to proceed? I don't wanna lose my notes and everything I have done in Zotero, but I am also tired of adding my pdfs one by one because a great number went missing. Thanks a lot
  • edited November 2, 2023
    Storage is irrelevant in the context of importing data from Mendeley, that happens locally on your machine, and can be later optionally synced, as explained above.

    When re-importing from Mendeley, Zotero will detect if you've previously imported and will display an option, checked by default, that says "Download new items only; don’t update previously imported items". As long as this option remains ticked, items previously imported won't be touched, so your changes are safe.

    For peace of mind, I'd recommend backing up your Zotero data before running the importer again.

    Zotero always imports to currently-selected library, ensure "My Library" is selected when opening the import Wizard and your group libraries won't be affected.
  • Hello @tnajdek

    I followed your advice; I re-imported my library from Mendeley with the "Download new items only; don’t update previously imported items" checked.

    However, there are still many papers that are not found by Zotero. To verify that these papers are in my Mendeley library, I signed in to Mendeley and looked for a couple of papers that Zotero did not find. These papers are in Mendeley and I could open them and see my notes and highlights. What is your suggestion to help with this? I have re-imported everything twice by now, lasting some hours every time and the problem remains.

    I love Zotero, but this is very frustrating.

    Thanks in advance
  • Try re-importing again, but this time with debugging enabled. Once the process finishes, please submit debug and paste Debug ID here.
Sign In or Register to comment.