first sync with new zotero storage

I'm migrating my shared library from webdav to Zotero servers, and upgraded storage last night to 5GB. my first sync from my mac (MacBook, OS X 10.6.2 ff3.5.5, Z2.0b7.6) was rocky and threw a bunch of Javascript errors, but eventually made it through to the end after some restarts and other vodoo. Syncing from my colleagues' windows machines has not gone so well. Both are running b7.6, and appear from the library and file listings to have synced pretty well, but then give the error:
Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.moveTo]

Error report: 254274446
Debug ID: D1803911796
  • 'message' => "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.moveTo]"
    'result' => 2147500037
    'filename' => "chrome://zotero/content/xpcom/storage.js"
    'lineNumber' => 786
    Unfortunately this doesn't give us much to go on, other than that something is preventing Zotero from copying a downloaded file from the temp directory into the 'storage' directory. Does this happen every time, or is it intermittent? If the former, have you tried restarting the computers?

    Do both machines give the same error?
  • It's happening every time on multiple computers, both before and after restart. Here's two sets of error reporting from two different Vista computers, both after restart. Could it be a cross-platform issue? Initial sync was from a mac. If I purge the sync and restore from one of the windows machines would that help? Any other restore/reset tricks to try? I should add that all our machines have custom storage folders outside of the firefox directory--could this be the issue?

    Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.moveTo]
    error report: 1277538091
    The Debug ID is D226579468.

    Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.moveTo]
    error report: 2085594465
    The Debug ID is D1011739968.
  • Brief update on this:

    I've now tried this on multiple profiles and machines running both vista and XP, before and after restart, and the error is very consistent. It appears that the *library* is syncing fine, but the *files* are not. In fact, at one point a new file seemed to have synced and I opened it on another machine, but it subsequently disappeared--so I guess the file is showing up in the temp directory and not making the move over to the permanent directory? This does not appear related to directory location--I restored the default storage directory on one of my machines, did a full sync restore from server, and still have the errors.

    I should also add that the file sync progress bar makes an appearance and a fair amount of progress is made before the first error. After the error, hitting sync again, the progress bar starts at 50% complete and fails almost immediately.

    I'm reaching the end of my troubleshooting chops here, and the move to Zotero storage is crucial for re-establishing our workflow after the JungleDisk failure, so any guidance will be much appreciated.
  • Disable the Norton Firefox extensions and/or any other Norton components that relate to Firefox.
  • w80
    edited December 8, 2009
    No luck on the one machine I currently have access to (virtual machine running winXP, Z2.0Beta7.6, ff3.0.13)--I was running AVG free (never installed norton) and turned it off completely. Upon sync the progress bar shows up, the file count gets (consistently) to 356 or 357/628 files, even though the progress still shows 0%, and then the same failure code, though it looks like a slightly different error. Report ID: 165250364
  • What kind of virtual machine? Are both Windows systems virtual machines?

    What other software is consistent between the two machines?

    And we need the actual error that shows up when you click on the sync error icon (unless it's still the nsIFile.moveTo error), since it's getting cut off in the error report. (If you're not, it's helpful to restart Firefox immediately before generating a Report ID.)
  • Sorry, should have specified.

    I've tried 3 windows machines, 2 of them actual, running vista, and one of them virtual on my mac running XP under VMware Fusion. In all cases the sync error has been the same moveTo error respective of software config, firefox restart, or machine restart. Right now I'm working remotely, so I only have access to my virtual machine, but can email back to the mothership if there are things to test on the physical vista machines.
  • w80
    edited December 8, 2009
    This has been a huge pain but I've made some progress--I'm pretty sure this is some kind of cross-platform issue. When the primary sync to the new Zotero file storage was from my mac, the windows machines all had the same error (which seems to have popped up elsewhere as well, most recently:

    So I did a full sync reset TO the server from one of the windows vista machines, then did a full sync FROM the server to another (virtual) machine running XP. There was a lot of waiting, a bunch of inexplicable (given that I'd just reset from the server) sync conflicts, and then...more waiting and more sync conflicts. But I now *appear* to have 1 mac and 2 windows libraries synced.
  • Didn't work for me.. still the same thing. This file sync seems quite buggy...
  • This is an issue with saving filenames containing characters that are invalid on Windows. We're working on a fix.

    (med80009: You've already encountered trouble with filenames with invalid characters, so this is just a different manifestation of the same problem. And these reports are the first we've seen of it.)
Sign In or Register to comment.