Unable to add RSS url

I've tried to add two RSS URLs, both are failed. Save button is grey in popup window after click Add Feeds by URL. Some screenshots including output log are uploaded, you can access by https://imgur.com/a/WUF99FL


Tried in Zotero 6.0.15 and Zotero 6.0.15-beta
  • edited October 13, 2022
    If you provide a Debug ID for trying to add one of these we can take a look, but usually this just means your access to the feed is being blocked.

    (I also can't open the second URL at all.)
  • edited October 13, 2022
    I can access these URLs in browser, the second URL in browser will download an RSS file.

    Debug ID D725794556

  • (3)(+0008841): FeedReader: Fetching feed from http://feeds.nature.com/ncomms/rss/current

    (3)(+0000426): NS_ERROR_UNEXPECTED Exception:

    _parseAndNotify@chrome://zotero/content/xpcom/feedReader.js -> resource://zotero/feeds/SAXXMLReader.js:76:15
    onResponseAvailable@chrome://zotero/content/xpcom/feedReader.js -> resource://zotero/feeds/SAXXMLReader.js:66:3

    (3)(+0000001): FeedReader: Terminating feed reader (Processing failed)
    Same answer as here:


    It's something about your computer or network.
  • Hi @dstillman, thanks for your reply, but I have a question. I can access these URLs in browser. If there is something wrong with my computer or network, the browser will fail to access these URLs.
  • No, not necessarily. See the Connection Error page I linked to in the other thread.
Sign In or Register to comment.