Openoffice extension - no connection with firefox

  • After updating to 1.0.2 for both Zotero and the OOo plugin on WinXP and OOo 2.3, I receive the following error from within OOo when attempting to insert citations through the OOo toolbar:

    'Zotero – Error: An Error occurered communicating with Zotero. Please ensure Firefox is open and try again'

    I confirm Firefox is running when this error message appears.

    I removed the OOo extension and now I have also lost the Zotero toolbar in Ooo. I have tried to uninstall and reinstall the extension, but the Zotero toolbar does not appear.

    As with others, I'm very impressed overall and look forward to using this more (and especially a working interface for defining citation styles, or modifying those that currently exist).
  • OK, just to summarize the issues here:

    1) If you're getting a communication error in OOo, first go to the Extension Manager, expand My Extensions and Zotero.oxt, and make sure is enabled. If not, try selecting Zotero.oxt and clicking Enable and see if that causes to become enabled. I've gotten errors at that point (and they've been discussed on other threads), but, at least for me, persistence, restarting OOo, and/or reinstalling the plugin has always paid off.

    2) If is enabled and you're still getting the communication error, make sure you have the latest styles by clicking Update Now in the General pane of Zotero prefs. (Until a few minutes ago, a full reset would've been necessary, but that should no longer be the case.)

    3) We're working on fixing the empty square issue. It only occurs on Windows.
  • Hi Dan,

    Im running zotero on Ubuntu 7.10 with OOo 2.3.0 and I also get the empty square, so I guess it's not just a Windows problem. Sorry about not declaring that properly. I don't know whether it is printed, but I can see and erase it on screen.

  • On Firefox, Zotero 1.0.2, OOo 2.3.1, Zotero OOo plugin 1.0.2, WinXP, I have lost the Zotero toolbar. I have uninstalled and reinstalled the plugin (and the plugin in 'Enabled' in the OOo Extensions manager) but the toolbar does not appear in OOo.

    This occurs on only one of the two machines on which I have the same set of software as listed above. How can I get the Zotero toolbar to reappear in Ooo 2.3.1?
  • The problem has got worse than ever for me now. Totally unable to use Zotero when writing.

    I've re-installed the plugin (for more than once). Its status in OOo extension manager remains UNKNOWN; and when I tried to enable it, I could not (it did not allow the action).
    I find that the status is DISABLED, but in grey -- meaning I could not enable it.
    I've also done the update at the Zotero preference, restarted OOo, even reboot computer. None works.
    Needless to say, the plugin is not working for me now, and I am stuck. :(
  • PS: I mean, I got the 'communication error' box every time I click on any icon on the plugin bar.
    I just redid everything again, problem persists.
  • Yam:

    You might try these other threads:

    As far as we can tell, this is a problem in OOo that we have no control over. It's always worked for me after trying a few times.
  • Dan,

    Thanks for threads. Though they did not solve my problem directly, they sort of inspired me to figure out some steps to get through. The key in my case was to make sure the plugin was completely gone, leaving no traits behind (uninstalled and cleaned computer, the restarted), then re-installed it. It worked!

    One little hiccup still, but not sure it is something from Zotero or OOo. When I chose citation style from the plugin, I was initially not able to highlight Modern Humanities Research Association (both with & without bibliography) while I could highlight any of the others. The issue arose across several different documents. I finally (somewhat accidentally) got around it but choosing another style & clicked OK, then I opened the box again to change style, and it allowed me to choose MHRA! Again, the same happened across different documents. Weird. This is not fatal but you'd probably want to look at it some time.

    Many thanks.
  • edited January 10, 2008
    Altough Firefox and OOo were working yesterday, I now have the same problem (the first one) as Yam... and solved it the same way.
    I already had the second problem while FF&OOo were still running yesterday... and have it still.
  • edited January 11, 2008
    1.0.x releases don't auto-update translators and styles after an upgrade.
    Why not? Are there any drawbacks if the translators and styles are auto-updated after a 1.0.x update?
  • edited January 11, 2008
    Why not? Are there any drawbacks if the translators and styles are auto-updated after a 1.0.x update?
    mozStorage in Firefox 2 is unstable with very large database transactions, and the translators in particular have grown too large to safely update in batch, so we're holding off on database migrations from the local SQL files on upgrade until Firefox 3.

    It's only an issue in 1.0.2 because 1.0.2 receives some styles from the repo that 1.0.1 and earlier don't. Zotero 1.0.3 will manually update from the repo on installation, and it shouldn't be a problem after that.
  • edited January 12, 2008
    When I chose citation style from the plugin, I was initially not able to highlight Modern Humanities Research Association (both with & without bibliography) while I could highlight any of the others. The issue arose across several different documents.
    Follow-up for the selection problem on this thread.
  • Just to let you know the solution from Dan Stillman worked for me (thanks), but not initially (I still got the 'no connection to Firefox' message after updating the translators. However, it turned out I just had to go back to the extension manager in Openoffice to enable the Zotero extension (again). I.e., the part of the extension was not automatically enabled after updating to Zotero 1.02.
  • This worked for me, although I had to jump through a few hoops before I could use OOo/Zotero without completely freezing my desktop (I'm using Ubuntu). Removing everything from ~/.openoffice.org2/user/uno_packages/cache didn't solve the problem, so after uninstalling the plugin and closing OOo, I had to track down leftover references to Zotero (using "grep Zotero -d recurse *" while in the .openoffice directory) and delete them from config files (namely, ~/.openoffice.org2/user/registry/data/org/openoffice/Office/UI/WriterWindowState.xcu) .

    Now everything seems to be working fine.
  • Same situation when migrating from 1.01 to 1.02 (Windows, OO).

    First ,connection problem and many uninstall of plugin, reboot and reinstalling.
    It's now OK but still the "empty square" issue...

    Following the link gived by dan (, it seems that a correction exist for empty square issue ? (changeset 2108) ?

    do we have to wait for a new release or is it possible to install a "patch" to be able to run zotero again ?

    thanks in advance

  • Hi folks -

    we have the same problem here after updating to the most recent Zotero version - neither Open Office nor MS WORD can communicate with FF and Z 1.0.2
    (which worked under 1.0.1).

  • underscore: For communication errors that aren't OpenOffice-specific, see the "communicating with Zotero" thread. This thread is mostly about the problems enabling in the OOo extension due to (what appears to be) a bug in OpenOffice.
  • I was excited to get the plugin working again under 1.0.2, but once again it's ceased to work for me after upgrading to 1.0.3. This time I actually get a JavaScript error in Firefox:

    [JavaScript Error: "[Exception... "'Command "openZotero" not found in ZoteroPane.handleKeyDown()' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]"]

    (I sent the above error using the "Report Errors" function.)

    Again I've tried installing/uninstalling/reinstalling/restarting, etc. in all different combinations and it hasn't worked yet.

    Thanks, Joe
  • Joe: The pref nglayout.debug.disable_xul_cache isn't by any chance set to true in about:config, is it? It should either not exist or be set to false.
  • I managed to install 1.0.3 without any apparent problems / errors. I even seems to work in OpenOffice, except that nothing is being inserted when I select insert reference (nor does anything show up in the editor part of the Zotero plugin screen when selecting a reference). And no error screen or anything else I can pass on to the developers.

    I tried all the tricks and tips in this and other relevant threats, to no avail. So I am back to 1.0.2.
  • Hi Dan, no that variable doesn't exist.

    I'm having the same problem again after doing a fresh Zotero install (1.0.3) on a different computer. It worked all day today, but now suddenly it crashes OO.o whenever I try to use it. The problem seems to have been triggered when I tried to use it with Swiftfox running instead of Firefox. (I'm on an AMD64 system where Adobe Flash only works on the 32-bit Swiftfox.) This crashed it, but when I tried again with Firefox it was too late and something was permanently wrong. I've tried uninstalling and reinstalling to no avail.
  • Is anyone else still having this no connection problem with OOo? I have tried Zotero/OOo plugin on multiple computers and on each one it works for a short while then suddenly stops working irrevocably. I've installed/uninstalled/tweaked/etc. dozens of times and each time I get the same result. It would be great if I could use Zotero/OOo again.

  • Joe, are you still seeing the same error you reported previously in Report Errors when it stops working or a different error?
  • edited April 10, 2008
    I got this same communication problem (OO 2.3, OpenSuse 10.3, Firefox and Zotero 1.0.3) but it is not really reproducible. Suddenly it works again (after a new start) and then it didn't. What helped was Dan's hint to copy things successively into a new document. I was lazy and just copied all text and citations of the troublesome document into a new one - and than *miracle* - it worked again (Strg+A; Strg+V).
    No idea why, but maybe it can help some as a workaround or the developers to track down the problem.
  • I've added a documentation page that summarizes some of the troubleshooting steps outlined in this thread. Make sure you are running Zotero 1.0.4, which fixes some potential causes of communication errors.
  • Hi Dan,
    as I just posted in another forum I rather consistently can avoid the problem by having firefox pone (of course) _and_ being connected to the internet. The commuunication error only occurs when I'm offline. Maybe that helps.
  • The commuunication error only occurs when I'm offline
    What exactly do you mean by "offline"? It does appear that switching Firefox to "Work Offline" mode breaks the integration server, and only restarting Firefox restores it. But that's just the Firefox offline mode, which is different from not being connected to the Internet...
  • Hi,

    I had the same problem as everyone else, but got inspired by this thread to remove my bibliography (not any citations in the text). This solved the problem, and remaking the bibliography was just done with a click. I speculate that I might have changed the bibliography manually without even thinking about it and then saved the document or something like that. That might have caused the error. Anyway, this worked for me, using latest version of Zotero and Firefox/ on Vista.
  • I've share vroni's 'offline' problem with Zotero 1.0.7 on Firefox 3.0, running Ubuntu Hardy. I have the latest Openoffice plugin. If Firefox is in 'offline' mode (which happens by default if I start Firefox when not connected to the internet) then there is a communication error.

    If I untick "Work Offline" in Firefox's file menu then it works again so this is hardly a big problem on an otherwise excellent tool. I filed an error, number 1488811287. I hope this helps and that I'm not just stating the obvious and/or previously discovered.
  • cokelly72: See this thread for more on Work Offline mode. (Summary: There's nothing we can do about it, unfortunately. The auto-switch doesn't happen on OS X, but it does on Windows and apparently Linux as well.)

    The bug I noted above where you'd have to restart Firefox after being in Work Offline mode has been fixed, though.
This discussion has been closed.