English citation: multiple pages


I am wonderin... which one is correct: (Habermas 1984: p. 44-55) or (Habermas 1984: pp. 44-55). I am leaning towards the latter "pp." but my citation style "Harvard Reference format 7 (Author-Date) (de) (dev)" dosn't put it that way.

So my Question: Which one of the above is correct; and: it the latter, how do I get my citation style to work korrektly when typing in multipe pages.

  • ... I should add: The "pp."-function works fine in the bibliography, when Zotero gets the basic information from the database itself... but it dosn't work correctly when adding/citing certain passages in the Text.

  • "correct" is hard to say, but more common is pp.
    Zotero automatically adjusts that when you use
    <label variable="locator"/>

    Harvard 7 was written to be used in German, so it hardcoded "S." in there - in German that's the same for multiple pages- any reason you're modifying that particular style?
  • Thanks for your reply!!

    However I was not able to make it work.
    This is what the line looked like befor hand:
    <label variable="page" form="short" suffix=". "/>

    and I changed it to:
    <label variable="locator"/>

    Any ideas?

    I am modifying that certain style cause I preffer the way the bibliography wors out. e.g.:
    Habermas, Jürgen (1993): Moral Consciousness and Communicative Action. Blackwell Publishers.

    Instead of:
    Habermas, J., 1993. Moral Consciousness and Communicative Action, Blackwell Publishers.

  • edited May 2, 2010
    If we're looking at the style harvard7de.csl, the line you modified is in the macro with name="pages". That macro is called only in the bibliography (search in the style file for "pages", with the quotes, and you will find that string in only two places -- the macro definition, and where it is called, in the bibliography section).

    Since that macro is not called in the citations section, it won't have any effect on the form of citations. The line you want is in the citation section itself, and is configured as described by adamsmith.
  • Sorry... you've lost me =)

    What line in the citations section will I need to modify? This is what it all looks like:

    <option name="et-al-min" value="3"/>
    <option name="et-al-use-first" value="1"/>
    <option name="et-al-subsequent-min" value="3"/>
    <option name="et-al-subsequent-use-first" value="1"/>
    <option name="disambiguate-add-year-suffix" value="true"/>
    <!-- <option name="disambiguate-add-names" value="false"/>
    <option name="disambiguate-add-givenname" value="false"/> away - see http://forums.zotero.org/discussion/6142 -->
    <option name="collapse" value="year"/>
    <layout prefix="(" suffix=")" delimiter="; ">
    <group delimiter=": ">
    <group delimiter=", ">
    <text macro="author-short"/>
    <text macro="year-date"/>
    <text variable="locator" prefix="p. "/>

  • replace
    <text variable="locator" prefix="p. "/>


    <label variable="locator" form="short" suffix=". "/>
    <text variable="locator/>
  • yes! i worked! thanks!
  • Hello,

    i am looking at this right now since i thought about removing the hardcoded "S. " in order to also display different kinds of locators Chapter, Opus, etc...

    But when using
    <label variable="locator" form="short"/>
    <text variable="locator" prefix=" "/>
    then i always get the locators without "." at the end. Of course i could add it as a suffix, but then it would be also displayed at "Teil" etc, or i would have to differentiate there...

    The basic question is: how can one get it to display the localized locators as defined in
    https://github.com/citation-style-language/locales/locales-de-DE.xml ?
    It seems they are already defined to include "." where appropriate.

    I already defined default-locale="de-DE" at the beginning of the style, so as far as i understood, it should automatically be in that locale...?

  • mmoole - the updated locale files will be in Zotero 2.1.7 and will properly display the period after "S" (as well as other abbreviated terms). You're doing everything right, I'd suggest just waiting for the 2.1.7 release.
    (The locale files were copied from csl 0.8 where they didn't contain periods, I fixed them for German a couple of weeks ago).
  • edited May 28, 2011
    aha, thats excellent!! Alles wird gut und noch besser ;-)

    vielen Dank!, viele grüße
Sign In or Register to comment.