ISI web of Knowledge problems

Hi everybody,
I am having some problems in dowloading citations from the above mentioned search engine. In fact the behaviour of zotero that I obtain is quite random.
After I search for a keyword in web of science I get the list of the matching articles. If I try to save some of them by clicking on the small folder icon in the corner of the URL in very few cases a window pops up asking to choose which article to download (normal behaviour) but in many others I just get a grey window in the lower right corner with nothing in it. (I get the grey window also in the "normal behaviour"). This behaviour is obtained also in the case of a single article (not a list) or in the case of the "marked list". It does not seems to depend on the specific page.
I am using Firefox on Ubuntu 7.10 Gutsy. I have disabled all others firefox extensions. The search engine is ISI web of knowledge v.3.0 (not the new one).
I would be very grateful if someone could help.
By the way, this is really a great program! I would love to donate if there is such possibility.
Thanks in advance.
  • Hi there,
    same problem with me. Zoteros behavior with Isiknowledge Web of Science (old version) is completely random. Often only the first safe actually works (but sometimes not even that one). Tested several platforms including SuSE Linux 10.1 and 10.2, Windows Server 2003 and Windows XP Pro. Same problem with all of these platforms.
    Zotero seems to try to safe the results, but fails somewhere along. First thought it could be a connection issue, but at least on my side it shouldn't (could still be a connection problem with the Web of Science server).
    The error is independent of the size of the search results and the fact if other tabs were open or closed beforehand (Zotero even appears to have a problem when isiknowledge is the only tab open).
  • Hi,

    This bug's been raised a couple of times before. We get the same problem with other databases and library catalogues that use frames: where the content of a frame changes between Zotero captures, but the frameset doesn't.

    A workaround is to reload the frameset between captures. For WoK/WoS, in Full Record View, hit the reload button, which takes you back to Select a Search option, then hit the back button, which takes you back to the Search Results Summary, then go back into the Full Record View and hit the capture icon. You can capture multiple records this way, without logging in and out, but it's still a pain.

    Dear Zotero, Any chance of a bugfix???

    (Perhaps it'll all be fixed when the scraper for the new WoK interface is introduced?)

  • Thanks very much for the workaround!
    It is still a pain, but will save some time.
    I second (third) the request for a bug fix ...

    Ben Bolker
  • We just pushed a translator compatible and functional with the new WoK interface. Please let us know if you experience problems with the site.


  • Thanks. The new WoK scraper seems to work, and, as the new interface doesn't use frames, we don't see the frame-induced error. We do still have the same problem with other sites that use frames.

  • I've prepared a translator for our library catalogue, and I think it's being bitten by this issue. The scraper works fine for a single entry, but when I back up to the list of search hits and enter a new item, javascript is still running (rotating disk shows when cursor is in the browser bookmarks area), and the next capture attempt hangs.

    Is there no way to shut down the JS process after the capture completes, or am I missing something? Would really like to get this sorted.
  • Frank: Can you post the translator somewhere and start a new thread with a URL to use to reproduce the problem?
  • The Web of Knowledge translator seems to be on the fritz for me for the last few weeks. Sometimes it will generate the folder icon at the top of a page with a list of citations, and sometimes it won't.

    About 80% of the time it will let me ingest an individual record, but not always. Is anyone else having this problem?
  • Can you take note of URLS where Zotero fails and see if there is anything systematically different between the URLS it fails and succeeds on?
  • edited April 1, 2010
    For instance, under a search in CAB (

    Record 1

    the icon does not appear,

    but when looking at record 5

    it does.

    I have been unable to re-create any searches where the general folder icon will appear, but I did see it earlier this week, so I know that it exists.

    For a demo of this effect see:
  • OK, I think I know what is happening. It would appear that there is no functional WoK translator.

    If you mouse over the article icon on the second one you will see that the DOI translator is the functional translator on these pages. The first item does not have a DOI displayed, this is what Zotero is looking for. The second article does have a DOI displayed.

    I opened a ticket for the WoK translator.
  • Web of Knowledge was working, but the CABI database was not yet supported. We have just added support, and your Zotero software will automatically update within the next 24 hours.
  • edited May 11, 2010
    edited because it was incoherent. Better put below.
  • Just an FYI, i found an old recording of myself demoing it for someone and web of knowledge did work at one time.
  • FYI - Not working with ISI Web of Knowledge again. Works in the CABI, Web of Science interfaces, but not the overall ISI one.

    To a layperson it seems like it may be possible to work on the issue from the big level of getting all ISI Web of Knowledge to have a translator. Or it may be the sub databases involved in my "Search all databases" setup. In the case of my institution: CABI & Web of Science work by themselves, but Zoological Record®, Biological Abstracts, and Food Science and Technology Abstracts do not seem to produce the folder icon.

    The longer I live with it the more annoying it becomes to have to switch to the sub-database and not be able to use ISI - the broadest search with Zotero.

    Thanks for everything!
  • Dear all

    there is again a download problem with ISI


    Any advice welcome
  • edited October 22, 2010
    Thanks again for adding CAB after my problems last time! Unfortunately It seems to be down again

    Also, on a related note, while I imagine this is not an officially supported feature, I used to be able to get WOK to import into Zotero by pretending I was sending it elsewhere as long as the download RIS/Refer files setting was checked in the settings. That work around does not seem to function anymore.
  • I do not know if someone made a change, but CAB appears to be working again, so thanks!
  • I'm not sure if this issue is related to the discussion on this thread, but I'm helping a user who only sees the Zotero capture icon for some records in Web of Knowledge. He sees it in some, but NOT this one, for example:

    Funnell, M. M. (January 01, 2011). Diabetes Self-Management Education: More is Better. Canadian Journal of Diabetes, 35.

    He's running Linux and using Zotero 2.1.6 with Firefox 4.0. The translators are up to date.

    Do you think this is related to the known ISI issues?

    (One example of a record where he DOES see the icon is:
  • The one that does work does so due to the DOI translator that picks up the DOI on that page - I don't think ISI works at the moment.
  • edited May 5, 2011
    ISI support does not yet include all databases, just WOS and CABI. I think we should be able to add more, but I haven't had a chance to do so yet.

    See also, on missing support for BIOSIS.
  • edited August 4, 2011
    Both CABI and ISI WOS (in their new interface) appear to be no longer importing.

    If I download: - I can still use the clipboard wordaround, but both with that - and with reset translators, I can get nothing from either CAB or WOS using regular methods.

    The file icons etc... still appear, but then I get the "check for known translator problems" box. This is not listed however.
  • They don't work for me either now (although they did not long ago!). That's pretty frustrating. I'll take another look and see what I can do.
  • Ok. I have something working, although it still is a little buggy (it saves all of the references in the current search).

    Please go to Web of Knowledge.js and save the file to the translators directory of your Zotero data directory (

    Restart Firefox, and it should start saving from all WoK/ISI databases. Currently, it saves all of the results for your current query-- that'll change soon, but the courageous can try it out now.
  • Tried it. As you said - buggy.

    Doing an All Databases ISI search it actually worked perfectly in most cases - and let me select only certain records etc...

    Although I did get one search with only two results that it gave me a single document response for (the other record was from Zoological Records which is unsupported I believe, although I have been able to get some records from it to work in the past - possibly just because they are also in ISI from other sources as well)

    If I tried to do a search in just WOS or CAB etc... it thought it was on a single document page, even if many documents were listed, and failed to grab even that single document (known errors box).
  • Hey,

    First sorry for my english, i am french.

    On the web site of web of knowledge [v 5.3], for exemple i try to input "big apple". i have 323 results. If i try to save references with zotero, it try saves all of the references in the current search. And it doesn't manage to. Is it possible to save just reference that i want ?

  • Currently Zotero not playing nice with Web of Science, or any of the other Web of Knowledge databases.

    When on a search results page it shows a "single document" icon - then goes to known translator error box if you click on it.

    When on a single document it shows a "folder" icon - then goes to known translator error box if you click on it.

    I have tested this in Web of Science, CABI and Biological Sciences, and MEDLINE.
  • I worked on this a bit more, and should soon have a new version that isn't so completely broken. It may still not work with all databases.
  • Is this fix still relevant?:

    "Ok. I have something working, although it still is a little buggy (it saves all of the references in the current search).

    Please go to and save the file to the translators directory of your Zotero data directory (

    Restart Firefox, and it should start saving from all WoK/ISI databases. Currently, it saves all of the results for your current query-- that'll change soon, but the courageous can try it out now."

    If so - please can you, in layman's terms, explain how to do this (assume I am a complete IT-idiot!) as I cannot work out how to save the file to the translators directory.

    PS The pathfile for Zotero listed here is incorrect for my computer - any ideas?

    Thank you
  • As for finding the data directory:
    The quickest and most reliable way to find your Zotero data directory is through the “Show Data Directory” button in the Advanced tab of your Zotero Preferences window.
    (the site has links that explain where to find those, too).

    Otherwise, tell us what you're trying to do to save the file that's not working and we can give specific help. Giving step-by-step directions without any indication of where you're actually struggling is too time-consuming to be feasible on a largely volunteer run support forum.
Sign In or Register to comment.