Memory leak?

I'm not sure if this is the best place for ?bug reports. The stand alone version was working very well for me under Vista but then suddenly stopped loading and leaving 50-70% continuous processor use with ever increasing memory use until I just had to kill the process using the Task Manager. I suspect this is what is called memory leak (whatever that is!). The problem is consistent and not solved by rebooting and, strangely, it is also happening using the Firefox addin. A separate SA installation on another computer is still working fine so it must be a local issue.

What I haven't yet tried is uninstalling the Firefox addin and reuploading the SA version in case anything has changed. I'll do that asap but comments or suggestions are welcome.

Many thanks, Richard
  • PS Maybe should have added that I'm running under Vista
  • What does "suddenly stopped loading" mean?

    On the Firefox side, are you running Firefox 4.0 and the latest Zotero 2.1 version?
  • Also, it may just be performing a large sync. You can check by temporarily disabling auto-sync in the Sync pane of the Zotero preferences and trying to sync manually. If it's a sync, just give it a few minutes to finish.
  • Thanks for the questions/suggestions. "Suddenly stopped loading" means the program doesn't appear after clicking the EXE file. There is however a zotero process listed in the Task Manager and it is continuously using 50-70% of the processor and ever increasing amounts of memory. I can watch this climb from ~170k to 800k over 30 minutes until I feel obliged to kill the process for fear of bring the whole system down. I don't think it is just synchronising since it doesn't have that much to synchronise.

    I am using Firefox 3.9, I think, but Zotero 2.1 (I had to upgrade for database compatibility). The problem is identical in Firefox and stand alone.

    I can't disable autosync because I don't ever get into the program any more. I hasten to add that all was functioning perfectly for several weeks beforehand.
  • There's no such thing as Firefox 3.9.

    Restart your system, and forget Standalone for the moment. In Firefox, you can access the Zotero preferences to disable auto-sync without opening the Zotero pane via Tools -> Add-ons -> Extensions.
  • Sorry Firefox 3.6.

    I did as suggested - same behaviour. Then I uninstalled Zotero 2.1, rebooted computer and reinstalled into Firefox - same thing. Finally, I wondered if I should restore the database from online - it worked, now back up and running and I haven't lost any data.

    So, it was a database corruption in case anybody else out there runs into the same thing, and not an issue with stand alone.

    Thanks and best wishes to all, Richard
  • Well, there's no way of knowing what it was, really, and we wouldn't advise others to use Restore from Zotero Server without further debugging. It's possible to test for actual database corruption via the Advanced pane of the Zotero preferences.
Sign In or Register to comment.