WebDAV : SSL certificate error connecting

I configured a WebDav : http://seriousgames.lip6.fr/webdav/zotero/
It is my first use of WebDav.

I tested it with cadaver (http://www.webdav.org/cadaver/) and it seems to work.

However I got a "SSL certificate error connecting to seriousgames.lip6.fr. Load your WebDAV URL in your browser for more information." when verifying the webdav server into Zotero preferences.

Have I forgotten something? Any help?
  • Did you select HTTP or HTTPS? If the latter, you need to whitelist the self-signed certificate by loading the URL in Firefox, as the message says.
  • I have the same problem, using a private webdav server. The access is through http and not https. When I put the adress into my browser I perfectly can logIn without any certificate announcement. What does Zotero differant than firefox? Don't zotero access through port 80? Help would be perfect because I run out of storage space and have to find a solution.
  • Don't zotero access through port 80?
    You wouldn't get an SSL certificate message for your WebDAV server unless you have Zotero set to use HTTPS for your WebDAV server.
  • I got exactly the same error. An SSL certificate error when trying to connect to http...

    I just closed the preferences box and open it again and it worked...
  • The whitelisting is impossible in the standalone version, since you cannot open any web pages... Any workarounds?
  • same problem here?

    I'm using zotero 2.0.9 on different computers and I have setup a webdav-synchronisation with the url:

    strange: syncing still works allright from my mac, but when trying to sync from windows (XP or WIN7) i get the SSL certificate error??

    when i copy the above address into firefox and press enter i just get an error

    whats wrong and what can i do?
  • i just wonder if there is a solution to this problem now?

    it still persists with zotero 2.1.5. and firefox 4.0 when using Windows (XP or 7)

    syncing works fine from mac osx, though.
    but when i try to sync from a windows computer i still get the ssl-error message.
    pasting the webdav-url in the browser does not really help
    i submitted an error-report id: 147670598
  • If the error you're getting when you paste the WebDAV URL into Firefox is a self-signed certificate message and you don't understand it, talk to your IT department (or do a Google search). This isn't a Zotero issue, and you should understand the security implications of whitelisting a self-signed certificate.
  • I spent over 9000 hours trying to get a new WebDAV server set up, getting many of the same errors. Even though my WebDAV is not set up as SSL/https:, I was getting SSL errors

    It finally worked when I manually created the /zotero/ subdirectory under my WebDAV root.
  • to @djcrowley. Thank you for your comment. LoL~~ It works well.
Sign In or Register to comment.