FF crashes after upgrading to MacWord Integration 3.1b2

I upgraded to Zotero 2.1 today and I also reinstalled the Python Ext and Zotero MacWord Integration 3.1b2

Zotero seems to work fine, and when I create a word document I am able to select a
citation style and insert a citation like i am used to.

But thats it.
Somehow the macword-integration stops working after inserting the first citation.
I can't insert another situation or add a bibliography, because Firefox just crashed.

After force-quittimg and restarting Firefox I get a message saying: "Zotero MacWord Integration has been successfully installed, but Word must be restarted before it can be used. Please restart Word before continuing."

After restarting Word it works - for two citations. After inserting two citations its the same situation.

What happened? How can I fix this? If there is no fix is there a way to go back to 2.0.9 ?

Thanks for help,


- - - - - - -
System Info:

OS: Mac OSX 10.6.6
FF: Version 3.6.15
Word: Word for Mac 2008
Zotero MacWord Integration 3.1b2
  • edited March 18, 2011
    What version of PythonExt do you have installed in Tools->Add-ons->Extensions?

    Try uninstalling PythonExt, restarting Firefox, verifying that PythonExt is gone, and then reinstalling it from the installation page.
  • it said 2.6.2 etc. and i had installed it from the zotero homepage. I just de-and reinstalled it - to no effect. ff just crashed again after trying to insert the second citation in a word document.
  • I have exactly the same problem. Also have tried all the possible solutions, reintalling pythonext, reintalling word plugin, restarting word, restarting firefox. No effect.

    This problem actually happened in the last version of word plugin occasionally, but this time, it totally stops working.

    word: mac 2011
    firefox: 3.6.15

    I do find one thing that may be a clue. When I install PythonExt 2.6.2 (the one on the install page today), at first, it is said not compatible with the current version of firefox. But after like 5 seconds, it does not say that anymore. Looks weird. I tried several times, always like this.

    Hope this can be fixed quickly. Thanks.
  • OK, this should be fixed in Zotero 2.1.1, now available.
  • It works now. Thanks for so fast response and fixation. cheer
  • it works. great. thanks a lot for the quick fix!
This discussion has been closed.