Issues for alpha standalone v.2.1a

I am very enthusiastic about Zotero standalone and looking forward to the next alpha/beta version. Really appreciate your porting this for non-Firefox users (Chrome user). As a long-time Endnote user, I'm looking to switch to Zotero standalone so I have no prior use of the FF-Zotero plug-in as comparison for features/functionality. Instead I manually added over 100 items of various types to v.2.1a2 to test flexibility and current status of project. I'm using WinXP-SP3 currently, but plan to be on W7-64-bit soon. Here are some functions that don't work or have confounded me as a newbie to Zotero.

1. Import of a Endnote Reference Manager [RIS] file did not work. This was the style sent to me directly two weeks ago as the one in my older version of EN didn't work either. Critical for converters. Assumed it has not yet be implemented?

2. Attach Link to File feature. Can link successfully to both .jpg and .pdf. Can click on the the .pdf file displayed as attached under an item directly. Cannot click on a .jpg for the same functionality. Nothing happens. The only way to get to the item is the show file button link to open the windows explorer folder and select it there. I haven't tried other file types as yet as my research is currently saved as either PDF documents or JPG images.

3. Preference setting for Drag-Drop of attachments. Currently only works for storing copy within Zotero. For those of us who desire to keep all attachments in a single folder to work with other software, it would be wonderful to offer a preference setting to make drag&drop either attached link or attach Zotero stored copy. Endnote and my genealogy program both offer this feature which I use.

4. Preference setting for the path to linked documents. My genealogy software allows me to set a default path for linked documents (e.g., Zotero's attach link to file). This allows to change computers and reset the path as needed within windows to the folder with the linked documents. This has worked well for both the Genealogy software and Endnote with many computer transitions over the years.

5. Attached Linked files icon designation. It would be nice for ease of use to have the appropriate icon for linked files (e.g., PDF, JPG) as is provided in the Zotero stored files. My other software does this. Not essential as I am pleased that I can choose to link, store, have notes, etc. but would be a nice cosmetic feature.

6. Is there any thought to more distinguishable icons for item type in the middle bar display? Currently the icons are colored between white, light blue and dark blue. The palette is neutral and pleasing, however other than the book and document it is hard to easily distinguish (e.g., say the manuscript, webpage, article) quite difficult on a 11.6 laptop display. Unfortunately I don't have specific suggestions that retains the clean neutral color palette.

7. Field across all item types for a local uniqueID. This has been discussed in the forum. It appears that there are at least a key minority that need this field for legacy systems or in my case as this uniqueID across more than one software program (e.g., genealogy) to uniquely identify research items. In intial use of Zotero standalone beta, it has some wonderful new features for managing research notes/data as well as purely bibliographic data which makes it a great tool. I use the uniqueID frequently to sort my research data in Endnote and my genealogy program. Thus, the uniqueID field needs to be displyable and sortable numerically in the middle pane of Zotero. I am currently using the Rights field and using leading zeros (e.g., 0004, 0012, 2770). It displays and sorts in the middle pane. As long as I remember to include the leading zeros and do not exceed 9999 , I have find a workaround.

8. Tags in separate pane. Although tags are not part of the bibligraphic record, it would be much easier to remember and use this feature if the tags were part of the Info pane vs a separate Tags pane, using a feature similar to the Creator field to add more instances as needed. This is an ease of use functionality issue. Perhaps this would intefere with separate tagging of attached notes?

9. Related --- new concept in bib mgmt for me. Very useful. Just learning the power of this feature.

10. Save HTML note as a file. I can drag&drop a linked or stored file to the desktop, which is a new and great timesaver feature for me. However I cannot D&D the HTML notes created within Zotero. In some instances I use the field for a transcription of original difficult to read document (either with a local PDF or no digital copy as the archive would not allow replication from the original). I'm wondering now if the notes field should just be used for brief research notes and any other use be a .htm file that I attach. It appears not all the HTML note creation is working? I click on the HTML button and nothing happens. I would assume I would see the HTML source code?

11. Attached note to item size of pane. I'm finding it difficult to size the right pane for notes on a small 11.6 laptop, particularly because the text of notes does not infinitely wrap to a small narrow width. Or perhaps this is because the text is copy/pasted into the note field?

12. Is or will standalone be compatible with Windows 7 64-bit? Currently using on 32-bit XP-SP3 but plan to switch soon.
  • Continuation of above

    13. HTML link doesn't work in notes. I copied a URL directly from the browser address into the note field and it appears as it should and in blue text but cannot click on it to launch the browser to that website. Nothing happens if you first select text in a note and then click on the link icon, which I would assume should prompt you to add the URL for that text? I stopped experimenting as it appears URL linking is not functioning in notes?
  • Just as a note - only 2) and possibly 1) are specific to the standalone.
    Endnote import is quite problematic because Endnote doesn't follow open specs for RIS _and_ keeps changing what it does so it's hard to tell why this is failing for you without more detail.

    As far as I can see, all other points have been requested and/or asked before and many of them will be implemented at some point (I'm sure for 3-7 and 13) - you'll find a bunch of information if you spend some time searching the forum.
    8) I've never heard and I think many people would disagree - the ability to scroll through items and immediately see tags in the tag tab has been highlighted by many people as very useful - having the tags in a much less readable way in the info pane does not seem to improve usability to me. Easier import of tag lists (e.g. separated by semicolons) has been requested before).
    10) Has multiple layers - I think I've written on part of that in a separate thread.
  • Here is a relatively simple one:

    On the Mac version, the standard "Hide" command is not implemented, either as a menu item (i.e. in Zotero>Hide Zotero), or as the standard keyboard shortcut (command-H).

    This is a relatively small thing, but it is a standard feature of the OS, and an important window-management control, considering the standalone requires switching back and forth with another app (i.e. a browser). It is also a lost feature over Zotero in Firefox (Firefox has all the standard Hide features implemented, so they obviously cover Zotero when it is running).
  • @scottpowell: Thanks for pointing out the hiding issue. Polish like that should be coming.

    @ketchell: Re 64-bit, see Re #10, the HTML button should show the HTML source for the note. If it isn't working, that's a bug and it'll be fixed in a later alpha. I don't know about line-wrapping-- I haven't noticed anything like that on my even tinier netbook.
    Re #6, you can use more interviews and conference papers if you want more color in the pane. Otherwise, I think someone has posted info somewhere on the forum on how to modify the icons, replacing them with something more to your tastes. It's just a matter of swapping out some images in the Zotero directory (or zipped directory).
  • The hide command and HTML view are now in the issue database. Thanks for pointing them out.
  • Thanks for the info about how to change the icons if desired. That solves the icon color/design issue.
  • @ajlyon. Great. Thanks for adding this so quickly. Looking forward to the next standalone release.
  • Just switched to Zotero after not being able to use EndNote, and it's looking great so far! Love the Chrome add-on and the standalone platform.

    Two things though...

    1) If you run a search in Google Scholar and try to add multiple references from the results page, Zotero only adds the first reference multiple times - basically, try to add the first three references (from the pop-up check box menu), and I get the first reference three times.

    2) It would be great if there was some way to add fields to existing records. Or am I missing that? I've got a few references that don't have a date associated, for example, and I can't work out how to add that in.
  • 1) Interesting - give a sample URL, trigger this behavior, and then see if you can report an error ID (from the gears menu)

    2) You should be able to modify fields in the right hand panel/info tab - is that not possible? If so, make a screenshot, upload it to imageshack and post a link here. You can't actually add new fields - but all items should have a date field.
  • No errors reported by either Zotero or Chrome. I just went to Google Scholar, hit the icon in the menu bar, and selected the first (five, for example) citations and imported them. See the following:

    As for 2), I've found a different thread that updated the translator, and it seems to be OK now. But no, there was no blank field for the year. I'm wondering whether it was to do with the translator issue.
  • 1) is a known issue; it's fixed on the trunk and it will be fixed in the next alpha.
  • for 2) you should see the field Date on the right after_ the item imports - regardless of whether a date was imported or not. Along these lines:
    or am I not understanding your issue correctly?
  • GUI thing on the Mac version: lose the horizontal line at top right below the buttons and above the Toolbar. It shouldn't be there (and keeps making me think there's another window just behind Zotero).
  • Importing problem. Error report 742134300. Standalone doesn't import a simple RIS file that the Mac Firefox does fine on:

    TY - JOUR
    N2 - A close study of Lat suffrāgium 'vote, voting' confirms its derivation from the IE root *bhreĝ- 'to break', but also calls into question the previous semantic explanations. The archetype of the primitive popular assembly was that of the warriors. In connection with armed crowds Lat. frăgor is commonly used to denote the sound of clashing weapons (armorum sonus in contrast to the 'shouts', clamor). Thus suffragium would have originally referred to the act of signifying assent at an assembly by fragor, 'clash of weapons' (cf. ON vápnatak).
    AU - Vaahtera, Jyri
    JO - Glotta
    IS - 1/2
    PG - 66
    EP - 80
    SP - Vandenhoeck & Ruprecht (GmbH & Co. KG)
    T1 - The Origin of Latin suffrāgium
    UR -
    VL - 71
    PY - 1993
    ER -
  • Hmm, biggest issue with Zotero standalone is currently that it does not start at all under windows 7, 64 bit.

    I have tried starting the program in a cmd console to see if I get any errors, but none were displayed.

    Anyone else experiencing this?
  • Really, really minor message text correction (did I mention it is minor)

    I'm on a MacBook Pro, running OS X 10.6.4, installing Zotero Standalone 2.1a2.

    I have a pre-beta Firefox Zotero plug-in with the appropriate Data Directory version. I didn't want to update that, but I needed a version of the Data Directory for the Standalone. So I created a new, blank Data Directory.

    After installing the the Standalone Zotero app - including pointing to the new Data Directory - I opened the Preferences tab, went to Sync to do a Restore from Zotero Server reset sync and was notified that Firefox would have to be restarted. I didn't have any instances of Firefox open, so I assumed that the stand-alone version of Zotero is nothing more than a site specific instance of Firefox and that message hadn't been updated. (I did mention this was minor.)

    I have enough non-tech savy colleagues, who have no idea that anything like site specific browsers even exist, that would be confused by a message like that. So, before being called a stable version, I would suggest updating any messages that refer to Firefox so that they more correctly refer to Zotero.
  • Thanks for catching that. Mentions of Firefox are part of the polish improvements that are happening right now. Good eye.
  • @ajlyon - Thanks for putting together such an awesome tool!
  • Oh, I'm glad to help. But it's not me that's doing the core development; I just patch up little things here and there, and post on the forums. Dan and Simon are the main people coding the vast majority of Zotero in all its forms.
  • That's Simon. Dan is Dan Stillman (not to be confused with Dan Cohen, director of the whole project). See and
  • which reminds me that I still think some 'markers' of who is who on the forum would be quite helpful. At least for official Zotero people.
  • @ajlyon - Thank you not only for being a bug/typo squasher, but a fount of organizational knowledge and pointers!
  • The standalone is GREAT. Thank you for developing it. A couple of issues I've found so far running it on a Mac with MS Word 2011 and Safari.

    1) I can't seem to import anything from Google Scholar using the folder icon. I click on the folder, and the check box selection window pops up. I select the appropriate reference and the import dialog box pops open, but remains blank and the reference is not imported. This function works correctly in the Firefox version. PubMed and many medical journal sites are working fine. Just Google Scholar.

    2) I've been having trouble adding multiple citations to the Word document. It seems erratic. I couldn't add more than 6 references at once, but was able to add them 1 at a time after that by editing the citation. Seemed like the whole citation field had to be selected, though, or it wouldn't add the new citation to the others.
Sign In or Register to comment.