Syncing problems (Error ID 404323802, debug ID D1203337790)


I've read a lot of posts today trying to finally figure out what's going on. The one that seems most like my problem might be:

Basically: I've gotten the "empty response from server" error after a long wait trying to sync (an hour or so?). I've tried many times on this computer to sync, and it's only worked a few times; usually, I use a different computer and have no problems. That other computer is a laptop, so I brought it to work (university campus). Differences: work computer is hardwired (OS X), laptop (XP) is wireless. Wireless/laptop synced just fine. So I disconnected the ethernet to the work computer and tried it via wireless... I'm still waiting for something to happen (I did a reset a few days ago, but it never finished, and now I've got nothing in Zotero on my work computer and it's still trying to sync for the first time), but I've got to go away for a few hours so wanted to post this and see if there's anything that those error/debug IDs can report. By the way, I have reinstalled Zotero very recently in an attempt to fix this (and restarted FF etc.) , and I've updated Zotero. But these problems have been ongoing for many weeks (a few months)

Many thanks, and I hope this makes sense!
  • Okay, 2 hours later and still spinning with the message "Getting updated data...".
  • You have a queued download. Currently, it could take a while. Don't restart Firefox.

    If you get the "Empty response from server" after that, it's likely a problem with your network, proxy server, etc. In most cases when people report this and we look into it, the Zotero server is properly returning a (large) response that's getting lost by the network.
  • And don't use the reset options for troubleshooting—they make things worse.
  • Thank you, Dan. I'm happy to be patient with the new rollout -- I didn't catch that when I decided I'd troubleshoot this now, sorry! Anyway, I'll wait and see what happens. This would be the second "Empty..." message today. I'm able to let it go for another two hours, after which I'll need to shut down.

    Depending on what happens, should I:
    1. Wait for the new rollout, or
    2. Trouble shoot with my local network folks?

  • Okay, now been spinning for over four hours. Should I wait for the upgrade or troubleshoot? Thanks.
  • There's nothing to troubleshoot.
  • Understood, so I'll wait.

    I've reconfigured my work computer to connect via the unsecured wireless network, logged in as a guest. I still cannot sync; it's been running for a bout three hours now, with no change. (Via that same network, I was able to sync my personal computer.) So I imagine it's something on my computer more than my network -- but it could be a combination.

    Anyway, looking forward to the new database rollout. Thank you.
  • Dan,

    Unfortunately, the upgrade seems not to have helped. My network is probably blocking something that must be opened -- and I learned that they did a network upgrade in the fall (which also blocked my ethernet printing and some other networking things). I've talked with the network folks, and they wanted me to ask: what specific port, protocol, and/or network parameters are necessary to adjust for inbound and outbound settings so that the data doesn't get lost?

    I've tried having a number of my students start using Zotero, but they too are having problems when on campus, so it definitely seems to be a local issue.

    Thanks for any help you could provide.
  • The upgrade is still ongoing. The switchover last weekend moved the data servers to the Amazon cloud. We're still in the process of transferring all user libraries into the new architecture.

    You have a queued download from 40 minutes ago. What happened then? Did you restart Firefox?
  • Thanks for the quick response, Dan.

    I've not restarted Ff or done anything -- it's still queued, still spinning, still saying "Getting updated data..." I'll be in the office for another 30 minutes, but I can leave the computer on over night if necessary...
  • I'm pleased (no ecstatic!) to report that my work computer on the campus network synced for the first time in months today. And it did it in less than 30 minutes (not sure of the exact time because I just assumed it'd keep going and didn't watch!). Looks like whatever server update happened finally made it work. Let's hope it keeps working. THANKS! Aaron
Sign In or Register to comment.