pages not recognized anymore after update to 2.1b4


I was using 2.1b2, and some sites (e.g. springerlink, wiley) would show the icon which allows taking a page into zotero. When hovering over it, it indicated that it wanted to use the generic DOI translator, which has been broken. Now, after updating to 2.1b4, the icon is gone, so the page seems to not be recognized at all anymore as containing literature.
Anyone else experiencing this?
I read that the DOI translator was supposed to be fixed in 2.1b3, so maybe it also has to do with the translator? Other pages with specific translators are fine (e.g. highwire2.0, PLoS).
  • Can you provide a specific URL for a page that should show an icon?
  • I should have thought of that, sorry. For example:

    It seems to me that those sites are affected that usually would have been handled by the DOI translator.
  • Out of curiousity - do you see a translator symbol for this page now?
    (2.0.9 is picking up the DOI of th wiley article).
  • no, it's not there. I tried updating the translators, but they are "up to date" in preferences.
  • edited January 25, 2011
    I am having the same problems with Springerlink and Wiley sites as mentioned above. No 'save to Zotero' symbol in the navigation bar) a and when using the standard option on their pages to download the citations information you can only save it as text file to your disk, no option to import it directly in your Zotero database.

    Note that for example that with PLOS the symbol in the navigation bar is present and works. However, using the download citation option on their page gives the same problem, you can save the citation as text file, but it is not imported directly in the database as it used to be done.

    Same for Google scholar: using the icon in the location bar works (citation is imported in my Zotero database), clicking on the 'Import into Endnote' option which shows under each link (could be different depending on your settings in Google Scholar) does only offer the option to download the citation as text file.

    Not sure it is related, but I tried as an alternative to copy the text (ris or bibtex) and use the 'import from clipboard' and that didn't work either (nothing happens at all).

    I am using Zotero 2.1b4 and Firefox 3.6.13 on Ubuntu 10.10
  • There are still import issues that are set to be fixed in the next 2.1 beta. That beta should be soon.
  • this error is fixed with 2.1b5
    many thanks!
Sign In or Register to comment.