Can't access "My Library" online<username>/items has been timing out for the last couple of days. Is the server down for maintenance?

  • No, it isn't.
  • thanks- so who do I contact to get this checked out? I want to know that my online backup is ok.

  • Try now and please report to us exactly what you're seeing.
  • I get the following message:

    "There was a problem fetching the items in this library. Please try again in a few minutes."

    Got the same message after a few minutes. Yesterday and this morning, the page just timed out (no server response) so I guess this is a good start.

  • I have tried resetting the online library using the "restore to zotero server" option. The first time it wiped out my online store since the page reported that "no items" were in my library.

    The second time I reset the sync arrow was rotating for 10 minutes so I assume it succesfully uploaded. However when I goto my library I still cannot access it- it just takes a long time to load and then returns a blank page.

    Can you offer any advice?

  • I am having the same problem. It reads, "Error fetching groups. Please try again in a few minutes." Is there any way to fix this?

  • And, we really need to be able to post our information for a collaboration project!

  • Is anyone still having this problem now?
  • No. It works now! Thanks so much!
  • still not working. can anyone offer any advice?
  • @johntang
    I'm guessing this is because you have a very large number of collections. With more than 100 collections/subcollections the page has to make extra api calls.
    Are you seeing a blank page or a message about an error loading collections/items?
    We're still sorting out a couple of issues with the new server setup that could cause a blank page with no error feedback, but that should be rare. Do you consistently get a blank page, or do you get error messages?
  • In firefox 99% of the time I get a blank page. the other 1% i get an error but I can't remember what it says- will post it if I see it again.

    in chromeI always get:

    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    which i think is the equivalent to blank page in firefox.

    not sure how else I can help with diagnostics.

  • okay thanks, I'll look into this.
  • I'm still having this problem. Consistently there is a blank page when I click on My Library. I have about 50-60 collections/subcollections in my library, additional in my group libraries.
  • @clousley
    there is something about your collections that is consistently causing an error with our api, so your collections won't load until we figure out what the issue is with that. Now that the server transition is basically complete I'm going to be tweaking some things with the web server to try to avoid these blank pages with no feedback. I believe you should be able to load your library page to at least see your most recent items now.
  • Give it a try now.
  • It still isn't working for me. I just see a blank screen.
  • @areteichi
    try now
  • actually now I see that your library is public, so I can let you know.
  • okay, it will not load your collections but it should load your most recent items now. We'll keep working on improving this and hopefully we'll be able to load libraries with many more collections in the near future.
  • Yeah, I can now access it! I don't see the collections but I do see the items at least :)
    Hope you guys will continue to look into the issue! Thanks!
  • If you want another library to trouble shoot check mine. I had a thread on this a long time ago. My collections still have problems loading. Error loading collection or blank page or sometimes a page will load. I have lots of sub collections and items in them. The group page comes up fine and is public.

  • Report ID: 2084914590

    Had not problems so far. Today I log in Zotero with Firefox 3.6.15, and my library appears blank. I have checked my Firefox data directory, and it appears correct - as it is the information I am using to log in. I cannot see my groups either (I actually logged in because I wanted to add a person to one of my groups). When I try to sync, I get an invalid response from the server (cannot find user or something like that).
  • Report ID: 2050587570

    When I try to sync the chromel I get the following error: Invalid response from server. Please try again in a few minutes.

    Also, when I try to view my library via Firefox nothing shows up. If I keep clicking on "My Library" occasionally my references will appear.
  • spujr - that sounds like some version of server overload - be patient.
  • Temporary issue on the Zotero server end. Hang tight.
  • Hey,

    I still have the same problem with one the group libraries "ioew" I admin. 5 days ago I uploaded a subcollection with about 2000 items. Some of these appears as recently uploaded in the group library, but none of them in the subcollection. Instead, there is the same "fetching group" error message and the commendation to wait some minutes. I thought that this is due to the sync queue, but nothing changed about this during the last days. As I tried to upload another collection of similar size 3 days ago it may have contributed to this problem. What do you think? Is it better to upload larger libraries step by step and with pieces of which size? Is it possible anyway to clear the sync queue for a new trial?
  • Online display of libraries has nothing to do with the sync queue (which is empty these days anyway). But there may still be issues with very large libraries or (more likely) with unusual distributions of objects.
  • I am a new user of Zotero. I started my collection on my workstation at work and planned to access it on my home computer. I thought it was a new user issue on my part that I couldn't access my collection at home. Is there someone I can connect with to find out if it is a basic misunderstanding of the system on my part?
Sign In or Register to comment.