can not enable in openoffice

Hi, I spent the last few hours trying to find a solution for this, but now I'm exhausted.

First, I had a hard time installing the zotero plugin for openoffice from the original zipfile. The zipfile only contains one file (.oxt), but it could not install properly. After reading advice from srk (, I unzipped the .oxt file from the zip file, and pointed my Extension manager to just the .oxt file. Problem (partially) solved.

Now, the problem is that every time I try to insert a reference from Zotero into OOo (or do anything related with the plugin), an error window pops up:"An error occurred communicating with Zotero. Please ensure Firefox is open and try again".

This problem was similar to the one mentioned by pvb-zotero (
but no solutions were posted.

In my computer, I noticed that all the components of the zotero extension was enabled, EXCEPT '' (it was shown as ' Disabled'). I can not enable it. I can enable all the other components.

I am running OpenOffice 2.3.0, Firefox, and the zotero plugin 1.0a4

I really really really want to use this plugin, so please help!


  • Hi Nia,

    Indeed I have exactly the same problem as you described. I already sent this infomation directly to Zotero support, so hopefully they'll come with a solution. If you find any solution in the meantime, please post it here.

  • Hi, having the same problem I reinstalled OO 2.3. During custom installation I enabled Python UNO-bridge. And it works!

  • I have the same problem, but a custom install to enable the Python UNO-Bridge didn't fix it for me. Did this fix it for everyone else?

  • Hi Niania and others,

    The above mentioned solution, reinstalling OO2.3 didn't work for me. However, I finally found the solution to the problem. As it turned out, the problem was that another program (ArcGIS) had set an system variable with path to python that came with that program. Removing that system variable solved the problem (in case it matters, I have Windows XP, SP2, latest Zotero and OOo plugin, python 2.5).

    To check if a path has been defined by another program, open a 'Command Prompt' window and type in the command 'SET'. Look in the list for something like:

    Pythonpath=c:\program files\arcgis\bin

    where the path will probably be different (unless you also have installed ArcGis).

    If there is a system variable 'pythonpath' defined, you can remove it as follows:

    Right click on 'My Computer' and click properties --> Advanced --> Environmental variables. In the box with system variables look for the pythonpath variable and delete it (you may want to write down the variable name and path in case you need to restore it).

    As last step, go to extension manager in OpenOffice and enable Zotero. This time you shouldn't get an error message any more and the plugin should work fine.

    Hope this helps.
  • Thanks! This is quite useful. Does anybody know of a workaround to have Zotero / OOo use an alternative python path? I'm trying to use Zotero and OOo portable in a computer lab which also has ArcGIS set the python path. Unfortunately, I don't have admin control (nor should I) to change system variables.
Sign In or Register to comment.