OpenOffice extension not working


I have the latest Zotero with Firefox under Linux (Opensuse 10.2) installed. I also installed the OpenOffice extension and i can't seem to make it work. I use OpenOffice 2.3.0 but I also tried 1.0.4 and 2.2 with no luck. I use the Novell Edition with the python stuff installed (e.g. bibus using a python bridge is working fine...)

When I try to insert a citation, I get the following error message:

BASIC runtime Error,
An error occurred
Type: Unknown
Message: python-loader:<type 'exceptions.ImportError'> No module named
pythonloader, traceback follows
no traceback available.

At the same time a Macro window pops up and the following line is highlighted:

oZoteroRPC = createUnoService("")

The file edited is "[My Macros & Dialogs].Zotero

Should I try a stock OO version? I would rather stick with the Novell edition. Is anybody able to use the extension with the OO version from Novell?

Any help would be appreciated.

Cheers Juergen
  • Have the same problem with the latest Firefox, latest Zotero and latest plugin. No clue how to fix it, help! :-)
  • Hi, I'd think your best bet would be to try installing the standard package for OOo to see if that makes any difference.

    I understand that the Novell version of OOo is modified, so maybe one of the modifications is responsible for the error you're seeing. That's just a guess, and a guess that does not respond to the particular error message you report, but if it were me, I'd try the standard OOo package.
  • Hi!

    I took the plunge and erased the Novel installation of OO and grabbed the brand new 2.3 released stock version from I did install that version completely (all rpm that come with including the python package) and it started fine. I went to the extension manager and tried to install the zotero extension which failed all the way to the end, resulting in this error message:

    ( { { Message = "python-
    Ioader:exceptions.ImportError: No mdule named pythonIoader, traceback
    follows\X000ano traceback available", Context =
    ( @0}}

    So the stock version doesn't work as well, at least on Linux that is.

    Cheers Juergen
  • edited September 20, 2007
    The Zotero extension works just fine with OOo 2.3 on Gentoo Linux, however. This is with a self-compiled version rather than with a stock OOo package.

    It looks to me like there there is a typo in the error message. In any case, on my system there is a series of files named "pythonloader" in the openoffice application directory, and none named "pythonIoader". See how there's an "I" rather than an "l" in the error message?

    I'm supposing that you just pasted in the error message from a terminal (or maybe ~/.xsession-errors), is that right?

    I'm not familiar enough with OOo to know what is looking for and not finding the pythonloader module. But I'm inclined to think that it's an OOo/python rather than a Zotero problem. To test this idea, you could try installing another extension to see if you get the same error. You can find some OOo extensions here:
  • Also not working with latest OOo-2.2.1 on Mandriva 2008.
    Error is different. It seems to find the python-loader but it does not find the module named 'os'.
  • See
  • I have this problem also, using OO 2.3.0 on Linux. Other OO extensions are fine.
  • Did anyone in this thread with this problem fix it or find a workaround?
  • I'm having a similar problem, running OO 2.3 under Windows 2000. When I click any of the Zotero add-in buttons, I get the error message "This property is read only." The offending line of code is:

    Mid(fnRemoveString, nTagStart, nEnd - nTagStart + 1, "")

    I'm running OO 2.2 under OpenSUSE on a couple of other systems and it works fine.
  • I have the same problem as dbrunell: on windows xp, zotero rc5. After updating zotero, the plugin was broken, so i updated to the latest. I opted for the automatic install, it told me it was the same version ('0') and I installed anyway. Now I get the 'this property is read only' error.
  • Same problems, maybe not same reasons?
    I run OpenOffice 2.3 under Win XP SP2, Firefox and Zotero RC5, i.e. all are the latest versions. When I try to import a citation into my text I get the error message :
    "This version of the Word plugin is incompatible with the installed version of the Zotero FF extension. Ensure you are using the latest versions of both components."

    Now, what ?

    BTW: Word?? Is this only the result of economic writing of an error message for the OOo plugin, or is there really a mixture of Word & OOo plugins ??
  • My Win2K setup mysteriously started working. No more "Read only" error. However, I just updated Zotero on the OpenSUSE 10.2 setup at the office and am having the problem there now. Strange.

    ftr, you may want to try updating the plug-in also. You have to download it separately.
  • Fixed it. Here's what you do. When you get the "read only" error, a window will pop up with the following line of bad code highlighted:

    Mid(fnRemoveString, nTagStart, nEnd - nTagStart + 1, "")

    There are two things wrong with this statement. First, a function name is being passed as an argument to a string function. Second, the assignment operator is missing and there is an extra argument to the Mid function. If you look a few lines up in the code, you will see the intended statement (commented out):

    Mid(sSearchString, nTagStart, nEnd - nTagStart + 1) = ""

    Just move this statement down and replace the erroneous one with it. Be sure to remove the leading apostrophe (comment prefix).

    Maybe the developers can update the plug-in available for download.
  • Great work dbrunell! It works on my machine now (windows xp sp2, openoffice 2.3, forefox

  • Bravo! Fixed the problem using the NeoOffice 1.0b1 extension on my mac.
  • May be unrelated to this, but I am no longer able to insert any reference in my OOo, as I get an error:

    If Right(sResultText, 1) = "." And LCase(sResultText) <> "ibid." Then

    OOo 2.3.0 on Debian, zot 1.0.1
  • This happens also after having disinstalled the zot OOo extension and reinstalled it.
  • Just updated Zotero and the OO extension and I've encountered a couple of problems.
    1/ Mid(fnRemoveString, nTagStart, nEnd - nTagStart + 1, "")
    This one was fixable as per the instructions above, but I thought I'd better mention it as its odd that the correct statement is still sitting as a comment a couple of line above the problem statement.

    2/ If I try to change the citation style I get a different runtime error message: this object is invalid
    This is the line that gets highlighted:
    oRange.text.insertTextContent(oRange, oField, true)

    I'm, so far, only having this problem with one old document - so might it be a dodgy reference that I need to track down?

    Regards, Jon.
  • I am also getting the pythonloader error:

    ( {{Message = "python-loader:exceptions.ImportError: No module named pythonloader, traceback follows\X000ano traceback available", Context = ( @0}}

    I'm using OO3 and Zotero 1.0.7. I have tried the OO plugin version 1.03b and the latest beta version from cvs and both give the same error. Help!
Sign In or Register to comment.