JSTOR translator is broken completely

Due to a recent site re-design.
Ticket created here:

Until this is fixed the recommended work-around is to use
Export Citation --> RIS (Endnote, ProCite, Reference Manager)
  • edited August 22, 2010
    I've checked a fixed version into the Zotero repository. It will hopefully be pushed to all users soon; in the meantime you can go to https://www.zotero.org/trac/browser/extension/trunk/translators/JSTOR.js?format=txt and save the file in the translators directory of your Zotero data directory.
  • Apologies -- that version does fix most of the problem, but it still botches PDF downloading. I'll look at fixing that as well.
  • The version at the address above now works for PDF downloading as well.
  • The updated translator has been pushed to clients. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.

    Thanks to ajlyon for the quick fix.
  • Wow! I am relieved to know that it wasn't user error and impressed that you fixed it so quickly. I've downloaded all my citations. Thanks.
  • I'm still having the problem, or at least part of the problem, reported in the ticket above (https://www.zotero.org/trac/ticket/1715). For the individual article cited there, or any other for which I do have full-text access, Zotero gives me a citation for American Economic Review, 1926. For a list though (the example given, or others), I get no citation, just an error pointing to known translator issues.

    So, part of my problem is that my workplace restricts which software I can use (please don't tell me to update; I can't.) I have Firefox 5.3.2 in a locked down mode where I must specify individual third-party cookies--JSTOR is specified, and worked previously, and works incorrectly for the single article without generating an error. I have Zotero 1.0.10.

    I have clicked on "Update Now" next to translators in Preferences repeatedly, and it tells me I'm up to date. Is it possible that the translators are not actually updating? How could I check? Are there good instructions for updating the translator file manually? (I may be missing something, but I don't see a "translators" directory in my Zotero profile.)

    Any help on fixing this would be much appreciated!

  • Susan - this sounds like the translator isn't updating or it isn't working correctly with Zotero 1.0.10 -
    Zotero 1.0 isn't supported anymore, so if you don't want to/can't update to 2.0 you're pretty much on your own. There is no translator folder in 1.0.
    Sorry, but there are very limited capacities and supporting versions that have been outdated for almost a year now is just beyond what is possible here.
  • Yes, Zotero 1.0 no longer receives translator updates, and applying them manually in 1.0 is non-trivial.
  • Hi, Dan, but is it possible? I am the point-person for Zotero at a large research-oriented institution with possibly arcane computer security concerns and there will be no update to 2.0 anytime soon. Meanwhile, many of us have come to rely on this tool, and we do at least have Notepad at our disposal.
  • Translators in Zotero 1.0 are stored in the SQLite database. Someone with moderate technical skills would be able to update it from the current version, but we can't provide support for this.
  • Ok, I'm looking at the older documentation about creating translators (http://www.zotero.org/support/dev/creating_translators_for_sites) so just confirm one additional complicationfor me. Assuming I/we can edit the SQLite db based on info in the JS version linked above, we would have to manually edit each db on each computer where someone wanted JSTOR (or any other broken translator) to work for them?

    (Sadly, a lot of the documentation doesn't say which version(s) of Zotero it applies to. An added confusion if we try to do this.)


  • edited August 31, 2010
    Assuming I/we can edit the SQLite db based on info in the JS version linked above, we would have to manually edit each db on each computer where someone wanted JSTOR (or any other broken translator) to work for them?
    yes, that's correct.

    The translator part of the documentation is not in terribly good conditions, that's true.
    In its defense - usually the only people who actually need to know any of this are people actually developing translators and that part is actually being improved

    Oh and google "Mordac The Preventer of Information Services" and send a couple of links to your IT people.

    edit: Wait - is this the LoC? That adds a whole new layer.
  • It may be easiest to install Scaffold 1.0 (a Firefox add-on, hopefully allowed by your security policies) on each computer and copy-and-paste the updated translator into each client. Scaffold is the only easy way to update and edit translators in the 1.0.x series of Zotero releases.

    It is possible that some future translator versions will use features that are not supported in Zotero 1.0.x, so it would be good to get the ball rolling with the computer security personnel on moving to slightly newer versions of Firefox and Zotero. If the security people don't like the syncing in Zotero 2.0, that could probably be disabled in a special build of the add-on (that you'd have to create and deploy yourselves, but it might not be that hard to create, especially with some advice from the devs).
  • edited September 1, 2010
    I would note that JSTOR should still works with Zotero 1.0.10, just not through the icons in the location bar.

    Just use JSTOR's export citation function, which their new site design makes easier than ever to use.

    With just a click or two more you can use the "export citation" link for any JSTOR article, or list of articles, to add them to Zotero. Zotero just intercepts the RIS file and imports the items.
  • Thank you, everyone, for the advice--we'll eventually figure something out and/or graduate to 2.x (in time for the 3.x release, no doubt).

    And especially thanks to Trevor for explaining that workaround to me! When I saw the more shorthand version up at the top I assumed that "export citation" was a feature of Zotero 2.x that I didn't have... but yes, it works! I'll share around that information immediately.

    I would suggest a bit more info somewhere on the Zotero site about the status of 1.0.10--right now there's a download from the front page, but not real info on what that does or doesn't get you in terms of support, or features for that matter. I'm not finding anything else obvious under FAQs or documentation, either. Is there a version release date history somewhere, or info on what is/was supported? I realize the desirable situation is that everyone always have the most updated version of the browser and Zotero, but reality doesn't allow that. (Yes, I still have IE6 on my computer at work, too.)

  • edited September 1, 2010
    I would suggest a bit more info somewhere on the Zotero site about the status of 1.0.10--right now there's a download from the front page, but not real info on what that does or doesn't get you in terms of support, or features for that matter. I
    that's a very good point. I don't think there needs to be a link to 1.0.10, but if there is it should most definitely say clearly that it's no longer supported.

    edit: changelog is here: http://www.zotero.org/support/changelog
  • I just started using zotero today and can't seem to load JSTOR (at all) when using zotero (can't even get far enough to save the citation). Any suggestions? when will JSTOR be fully supported?

  • Susan: I don't really know what that means, but see Proxy Troubleshooting, and start a new thread if you still have trouble.
  • Recognition of JSTOR items did not work for me, either. I had the following JSTOR-related proxy settings in Zotero:



    After deleting these, Zotero recognizes JSTOR items again. What I find in Zotero settings now, is this proxy value:


    Dan, these proxy URIs change due to internal Penn library changes, right? What should a user do in such a case? Should we, as I did, find the offending proxies and delete them by hand?

    Thanks, mutlu
  • in general yes - although this seems like a mess: Does UPenn assign you a new ID - the 4 digit number - for every session? I'm not sure how Zotero would/could handle that.
  • Note that these aren't IDs, but rather port numbers. Regardless, it sounds like UPenn needs to think about reducing the complexity of their proxy system--- I don't see why the port needs to change randomly.

    If the correct port number is unpredictable, there's no way Zotero can know it and use the correct one.
  • Thanks for your answer. No, thankfully the ports don't change with every session. But they do change once a while, maybe once a year. Thus far, I have wiped the entirety of Zotero's proxy settings twice due to massive changes. Surely, this is about some kind of internal reorganization at Penn, but might throw off users who do not know why it does not work.
  • I think you can just adjust them by hand instead of wiping them entirely. But if that's sufficiently rare that's not such a big deal.
  • Sorry to resurrect but...

    JSTOR import seems broken for me at the University of Toronto.

    The library here is generating a link like so: http://www.jstor.org/sici?origin=sfx:sfx&amp;sici=0003-1224(198202)47:1<114:TCOIMS>2.0.CO;2-D

    If I go to the article's "stable URL" here: http://www.jstor.org/stable/2095046 it gets recognized properly by Zotero.

    Any clue how to fix this (other than having to go to the stable URL for all my JSTOR-sourced things, which is frustrating since JSTOR doesn't make the stable URL hyperlinked *sigh*)
  • When I click on a link like yours, I'm automatically redirected to /pss/2095046 or /stable/2095046, depending on whether I have access to JSTOR. Zotero correctly detects saves from both. Not sure why you aren't being redirected.
  • @ajlyon: wish that was happening to me... I tried a different browser and still no redirect.
Sign In or Register to comment.