Getting Word Processor Integration to work in Linux -- Java plug-in problem, component unreachable

In the last day, I had to get Zotero's word processing integration to work on two computers with Ubuntu Karmic. After reading enough of these forum posts, I was able to get the integration working just fine. Problem is that most users aren't going to have the patience or technical skills. Zotero is a terrific piece of software that people should be using. At a minimum, please put the following information, which was crucial for my efforts, on a support page. Better still, Zotero installation should handle this or tell the user what to do.

#Make sure the java plug-in is actually turned on in Firefox add-ons > plug-ins
#zotero only works w/ sun java 6; install jre and plugin.
#go to word processor integration plugin preferences in Firefox add-ons and tell it to reinstall openoffice components
#Issue the following in a terminal window and tell it to use sun java 6 as the default:
sudo update-alternatives --config java
#Issue this to tell it to use sun java 6 plugin:
sudo update-alternatives --config
  • This is all already on the troubleshooting page.
  • Yes, I saw the troubleshooting page, but didn't fix my two problem computers till I had tried odds and ends from the forums. Might be something I missed, but: The --config java isn't on the troubleshooting page (is it really necessary? I don't know, but I used it and eventually things worked.). Also, it may be helpful to mention how to activate the sun plug-in in the new Firefox. Mine was turned off--possibly because I was being cautious and had Java checked ''off' in the older version of Firefox in which the Java on / off switch was prominently visible in the preferences. In the new version, it's not in an obvious place.
Sign In or Register to comment.