Word 2010 zotero plugin problems

I'm using Word 2010 and the Zotero 2.0 plugin is having trouble recognizing zotero in the Firefox browser (asks if it is open). Any suggestions?
  • In other words, you're getting the message "An error occurred communicating with Zotero. Please ensure Firefox is open and try again."? (Please include exact error messages when reporting problems.)

    As far as I know the plugin has not been tested in Word 2010, and I don't know if anyone is using it successfully, but you can try the usual troubleshooting steps.
  • edited August 3, 2009
    I'm using Zotero plug-in with word 2010 nicely with newly created documents. The only problem I'm having is with documents coming from older versions of MS Word. When I try to add a new reference for example I get an error window saying :"Microsoft Visual Basic; Run-time error '13': Type mismatch"
  • Please have a look at the last entries in the discussion "Microsoft word: Runtime error '13' when pres ..." This could solve your problem
  • The problem I am having is that I have to re-install Zotero each time I re-open Word.
  • I keep getting the error message that the macro cannot be found or has been disabled because of your macro security setting. I followed the help to enable macro and assure the path to the template, but cannot make it work. Any help will be greatly appreciated.
  • I was able to download the plugin for Word 2010 and it appears as a tab in Word, but when I try to add a citation/reference, or use any of the Zotero features for that matter, I get a "Zotero Integration Error" that says "Zotero experienced an error updating your document." Any idea what might be causing this problem?
  • so is this still unsolved?
    I'm considering 2010 for my next collaboration, but not without zotero :)
  • I'm also using Word 2010 and I've used Zotero before in Word 2007 without problems, but now after I've installed Word 2010 I see nothing in Word - there aint no plugin in Word, although I've reinstall as explained in the usual troubleshooting steps. What can I do?
  • Same problem as HrFrom. Nothing appears in Word 2010.
  • I'm using the Finnish version of Word 2010 and the newest Zotero version downloaded one week ago. I have not been able to install the Zotero plug in Word. I've tried to install it repeateadly and I've used all the advice I found from your pages. What should i do?
  • helenelaurent, do you get an error message installing, do you not see anything in Word, or does the plug-in not work?

    If you see an error message stating that the plug-in could not be installed, we can almost certainly help you if you provide a report ID.

    If you don't see anything in Word with the plug-in installed, find the Word startup folder (follow the steps under Q3 here) and check whether there is a file named Zotero.dot there. If not, you may need to copy the file from the default startup folder location, which is also described on that page.

    If the Word plug-in shows up but you see an error message stating that "Zotero experienced an error updating your document," you should try following these steps.
  • I don't see anything in word and the plug in does not work. I'm sorry, but the page you gave (If you don't see anything in Word with the plug-in installed, find the Word startup folder (follow the steps under Q3 here) ) gives advice only to Word 2003. Maybe there's and page in English that I could use? I haven't found the Word startup folder, so I don't know whether the Zotero file is there.
    This is so complicated......
  • These instructions should be better. Follow the procedures for Word 2007; they should be the same.
  • I'm using Word 2010, and like with other users after installing the Zotero WinWord-Add-In nothing seems to happen. I managed to get the Add-In running by manually installing it with the "Options/Add-Ins" menu directly in Word. I don't have the English Version of Word, so I had to guess the English menu titles for this comment, but here's how I did it: Click the Microsoft Office Button, and then click Word Options. Choose "Add-Ins". Now you should see a List of all activated and deactivated Add-Ins. In my case, Zotero did not appear anywhere here. At the bottom of the dialogue is a drop down menu. Choose "Word-Add-Ins" and confirm. A new dialoque should open ("Templates and Add-Ins" or something like that). On the right side is a button called "add template" or similar. Click this button and you'll get a new window where you can choose a Template or Add-In to install in Word. Choose the "Zotero.dot" file (see Simons link with the instructions where to find it). Restart Word and you should get a new tab called "Add-Ins" with the Zotero buttons.

    I'm sorry for the imprecise instructions. Perhaps someone with the English version could provide the specific menu titles and buttons?
  • Thank you Stefan! I had the same problem, and your instructions worked perfectly.
  • I'm having the same problem as shannon.jones. Have you figured out a way to get around this yet? I've reinstalled the plug-ins, but it doesn't seem to do any good.
  • I just uninstalled the click-to-run and then, when prompted to log in in the next window with my address and password, it doesn't recognize me. Now I have uninstalled the click-to-run without being able to install the MSI-based edition. Any counsel?
  • hi,
    i have Word 2010, i see Zotero in Word but when i click to add a citation nothing happens.
  • Hi. I finally succeeded in installing plug-in for Word 2010 but I do not see a tab or menus or anything like that. Details:
    - Windows 7 professional 64-bit
    - I have installed Zotero Standalone and have been using that primarily, but also have installed plug-ins for Chrome (my main browser) and Firefox (which I have been using also, just to be sure I am doing it right); and I installed the Word plug-in (details below); all plug-ins are latest available
    - MS Office Professional Plus 2010, up to date (v.14.0.6something, 32-bit)
    - have a few other add-ins installed, including ReferenceManager (which I use to get BibTex citations into Word's own source manager)
    - when I go to File\Options\Add-Ins through the Word menus I see Zotero.dot under Active Application Add-Ins, listed as being in the Word\STARTUP directory
    - if I look for Zotero.dot in Windows Explorer I see that it is truly in the Word\STARTUP directory (i.e., the listing above is correct)
    - But nothing shows when I am in a Word document - no Zotero tabs or menus
    - I have tried removing Zotero.dot, exiting Word, then adding it back, exiting Word, going back into Word, etc. -- it shows in the Add-In manager, but again, no tabs or menus for Zotero

    Any advice?

    BTW, I had a heck of a time getting the Word plug-in installed because of error messages reporting conflict with OpenOffice. Through a series of steps I can't quite remember, it finally installed properly (except for not working). Those steps included: uninstalling OpenOffice, uninstalling and reinstalling Zotero Standalone, and installing the Word plug-in through the Firefox browser.

    Anyway, if someone can help me get the seemingly properly installed Word plug-in to work (since it does show as being installed) I will be eternally grateful.


  • donboyd5, do you have an "Add-ins" tab in the Word 2010 ribbon? If Zotero.dot shows up under add-ins, the Zotero buttons should really be there.
  • Hi, thanks. No, I didn't but this was enough of a clue to figure it out. For the benefit of others who may have the same problem:

    I didn't really understand the ribbon before. On my system Word did not show an add-in tab at all and I couldn't find a way to make it show, so I did some Googling. It turns out that one of the problems in Word 2010 is that certain "COM" (?) add-ins will make the add-in tab disappear (see http://social.msdn.microsoft.com/Forums/en-US/worddev/thread/f5a83201-6799-43d8-b354-f9259482d98a/). So what I did was uncheck ALL of the COM add-ins I had, exit Word and restart it, and there like magic was the add-ins tab (which I had NEVER seen before), with the Zotero menu showing.

    So the Zotero issue is fixed. I now need to go back and check the COM add-ins one by one until I find the offending one and I guess I'll have to live without it unless I can find some sort of fix.


  • For what it's worth, I did the follow-up steps I mentioned, and ReferenceManager, which I recently installed, turned out to be the offending COM add-in. It allowed me to import BibTex citations into Word's source manager. So I've got it disabled now. It looks like in any given session of using Word, I can either have the Add-ins tab, or Reference Manager, but not both. I'll choose the former.
This discussion has been closed.