Openoffice extension - no connection with firefox

I installed both the MS Word and Openoffice extensions. The word extension works fine. But when I try to insert an citation in an Openoffice document I get the message:

"An error occurred communicating with Zotero. Please ensure that Firefox is open en try again".

However, even when Firefox is open (btw I didn't need to do that in the first place when using with Word), I get the same message.

p.s. I have my Zotero db in a custom location, but even when I moved the default location, the same error happened.

I am using Zotero 1 rc3, OpenOffice 2.2.1 on Windows XP.


  • Bump, I get the same error. Anyone got some ideas on how to troubleshoot?
  • I, too, have this error. What is causing it?

    Just a side comment: wouldn't it be nice if Zotero could just open in OpenOffice? Firefox is such a resource drain, I'm starting to get annoyed at having to open if everytime I want to use Zotero.
  • Just a side comment: wouldn't it be nice if Zotero could just open in OpenOffice?
    I doubt this will be possible, since the Zotero database relies on Firefox's sqlite backend.

    Maybe a future version of the OOo bibliography tool will be able use the Zotero data directly, though. You might want to check out the OOo bibliographic project:
  • At some point, we may be able to run a standalone Zotero bibliography engine using XULRunner, although the resource requirements may still be substantial.
  • I still have the same problem now after upgrading to Zotero 1 rc5 and OpenOffice 2.3 on Windows XP.

    Hope somebody will be able to solve this because it is a real showstopper.
  • edited October 23, 2007
    pvb (or anyone else experiencing this): Could you run Zotero with debug output, reproduce the error, and send us the contents of the debug console at
  • edited December 6, 2007
    I'm having the same problem.

    Would love to send you the debug info but the last step in the "run Zotero with debug output" doesn't work for me:

    b) “C:\Program Files\Mozilla Firefox\firefox.exe” -console

    It will start Firefox when I enter C:\Program Files\Mozilla Firefox\firefox.exe but not with the -console behind it.

    I run Win XP, Zotero 1.0.1, Firefox, and OO 2.3.0 (I just noticed 2.3.1 came out, so I am going to try that)
  • I too had this problem (OpenOffice 2.0 under Linux) but managed to fix it by using the Open Office Extension Manager (under "Tools" menu) to enable the Zotero extension.

    Quite frankly, I'm not sure why it worked, but simply highlighting the Zotero.oxt extension in the Extension Manager and clicking the [enable] button seemed to do the job!

    Hope this helps!
  • Thanks subconscious! I had the same problem in Oo.o then realized it was simply a matter of enabling the main part of the extension (all the subextensions are enabled, but not the top-level Zotero extension). It might make sense either to have it enabled by default or at least to throw an error message that corresponds to the actual problem ("Check to see that Firefox is running and that the Zotero extension is enabled").
  • Hi. I had the same problem, but my solution was very different so I am posting it, maybe it helps someone else. I use Word 2007 and I got the same error. Tried uninstalling and reinstalling with no help and then it dawned on me: I use Zonealarm and I simply gave Word permission to access the internet and voila!.

    If you are struggling take a look at your Firewall, maybe the problem is there.
  • I use Zonealarm and I simply gave Word permission to access the internet and voila!
    Just want to clarify that the Zotero plugin doesn't actually access the Internet, but it does make a request to a miniature web server running within Zotero, accessible only to your local machine (bound to localhost, in tech speak). You shouldn't need to (and probably don't want to) give Word access to the Internet or even the local network, but depending on your firewall you may need to give it access to "" or "localhost" or the "loopback adapter".
  • Sorry for the misunderstanding. I understand it as such, but in Zonealarm Word was refused any access, either to the Internet Zone or the Trusted Zone. So it was not Zotero who was to blame, but Zonealarm blocked any communication between Word and any other program that "appears to be a connection to any server".

    Thanks for clarifying
  • To get back to the original topic ;-), I finally found the solution for the problem I reported before (first message of this thread). And it is a quit simple solution. It appeared that another program (ArcGIS) had set an system variable with a path to python that came with that program. Removing that system variable solved the problem.

    To check if a path has been defined by another program, open a 'Command Prompt' window and type in the command 'SET'. Look in the list for something like:

    Pythonpath=c:\program files\arcgis\bin

    where the path will probably be different (unless you also have installed ArcGis).

    If there is a system variable 'pythonpath' defined, you can remove it as follows:

    Right click on 'My Computer' and click properties --> Advanced --> Environmental variables. In the box with system variables look for the pythonpath variable and delete it (you may want to write down the variable name and path in case you need to restore it).

    As last step, go to extension manager in OpenOffice and enable Zotero. This time you shouldn't get an error message any more and the plugin should work fine.

    Hope this helps.

  • Thank you, Paulo!
    I'm using ArcGIS and was trying to make the Zotero extension work with OpenOffice and ran into the problem described above. Your solution would probably solve my problems with the Zotero extension, but I'm afraid I will then get problems with ArcGIS instead. I'm using various tools in ArcGIS, and I think Python needed to run them. Any ideas on how I can use both the Zotero extension and ArcGIS at the same time?

  • Hi Thorbjorn

    No sorry, I wouldn't know. I use ArcGIS a lot less nowadays, relying more on other free alternatives. To me this problem with python seems to lie with ArcGIS rather than Zotero, Firefox or OpenOffice so maybe you can report it at their support site?

    Just to make sure, I reported it to Zotero support too, so at least they know (one of the possible) causes behind this more often reported problem. And who knows they can come up with a solution.

  • I am using the latest official 1.02 and OpenOffice plugin just released. Both are installed properly and the plugin shows everything enabled in the extension manager but I get the "can't communicate with Firefox" error when I try to insert a citation. Firefox is open, so at this point, I can't use my database. Is there a solution? John
  • I just updated to 1.02 and the newest OOo plugin and with as result some erratic behaviour: sometimes there seem to be no problem, than suddenly I get the message 'can't communicate with Firefox'. Indeed, this time everything seems to be enabled in the extension manager.

    In addtion, when I manage to insert a citation in an OOo document, it is followed by a small square sign.

    Hope this can be fixed soon, for now I reverted back to Zotero 1.01
  • For those getting communication errors, is Report Errors in the Actions (gear icon) menu becoming activated (non-gray) after you receive the communication error? If so, please send in an error report and let us know the Report ID you receive.
  • Hi Dan, I've just hit this error. I've sent in an error report: 533624866

    Regards, Jon.

    [JavaScript Error: "redeclaration of const kSaveAsType_Complete" {file: "chrome://global/content/contentAreaUtils.js" line: 118}]
  • I've got the same problem, and also sent you an error report, which (strangly) is different from the one sent by Jon Rubin. My question really is how i can revert back to the working 1.01 version for the moment? Where can I get it from? Thanks for you for your help.
  • Think mine might have been a red herring. I'd been having trouble getting the python bridge to work. But everything did install smoothly, finally and so far I haven't had any more communication problems. I'll let you know if it turns out to be flaky, but fingers crossed.
  • edited January 8, 2008
    Same problem here (I had the same problem last week with the unstable version of 1.02 and downgraded to 1.01 stable). Here is the behavior I am now experiencing: I can add an empty bibliography, then open the "insert citation" dialog to select the entries I want to insert. But when I click "ok," I get the "error occurred communicating with Zotero . . ." notification without actually inserting the citation, and after that point anything I do brings up the same notification. "Report errors" doesn't show anything related to Zotero.

    For the moment, I guess I'll have to go back to 1.01 until this version works with OOo if I can find it somehow.

    For those who need to revert to 1.0.1 to use Zotero with OOo, this is how I've done it:
    Zotero 1.0.1 can be found here (same address as the current xpi, just replace the 2 with a 1):
    The OOo plugin can be found here (again, just manually change the 2 to a 1):
    After uninstalling the current versions and reinstalling these ones, I'm once again using Zotero with OOo. I look forward to trying the new version when I can safely use it with OOo.
  • edited January 8, 2008
    Same problem here:
    report ID: 1127050403

    (the different errors I see, I imagine come from different actions generating the error lines)

    I sent in a second report (1833858649) after running the following sequence of commands:

    1-2 errors already there on firefox startup

    Working on a blank OOo file:
    3- insert citation (it allows me to pick a reference from the db window, gives an error on hitting OK)
    4- edit citation (with none to edit)
    5- insert bibliography (with none to insert)
    6- refresh

    Working on an existing odt file (using ReferenceMarks) with plenty citations:
    7- insert citation (doesn't open the db window)
    8- edit citation
    9- insert bibliography (inserts {bibliography} in the text)
    10- refresh
    11- edit document preferences

  • Thanks to everyone who sent in an error report. The relevant error seems to be this line:

    [JavaScript Error: "item._csl has no properties" {file: "chrome://zotero/content/xpcom/cite_compat.js" line: 370}]

    What citation style are people experiencing this error using?
  • edited January 8, 2008
    Chicago Manual of Style (author-date).

    Wait! It seems to be working now!!!

    I do get a square added to new references, but everything else is working fine (including editing references other than the first one!!!)

    Cheers! (and thanks for the great work!)
  • 1.0.x releases don't auto-update translators and styles after an upgrade. If you're experiencing this problem, go to the General pane of the Zotero prefs and click Update Now.
  • Hi Dan, I tried updating the styles, but I'm still getting the square box after a reference.
    OpenOffice 2.3.1 WinXP
    Regards, Jon.
  • Updating should fix the connection error, not the square issue. Sorry if that was unclear.

    I created a ticket for the square issue.
  • Hey guys,
    The discussion here is going way too technical for me, I don't understand the language.
    I just updated to Zotero 1.0.2, then also tried to update the OOo plugin.
    Problems I encountered:
    1. Unable to install the pluggin initially. Seems to be done with a 2nd try. Dont know why, I did everything the same way.
    2. OpenOffice says the pluggin's status is UNKNOWN, so I tried to enable it but could not.
    3. I opened the document anyway, and the pluggin seems to work when I choose style of citation; but it would not allow me to shift to another style -- I've tried this for a few times with different styles, by opening different documents -- it only allows me to choose style for once; whenever I try to shift style, it reports error when communicating with Zotero.
  • Hi Yam, It's strange if you can't change your style after the initial choice, but I've made the expirience that this isn't a very good idea anyway, at least if you swap from a "normal" to a "footnote" style or the other way. After trying this I always had quite a mess with my quotes. but I guess that's not really any help. I would try to completly uninstall the OOo plugin and reinstalling the right one.

    About the initial Problem: the solution by Dan Stillmann did the trick for me but I also had to do Prefs/Advanced/Reset Translators and Styles. After that it worked again, I just had to choose the citationstyle in my OOo file again.

    It's really great with the new version the "edit citation" function is eventually working and I might know what this box at the end of a quote is for. I suspect it's an attempt to solve the problem of never beeing able to get out of the quotes without starting a new paragraph. It is kind of working and has solved the problem to some extend but it's still not perfect, because you always have to erase the box by hand. I guess you could also ignore them while writing and erase all boxes after finishing a paper with 'find replace', but still...

    Never the less zotero is a great project and is getting greater with every release, thanks a lot.
This discussion has been closed.