Items in the collection ____ have been added and/or removed...

I've gotten this error before but I thought it was because of something I did, yet I got it again and it seems something's not right (or I'm not doing something right) because I also got an error -- I tried to submit a report, but the option was greyed out on the menu.

Here's what happened: I synced yesterday or the day before with no problems. Today, I did a bunch of work using citations in one subcollection; when I was done with them, I moved them to a different subcollection and deleted them from the first. Involved in this work/move was a new sub-subcollection. Please with my work at having gotten through dozens of citations and most of what I needed to do (well, all the minor sources at least), and preparing to move on to the remaining few items, I figured I'd sync.

Perhaps I shouldn't have synced?

Because then what happened is all that stuff that I "did" (moved/deleted) got returned to the original location. (And I got an error saying I needed to restart.) Now I have to go back and re-delete all that stuff from the initial subcollection. Not the end of the world, but a big waste of time (the moved stuff is all right where I moved it).

I guess my question -- in addition what's going on here and why did this happen -- is why the sync system doesn't recognize the newest edits and accept them. I move stuff around between subcollections, and I don't want sync undoing that!

Or is that by design.

Thanks for any advice.
  • Sorry, here's the full text of the window that popped up:

    "Items in the collection ‘___’ have been added and/or removed in multiple locations. The following items have been added to the collection:"

    Then there's a list of all the stuff. I copied it to use it as a reference so I can re-do my work, but the problem is that it's only title and author -- and most of the titles and authors are EXACTLY the same (I'm working with a lot of anonymous periodical reports)!
  • I am seeing the same error with the 2.0 plugin. Error report 331764051. Happens after I updated the subcollection (added new articles, edited author info on one item and moved items into the subcollection) on one machine, then went back to another machine (the next day) which had FireFox running and tried to use Zotero. Uninstalling/re-installing Zotero did not fix things. I will try removing the cached data after removing Zotero and then re-install Zotero.
  • Uninstalling, removing the Zotero folder from the FireFox profile location and re-installing Zotero (retsarting FireFox after each Zotero uninstall/re-install operation) fixed the problem. Zotero then resynched to the Internet storage and is working fine.
  • I have the same issue Error report id 427072915. The popup is driving me crazy. Until now i've never tried to sync two machines but if this is what is going to happen when i do i think i'll stick to manually trying to organise my things.

    Is there an easier way than above to fix this?
Sign In or Register to comment.