"No fields in itemTypeFields" Error during upgrade

I just opened Firefox and agreed to the Zotero database upgrade and then received the error, Report ID 1823237911, saying "No fields in itemTypeFields". The zotero field in the browser status bar now says: "There was an error starting zotero".

This error now comes each time I start firefox. The second Report ID is 1205896217.
  • Odd. First, try disabling your other Firefox extensions and restart Firefox, which should cause the upgrade to run again. If the upgrade still fails, two options:

    1) Upload your database to the DB Repair Tool and e-mail the Upload ID to support@zot....org, with a link to this thread. You can ignore the download link the tool provides.

    2) Provide debug output. You may be able to provide a Debug ID by accessing the Advanced pane of the Zotero prefs via Tools -> Add-ons -> Extensions -> Zotero -> Options/Preferences, checking "Enable after restart", restarting Firefox and running the upgrade wizard again, and then returning to the Advanced pane and submitting the output. If that doesn't work, you can use the old method and e-mail the output to support@zot....org. In either case, if the upgrade wizard doesn't run automatically after restarting, deleting compreg.dat and xpti.dat from the Firefox profile directory and restarting Firefox should cause it to run again.
  • edited January 26, 2010
    I have the same problem, tried disabling extensions--didn't work. Tried option 2--Debug ID is D1794188934. I also have the output from the console if that doesn't work. My db may be too big to go with option 1. Let me know what else I can do.
  • Thanks. We've reproduced this and are working on a fix.
  • This is now fixed on the trunk. We'll be releasing a new release candidate shortly with this fix. As an immediate workaround, install the dev XPI, perform the upgrade, and then switch back to 2.0rc1 from the front page.
  • Brilliant. That worked. I switched to the trunk and then switched back, so 2.0rc1 is now running smoothly. Thanks very much for fixing it so quickly.
  • Worked for me too--many thanks!
  • Yes, many thanks indeed for responding to this so quickly.

    I am able to do without zotero for a day or two. Should I just wait for the new release candidate, rather than using devXPI? Are you planning on releasing the next release candidate that quickly?
  • It's completely safe to fix this via the dev XPI (which currently has no other changes) and then switch back to RC1, but if you'd prefer to wait we'll have a new RC out by the end of the day.
  • Just a thought: Maybe this pinned thread could be added to the "2.0 Beta" category (even if 2.0rc1 isn't technically a beta). As of now, if a beta user runs into this error and goes straight to the "2.0 Beta" discussion area, they won't notice the existing thread.
  • Fixed in 2.0rc2, available now.
This discussion has been closed.