persistent Word Processor Integration / PhytonExt problems


Since late summer this year I have a problem with the Zotero Word Processor integration: Whenever start Firefox, I see the following prompt:

"The Zotero MacWord Integration installation succeeded, but a necessary component does not appear to be loaded properly.

Zotero can attempt to correct this for you. A Firefox restart will be required. Continue?"

(restarting Firefox does NOT fix the problem)
To at least get rid of the annoying prompt, I have deactivated PhytonExt - but then of course I can't use Zotero with Word (which btw also doesn't work since PhytonExt is required for Word Mac).
This problem wasn't very acute for the last months as I was not writing any publications. I have tried to fix it a lot of times; I have even created a new, clean Firefox profile; still, it's not working. Now I have an important paper due in January and really need to get to work on it...
I think it's an issue with PhytonExt. I have tried both the official release and the Zotero release, neither of which fixed the problem.

I am using a Macbook Aluminum (2008, 2,4 GHz); Mac OS X 10.6.2 (Snow Leopard), Firefox 3.5.5 and Microsoft Word for Mac 2008 12.2.3 (German version; all the other software is in English).

Could somebody please help me with this?
Thanks so much!
  • Thanks, but I wouldn't have started a thread if I hadn't tried all these things already ;)
  • well, it's hard to tell from your post (and you'd be surprised by how many people don't find the relevant info in the documentation).
    If that's the case, you should trigger the error (with the Zotero updated python ext), create and error report from within Zotero and post an error ID here.
  • I have triggered the error with the current Zotero updated Phyton ext; the error id is 681334913. Thank you for your time!
  • Any ideas, anyone? I'm kinda running out of time here...
  • If you're still having trouble, it looks like you have a copy of the Python appscript package in ~/Library/Python/2.6/site-packages/ but don't have setuptools, which that version of appscript requires. PythonExt's bundled appscript, used by Zotero, doesn't require setuptools.

    Is that something you installed? (If none of that makes any sense to you, the answer is probably "no".) If not, another app might have put it there.

    Either way, you can either delete the appscript .egg file from that directory or install setuptools into ~/Library. We'll also see if we can update our code to explicitly use the bundled version of appscript.
  • Hi Dan,
    thank you for your answer.
    I have tried and uninstalled the appscript.egg file, but I'm afraid it didn't fix the problem. I have also tried to do a clean uninstall of both firefox and the python extension, but neither worked. I created a new profile on my mac, but even there I had the same problem.

    How do I install setuptools as you said above? Do you have any other ideas? Is there any way to transfer my library back to Zotero 1.0 so I can continue working with it?
  • Provide another Report ID from the new profile. The error above was caused by what I said above.
Sign In or Register to comment.