Add Item by Identifier (DOI) broken?

"Add Item by Identifier" stopped working for me, at least for DOIs. Any DOI entered yields the the Lookup-Failed-Message "Zotero could not find a record for the specified identifier. Please verify the identifier and try again." There is no problem with ISBNs and PMIDs.

Does, for example, the DOI
work for you?
  • I didn't write our DOI support, but it looks like the format of CrossRef's resolver responses may have changed slightly. I've added a quick hack to the translator that seems to fix this.

    Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.

    Thanks for letting us know.
  • edited July 10, 2009
    There've been some additional changes to the CrossRef resolver, so we'll need to make further tweaks to the translator.
  • Any idea on the timeframe of these tweaks? I've surprised myself by how many times I've attempted to add things by DOI over the past week, it really is a very useful feature!
  • An updated translator that fixes this is now available. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.
  • Brilliant, thanks!
  • edited July 16, 2009
    Sorry! Please ignore my last post ... I have it!
  • Have you tried updating translators? Works fine for me now.
  • Very many thanks to you all
  • Fantastic!

    Now ... if only I could highlight a DOI or medline reference number, right-click, and have a pop-up menu function "Add item by Identifier" (to accompany the existing "Create Zotero item ..." menu item)

    Also, if the "Add item by Identifier" entry box could accept strings like: doi:10.1016/S0165-0173(05)00129-3 (i.e., parse away the "doi:") ... cutting and pasting would be all that much easier!

    Many many thanks for Zotero and for the support!
  • Derek: Both are planned. But there's also a DOI translator that should trigger on any page with a DOI.
  • I noticed two problems with this function :
    1- for some DOI, it does not work
    e.g. : doi: 10.1021/jp020449+

    2- more important :
    many times, only the first author is added to the notice !
    e.g. : 10.1016/1352-2310(95)00404-1
  • jbock, in both of these cases, the metadata is not registered properly with CrossRef, the central authority for DOIs. In the first case, there is no metadata whatsoever in the database, while in the second, it is incomplete. Unfortunately, we have no control over the quality of the metadata that these publishers submit to CrossRef, so we can't do anything to improve the results here.
  • Simon, thanks for your answer,
    how can you distinguish between incorect metadata and potential zotero bug ?
  • I have been having problems with the add item by identifier as well. It has consistently not worked for the last week or so. Here is the last ISBN that I tried


    When I attempt this I get an error that I then reported using the report error function. The error ID was 1807188308.

    Thanks alot
  • Reichard, Gary, and Organization of American Historians. 2008. America on the world stage : a global approach to U.S. history. Urbana: University of Illinois Press.

    works fine for me, maybe you had a typo in the ISBN?
  • Works for me as well.
  • So I coped the the ISBN from above and still did not work. Here is the code of the error that I get

    [JavaScript Error: "[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIChannel.contentType]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: file:///usr/lib/xulrunner- :: FP_onStartRequest :: line 1440" data: no]" {file: "file:///usr/lib/xulrunner-" line: 1440}]

    The new error ID number is 1743311334. Does anyone have any idea what the problem might be???
  • That's not a Zotero error.

    Generate debug output for the add attempt from Advanced pane of the Zotero prefs, submit it to the server, and post the Debug ID here.
  • Actually it looks like the above code may be unrelated to the identifier problem, because it is there every time I turn on Zotero whether I try to use the add item by identifier or not, however neither that ISBN nor any other is not working for me.
  • Ok. Here it is

    Debug ID is D378762285
  • Ok I think i did that wrong. This time I turned the debugging on, tried to add the ISBN, and then submitted it. The new ID is

    The Debug ID is D1831324649.

    sorry about that.
  • Is "Accept third-party cookies" enabled in Privacy pane of the Firefox preferences? If not, that's the problem.

    If it is, try disabling other Firefox extensions.
  • edited October 27, 2009
    Actually, this may be the result of a proxy entry for in the Proxies pane of your Zotero preferences. (If you don't see it but see a Multi-Site line, double-click on that line to see all the associated hosts.) It's possible that's interfering.
  • edited October 27, 2009
    We'll work on a fix. Don't bother disabling Firefox extensions. In the meantime, removing the proxy entry should fix the problem temporarily (until the next time you try to use that via your proxy).
  • There is a multi-site proxy on my proxies pane and it does contain a proxy, until I just deleted it. After deleting it I still had the same problem. Should I try deleting all the proxies and starting over again?
  • You might need to restart Firefox. But based on your debug output it'd definitely be due to a proxy entry.
  • That did the trick. I have no proxies from my university now on my zotero, but that is okay, they were causing other problems as well, I think my life will be better without them. Thanks for all you help.
  • When I tried this method, it did not import all authors. "Import into RefMan" in Google Scholar is still my favorite method for importing. I just wish that abbreviations worked.
  • edited January 6, 2010
    I'm also having problems with DOIs. I don't think I have ever been sucessful at using DOIs to add an item.

    For example, this DOI:


    If I go to and use their search box, the DOI locates the correct source.

    If I try and use the DOI wizard in Zotero then it doesn't work. I get the usual error message about it not being found.

    Turning on the debug output (below) I see that whilst Crossref is reporting that it didn't find the item (or is it Zotero saying that), it actually DID return the details of the item.

    I have turned on third-party cookies, and restarted Firefox. Any ideas?

    [debug output removed — D.S.]
  • This appears to be because the parsing code for Crossref book results is slightly broken (CrossRef.js):
    72: var refXML = xml.doi_record[0];
    140: item.title = refXML.titles[0].title.toString();

    For a book chapter, at least, the first E4X does not work; the title could be pulled with:
    item.title= xml.doi_record[0][0]

    But it won't work to just replace refXML with the content_item, since the metadata are stored in book_series_metadata. To handle these, it's probably necessary to add a special case for books with the type edited_book, but I'm not very familiar with the ins and outs of the CrossRef response format.
This discussion has been closed.