[Zotero 7 Beta] Text annotation disappears when using dark mode for content

The text annotations disappear when using dark mode for the PDF content. I can make annotations they just aren't visible in dark mode.

https://s3.amazonaws.com/zotero.org/images/forums/u6803827/uzpavaf1mk3g9sw2hi1b.jpg
https://s3.amazonaws.com/zotero.org/images/forums/u6803827/cdlmae6hxun88mw1syow.jpg

Also, it would be great if we could change the text size of these annotations. Thanks!
  • edited April 17, 2024
    Does it reappear if you zoom in or out? Or if you restart Zotero?

    I can reproduce on Windows 10 in Troubleshooting Mode.
    Zotero 7.0.0-beta.74+2e8073ab9 (64-bit)

    For me, it usually triggers the bug when changing the Zoom level.
    Normally, the text annotation would quickly disappear and reappear after changing the zoom.
    But sometimes it does not reappear, even after waiting a long time.
    It reappears after restarting Zotero.

    https://s3.amazonaws.com/zotero.org/images/forums/u265723/qf2nol91zcx467aijgcc.png
    https://s3.amazonaws.com/zotero.org/images/forums/u265723/azom32ykcva5hgxuboiz.png
    Also, it would be great if we could change the text size of these annotations.
    You can change the text size by resizing the text annotation box:
    https://forums.zotero.org/discussion/109830/zotero-7-beta-feature-request-text-size-font-at-annotation-level-in-reader
  • It does reappear if I zoom in and out! I'm on MacOS Sonoma 14.4.1 using Zotero 7.0.0-beta.74+2e8073ab9
  • I still can't reproduce this. Does it happen with all PDF files?
  • For all PDF files for me.

    In some cases, I can zoom in and out many times, and it always reappear for some time, before showing the problem again.
    I have noticed that after restarting Zotero, the bug occurs more consistently: zoom in, zoom out, and it is gone:
    https://s3.amazonaws.com/zotero.org/images/forums/u265723/bmyluz22gfuaniey9qwg.png

    Not sure if there is anything useful in it, but here is a Debug Output reproducing the problem:
    Debug ID: D33918503
    Zotero 7.0.0-beta.75+f7dc68c7f (64-bit)
    Windows 10
  • From the hidden state of the annotation, I get one error for clicking on the annotation in the left-hand pane:
    (1)(+0022603): TypeError: event.target.classList is undefined _handlePointerUp@resource://zotero/reader/reader.js:28399:9
    Debug ID: D1514565876
  • Does this issue occur only in dark mode?
  • Sorry, the last one is not specific to dark mode. So not related to this issue probably.
    Steps to reproduce:
    1) Click inside the text box inside the PDF center pane, so that it enters the text edit mode
    2) Click on the annotation in the Annotations Pane on the left
  • I mean the original issue of disappearing text annotation. Does it only occur in dark mode, or was it also reproduced in light mode as well?
  • edited 27 days ago
    The original bug is only reproducible in Dark Mode, in the sense that you see the problem only in Dark Mode. But the actual steps to get there also trigger the problem in Light Mode.

    I have finally narrowed down reproducible steps:
    1) Switch to Dark Mode
    2) Make a text box annotation on a PDF file
    3) Go to another page
    4) Zoom in
    5) Go back to the text box annotation
    -> The text box is not visible anymore
    6) Switch to Light Mode
    -> The text box is visible again.
    7) Switch to Dark Mode
    -> The text box is not visible anymore
    8) Zoom out on that page
    -> The text box reappears

    The key step here was to make the zoom in another page.
    That was triggered more often as the testing was done with a text box placed at the bottom of the page.

    If you place one text box at the bottom of the page, and one text box at the top of the next page, they can only appear in turn, depending on which page you last made a zoom.

    If you make the same steps starting from Light Mode, the text box disappears at the end when you switch to Dark Mode.
  • I can finally reproduce this. We'll fix — thanks.
Sign In or Register to comment.