Can't log in zotero 6.0.4 in Ubuntu 20.04; "User canceled master password entry"

ID: 826337552
Zotero 6.0.4 in Ubuntu 20.04

I recently installed the Zotro 6.0.4 in my Ubuntu 20.04, But when I tried to log in to my zotero account, it will appear “User canceled master password entry”. I am sure that my account and password are all right, I don't know where the problem is?

  • [JavaScript Error: "NS_ERROR_FAILURE: Couldn't decrypt string" {file: "jar:file:///opt/Zotero_linux-x86_64/omni.ja!/components/crypto-SDR.js" line: 179}]
    Does it work in a new Zotero profile? (You don't have to actually sync — you can just test whether you're able to set up syncing and quit.)
  • Thanks for your suggestion, I solved the problem with the new zotero profile. I moved the zotero profile in the win system to the ubuntu system, that may be the cause of this problem.
  • Ah, OK, then it was likely just a permissions problem. You should be able to fix it by fixing the permissions in the old profile. Either way, you should delete one of the profiles via the profile manager to avoid future confusion, and if the new profile created a new data directory, you should switch back to the old data directory and delete the new one.
  • Which file store the sync information? So that I will skip copy only this file.
    I want to move extension settings from windows to ubuntu. Copying all files in the profile folder will lead to "User canceled master password entry" problem.
  • A possible solution: I created a new profile, and before starting zotero with the new profile, copied a few files from the old one. This seemed to work for copying preferences and add-ons over without breaking sync.
    The list of files:

    Try at your own risk!
Sign In or Register to comment.