Exporting a library with attachments and including annotation won't export any of the pdf files

I export my library using the "Export Library" command and chose to export attachments with annotations. None of the pdf files are included in the "files" directory. Exporting the library with attachments and WITHOUT annotations works fine --- the pdf files are present and they are not annotated. I can't get it to work even once tonight. This problem seem to be intermittent, as I know I have done this in the past successfully. I also know I have done this in the past and I have had the same problem I am describing here. Restarting Zotero and even restarting the computer has no effect. It doesn't seem to matter which export format I choose; all formats that allow for the exportation of annotations fail.
  • edited September 8, 2022
    Can you reproduce this with a single item? Can you provide a Debug ID for that?

    If not, try half of your library at a time and keep halving until you find the smallest number of items that reproduce the problem.
  • I can't reproduce it with a single item. Exporting the collection that has about 200 items, 150 attachments of which 40 have annotations works fine. It I export the next folder in the hierarchy, there are more than 1,000 attachments but still only about 40 of them have annotations (of the new style where they are not stored with the pdf). That fails. It also fails whenever I export the entire library. Thanks.
  • So then you should do what I say above.
  • I'm not sure how I can do that. The smallest collection that contains all of my annotations exports just fine. The next folder in the hierarchy that contains the folder with all of the annotations won't export. There is nothing in between these two collection to export.

    The Debug ID of the smallest collection that fails is D1244280290
  • Don't export the collection -- export all of the items in the collection, then half of the items in the collection etc. to narrow this down, not unlikely to 1 specific item that's breaking this.
  • Thanks for the suggestion. I tied that. I don't think it has to do with one or more files. I have items in a collection that I successfully exported (the collection) earlier today. I just tried to export the same collection and some of the items in the collection --- no pdfs. This is a very strange problem that defies getting a handle on it. It's intermittent and I can't tie it to any specific actions. I even checked the database for consistency. No problems.

    I have a Zotero.rdf of the collection that has all of the annotations and pdfs in it from earlier today. I think I'm just going to start the library over from a fresh install. I don't know what else to do. Thanks again for your suggestion.
  • edited September 10, 2022
    I think I'm just going to start the library over from a fresh install.
    No, don't do that. If you're going to bother posting here, let us help you.

    The debug output you submitted above was in the middle of an export process. Nothing had failed — it just wasn't finished. We would need to see a Debug ID where the problem actually occurred.
  • OK, I'll not do the fresh install at this point. So is the only problem is that I am not waiting long enough? Sometimes I get the spinning wheel and I wait til that vanishes before checking. Other times (on smaller exports) no spinning wheel. I did check some of the exports that had no files, and now they have files. I guess my question is "How do I know when the export has completed?" It still doesn't just feel right.
  • That's just a bug — it should show a progress window until the export is done. We'll investigate. For now if you're exporting a lot of files you can go to Help → Debug Output Logging → View Output and wait until the output stops.
  • Got it. If it helps, when I export attachments without annotations, the spinning wheel is present longer and when it's completes all the files are present than when exporting the same collection with annotations. I've noticed this mostly when exporting large collections. For small collections, typically the spinning wheel isn't present for either case.
  • I can confirm the issue.
    I exported a collection with 243 attachments without annotations: Progress bar appears, entire process finishes successfully within one minute or so.

    Debug ID D1601804220
    Exporting the same collection with annotations: no progress bar. The attachment folder structure shows up but the folders are, at first, empty. The files do show up however. Entire process that took about one minute without annotations took about 10-12 minutes to complete with annotations.
  • Hi, I am experience the same problem. When I export one of my collection.
    I do not get the pdf attachments.
    The process is very fast when I export so I guess that something is wrong with the exporter.
    Pleas help
    Nic
  • @nicolaschiavottiello: As noted above, the export process can currently continue after the progress window closes, so the files may appear if you wait a bit.
  • Hi thanks a lot I will try and let you know. Do you know how much roughly I need to wait for 200 references?
  • edited September 20, 2023
    If you selected Export Files, a 'files' folder should appear in the export folder, and it should be populated with subfolders as the attachments are processed — you can watch this happen.

    And to be clear, it's only slower if you also selected Include Annotations. Otherwise the files are just copied over immediately.
  • OK - I have the same issue, and following @dstillman, I decided now to let Zotero open even after the progress bas disappeared.

    Is there any way to know when it has finished exporting? I have thousands of references to export and the only way I saw at the moment is to check the Activity Manager (MacOS).

    This is really dissatisfying...

    export without annotations is nearly immediate.
  • It seems like this issue is still present.

    I find myself unable to export some pdfs on zotero - they simply won't save anywhere on my computer and the debugging output says (1)(+0000506): Error: Worker 'export' failed: (followed by the annotations on the pdf).

    However, many other pdfs are able to export flawlessly with all their annotations. I can't figure out why it doesn't work for some pdfs.
Sign In or Register to comment.