not capitalizing titles in chicago

i saw that there is a lot of messages about the unwanted feature of Chicago 17 which always capitalizes titles, what is not suited to the EU (or more broadly not en-US) context.
i operated according to the indications in "How do I prevent title casing of non-English titles in bibliographies?" which requires to change the tag which describes the language of the publication: practical but not perfect.

but when in the document preferences one chooses the Chicago style, there is also a field for the "language" which operates on the dates (the names of the months are translated) and on function words.
why this choice cannot operate on the title of the source? if in the document preferences i choose italian, it should imply also that titles are not capitalized.

  • You can modify the citation style.
    You'd basically remove all instances of text-case="title" that you find throughout the style.
  • If you set the style to any language other than English, title casing is in fact disabled unless the language for an item is set to en, so this already works the way you suggest -- are you sure that's not the case for you? This works for me and as far as I know the related code has never changed. Note that this is the language for the citation styles, not the language for the Zotero interface, which (appropriately) plays no role in how citations are displayed.
  • uh, the problem is that when i import the data of an item from an external source, nearly always the items written in english get the language field set to en or to en-US.
    so it seems that the language filed ovverides the language choice in document preferences; while probably it should be better the contrary: the language choice in document preferences overrides the content of the language filed of the items.
  • No, definitely not -- if you're using Chicago style, English titles should be title-cased. I'm also not sure why you think that wouldn't be appropriate when writing in other languages? The Chicago Manual says to respect other language's conventions with respect to casing, and that would also apply to English.
    If you want a style that doesn't change case, use a different one or edit Chicago Manual as per the post by damnation above.
  • i understand your point for keeping "pure" the style Chicago.

    i edited the chicago 17 full note csl file, i expunged the text-case="title" string, saved it putting EU in the file name, added it by clickin on + and by choosing the file itself

    but the example of title in the style editor continues to show the title capitalized
    like it is not sufficient to expunge text-case="title"
    or i didn't understand how to put the new cls in place of the previous one
  • You want to change filename, title and id as described in the link above
  • edited October 25, 2023
    ok, now i have it visible and choosen
    but in style editor|refresh (and also in other ways) as far as i can see the titles remain capitalized
    the string to expunge is (also?) something other than text-case="title" ?
Sign In or Register to comment.