Monochrome emoji after latest Windows update

  • @dstillman

    I've created a new Windows local user account on my computer, opened up Zotero, imported a random paper and added a tag.
    The problem persists.

    You can find a link of the screenshot there :

  • @Asclepius: Thanks.

    So based on that and the workaround from @hanyc1213, it's possible this is caused by some software having been installed on the system that added a different version of the Segoe UI Emoji font.

    If you're seeing this, go to the Fonts control panel, search for Segoe UI Emoji, right-click → Properties → Details, and let us know the version of the font you have. (I have Segoe UI Emoji Regular version 1.45.)

    It'd also be helpful if someone seeing this could try with the Zotero 7 beta to see if it still happens with that.
  • @dstillman

    I also have version 1.45 of Segoe UI Emoji.

    However, interestingly enough, the file was created the 11th of October 2023 at 22:26, which may coincide with the beginning of the issue (I've noticed on the 13th of October but not sure if I have used Zotero the 12th.)
  • same coincidence! (The file on my comupter was updated on October 11th, which coincide with the problem.)

    I think I had made a windows updated on that day...
  • Seems caused by the font update in KB5030310? I checked the file information for cumulative update KB5030310 at and found "seguiemj.ttf" listed. Additionally, in the "File version" section, it's marked as "Not versioned," suggesting that this file update won't affect the version number.
    Hope this information might help with solving the problem.
  • edited October 16, 2023
    I had to ask my IT guy to go through the new account thing with me. The result was the same.
    He did suggest rebuilding the icon cache and did so, to no avail. There was no change in the icon status.

    [ETA: Just saw the other comments and will check on that too]
    What next steps do you suggest?

    I'll check on my husband's computer by installing Zotero to see if it acts the same (he has the same iOS and version, but it's a completely different machine). We also have a few older PC's and laptops in the house all on different versions of Windows and I'll install Zotero on them and report back later this week.
  • @dstillman

    Ok, so I've found a workaround and have restored my emoji as they were.

    The findings of @NightwatchGu and the coincidence noted by @appw pointed to a change in seguiemj.ttf.

    So, as suggested in a Reddit post ( I have downloaded a Win11 ISO and extracted the font from sources\install.wim\1\Windows\Fonts\seguiemj.ttf using 7-zip. I then installed seguiemj.ttf (version 1.35) and rebooted my machine.

    When I opened up Zotero again, I had the pleasure to get my emoji back ! :)

    Not a perfect workaround as I have now two versions of seguiemj.ttf installed on my machine (Win11 wouldn't let me uninstall 1.45 as it is a protected system file) but good enough for me for the moment :)

    Hope this helps people to find a proper fix or use this workaround for the time being !
  • Font: Mine says 1.45 and that it was created/modified September ‎27, ‎2023, ‏‎11:35:40 AM.

    On our other Windows 11 laptop, I installed the latest Zotero, created an entry, added a tag, and everything worked fine. I checked the windows update and it had 3 updates to do, so I started those and took a pic (it's on my cell phone, I'll edit with the image links when I get to that.)
    One was a Framework update (KB5031323), a second was a malicious software tool removal update (KB890830), and the other was a cumulative update (KB5031354).

    The one that broke the icon (because of course it did) is KB5031354.

    I have no idea how that can help at this point. I'll upload the pics and share the link asap
  • @andreemcaron: No need for pics — that info is helpful. Unfortunately we have KB5031354 and 1.45 on our test installs and can't reproduce the issue, so there has to be something else that's contributing to this.

    We also still need someone seeing this to test with the Zotero 7 beta.
  • edited October 16, 2023

    Hi! I followed the link and tried to understand what was being explained and your explanation and sadly that's already too involved for me. Where did you download the Win11 ISO and how did you extract the ttf file from it. I literally just copied the 1.35 file from my other machine before the update and tried installing it and it doesn't do anything at all.

    I'll try installing the Z7 beta on the other machine. I can't get it to install in parallel like it was mentioned in another thread and really don't want to lose 5 years of research papers on my own laptop! lol Will check back later with that.
  • @andreemcaron

    To give you a quick tuto :
    1) Download the ISO on the official Microsoft download page (

    2) Open the ISO using an appropriate software (7-zip works)

    3) Open the sources folder and extract install.wim

    4) Open the extracted install.wim with 7-zip and go to 1\Windows\Fonts\

    5) Extract seguiemj.ttf

    6) Install the extracted seguiemj.ttf

    7) Reboot your machine

    8) Open Zotero and cross your fingers
  • edited October 16, 2023
    Ok, I can confirm that with font version 1.45 with Z7-beta the icons work fine, the color is restored, and when I open Z6, the icons are monochrome.

    I can also confirm that if you simply reinstall the 1.35 version of the font, it works in both.

    Somehow the 1.35 font I grabbed from my other machine got installed after all, so I'll try the beta on the other computer to confirm or infirm this.

    It works!
    I reread how to do the dual use thing and the beta version restores the emojis!

  • thanks @Asclepius

    It took a while to get the old font file, so I upload it here.
    Just download and install the font, then the problem will be solved.
  • I also have the black and white emojis in v6.0.27 and color in v7.
  • The issue of emoji going black and white is solved here, but the emoji doesn't seem to be the same as before.
  • edited November 2, 2023
    @kikkiz: That workaround is noted above as well, but all it does is switch you to something other than the native Windows emoji font. I wouldn't recommend doing that.

    For everyone affected by this:

    It sounds like the two real options for the people seeing this are 1) install an older version of the font or 2) install the Zotero 7 beta.

    I'd recommend people install the Zotero 7 beta, since it'll be much easier to forget that you have an old version of the font installed, and it might affect your ability to view newer emoji as they become available. The Zotero 7 beta has been out for months and is fairly stable at this point.

    I still don't know why we're not able to reproduce this with version 1.45 of the font on our systems. If anyone can identify any other differences between systems where this occurs and where it doesn't with the latest Windows update installed, please let us know.
Sign In or Register to comment.