Retraction watch not working


I’m concerned the retraction watch feature is not working in Zotero, I have the following paper in my library. It has been retracted but Zotero has not flagged it at all.
  • It's working fine, but it looks the current implementation is incorrectly comparing DOIs case-sensitively. That's rarely a problem, since publishers almost always use lowercase characters in DOIs (which is why no one has ever reported this before), but here RSC is using capital letters, and so the retraction isn't being properly detected. We'll fix that. Thanks for reporting.
  • OK great thanks Dan, great that it will be fixed and thanks for the quick response!
  • OK, fixed in the latest Zotero beta, and the fix will be included in 6.0.22. Once you're running a version with the fix, any previously undetected items will be flagged the next time Zotero checks for retractions (about once a day).
  • edited February 6, 2023
    Thanks a lot! I'll test it when 6.0.22 is released and let you know if it works.
  • @dstillman CrossRef also stores DOIs in uppercase so if folks are pulling data from CrossRef and not lower casing it (I think the CrossRef translators and DOI Manager both do), that could be another source of uppercase DOI data
  • @ben_a: Zotero 6.0.22 is out now with this fix.
  • Thanks Dan, unfortunately the article is still not flagged for me under 6.0.22, does it take time for it to be detected?
  • When did you update? As I note above, it should be flagged the next time Zotero checks for retractions, which happens about once a day.
  • Oh ok, yep I've only just installed it now. I'll get back to you tomorrow and see if it works.
  • Hi Dan, seems like the retracted article is being detected for me now, it came up with a red banner when i loaded my library today. Not sure what has changed, it's still version 6.0.22, but thanks.
  • As of 4/8/2023 using version 6.0.23 - case sensitivity still appears to be an issue for RW integration.

    For example:

    10.1056/NEJMoa1200303 (not flagged)
    10.1056/nejmoa1200303 (flagged)

  • Hello! I am using Zotero 6.0.26 (MacOS) and it is not detecting a retracted paper for me. I tried changing it to lowercase DOI and it still did not provide an alert. Any ideas? Thank you!
  • @heathersaigo: We always need specific examples.
  • Sorry about that. This is the paper that should be flagged.
    10.1056/NEJMoa1200303 and I also changed it to all lowercase. Do I need to install an extension? I just learned about retractionwatch today so I'm not familiar with this feature and wanted to check it out. Thank you!
  • edited August 29, 2023
    @heathersaigo: OK, so the same DOI that @lizcody1 provided. I see what's happening here — we're still not handling case properly. We'll fix. Thanks.
  • @lizcody1, @heathersaigo: OK, mixed-case DOIs should be detected properly the next time your Zotero checks for retractions (within 24 hours). Thanks for reporting.
  • @dstillman Thank you! It's working now! I appreciate your help. :-)
Sign In or Register to comment.