[files_not_syncing] A few PDFs are not shown in iOS App while available in Zotero Web

Dear Zotero-Team,

your long answer about file syncing issues has helped me well in the past - however not this time (https://www.zotero.org/support/kb/files_not_syncing).

A few PDFs that are available in Zotero Web do not sync with the iOS app.
There is no icon to press for download - in the iOS App it simply appears as if no PDFs would be attached to these references.

I opened the database entries while logging and hope that helps.
DebugID: D1506305184

Kind regards

  • Note that you don't need to press any icon to download anything — you can just tap anywhere on the row (other than the `(i)`). What happens if you tap the row for these? Does it open the details pane?
  • @manook can you please start logging, then drag down on items list to start a sync? When the sync finishes (the activity/progress indicator is gone), stop logging and send the Debug ID here please.

  • @dstillman: when I tap the reference, the DOI link opens (a link-like sign is shown where the PDF icons usually appear). The URL field is empty.

    @michalrentka: D1927246545

    Thank you!
  • If you make a change to one of the attachments — either adding a tag (which you can do in the desktop app) or adding an embedded note (which you can do in the web library after clicking on the Attachments tab and clicking on the attachment) — does that help?

    Can you provide another Debug ID for the first sync from iOS after making that change elsewhere?
  • I had similar situation, triggering some changes like adding annotation helped with sync
  • @dstillman

    ad 1.) adding a tag in the desktop add did not help, though the added tag showed in the reference on iOS after sync (D1225995484)

    ad 2.) adding an embedded note in Web App did help and made the PDF download available on iOS (D1459127129)
  • edited August 28, 2023
    To be clear, you have to add the tag to the attachment, not the parent item.
  • Anyway, we'll see if we can figure out how that happened, but once the attachment is updated you can undo whatever change you made.
  • Yes, that was a misunderstanding.

    So, embedding a tag within the PDF from Desktop App also makes the PDF available on iOS after sync (D2101242710)
  • Hey @manook the issue should be fixed in the upcoming iOS/iPadOS release.
    If you want, you can try it before that, and provide any additional feedback, by using the public beta.
    Please check https://www.zotero.org/support/beta_builds#zotero_for_ios_beta for instructions.
  • Had the same problem. Adding the tag, both to the item and the attachment solved it. Very weird, syncing worked for all other items (and files); the error only affected a particular book section and the entry for the book it belonged to.
Sign In or Register to comment.