Data syncing issues on jailbroken iOS concerning updates 1.0.16/17

edited June 27, 2023
After not using Zotero for a while (following Box's discontinuation of its WebDAV service -- this time for good), I decided to make use of the jailbroken iPad I use for reading and figured out a way to locally sync my attachment files with the use of Resilio Sync (and a symlink trick on the iPad).

It all seemed to be working well, until updating to 1.0.17, when the data syncing stopped working. Don't ask me how or why, the file syncing was done with Resilio correctly, it was just the data not synced: e.g. renames of files and removals from certain collections made on the PC did not reflect on the mobile device, despite Zotero data sync being turned on (yes, I was logged in, and waited enough).

So I decided to further make use of the JB state and downgraded back to 1.0.15 and hey presto -- now data is syncing properly as before.

My question:
Are the data syncing hiccups (if you have been aware of those anyway) going to be fixed in the future or I can say goodbye to further updates of the app?
Or is it just me that uses the downloads folder and not using WebDAV or Zotero sync to sync the files? I mean, data still should be syncing and obviously something HAS changed since the last updates.

  • edited June 27, 2023
    We just need a report of a problem — you don't need to start talking about never being able to upgrade again.

    Are you getting a sync error? Can you provide a Debug ID for a sync attempt (pulling down on the items list)?
  • I don't believe there are any known issues with sync in the iOS version 1.0.17 (and it's very much possible that the fact that the downgrade worked is a co-incidence, e.g. bc you also restarted the iPad) -- so you'd have to report this in detail should it re-occur:

    You are, as far as I know, the only person using the iOS app with linked files who has posted here, and that's certainly not something that you'd get support for, but e.g. moving an item to a different collection should, as you say, be purely data syncing and work independent of that
  • Sync errors only relate to WebDAV because the fields are not filled in. I sync locally between the devices.
    I am not sure Debugging is doable on the iOS side?
  • Sync errors only relate to WebDAV because the fields are not filled in
    I don't know what you mean by that.
    am not sure Debugging is doable on the iOS side?
    I linked to instructions.
  • These are not linked files. The files are synced back to the downloads folder -- as if they were downloaded from the web on iOS.
    Yes, data sync is different from file sync, which is handled separately.
    iPad was not restarted, as it would entail needing to re-jailbreak again.
  • Apologies, indeed there are options to debug.

    Then, I will be back with you later on.
  • Fields not filled in means that I did not tick Zotero file sync so I had to tick in WebDAV (there is no option to not tick either of them), so I left the WebDAV fields empty as I don't have a service provider (yet).
  • Debug ID:

    I made some changes on PC (moved item to a different collection), upgraded to 1.0.17 and did the debugging steps; changes, again not reflecting on iOS side.
  • edited June 27, 2023
    "it's very much possible that the fact that the downgrade worked is a co-incidence..."

    It seemed to be... as back on 1.0.15 it no longer syncs again.
    But the item I moved to a different (`.to-read`) collection a few days ago (I don't remember on which device) is in the proper place on both devices.

    I am beginning to think it was a big fluke managing to add my files on the PC side with Folder Import and have not only the files themselves but also the collections complete with items in their proper places to begin with...

    One thing is for sure, this setup will not work the way it is now.
  • Are you saying syncing is working in 1.0.15 or not working?
  • It is not working on 1.0.15 now.
  • edited June 27, 2023
    Did my iPad at least send the debug log at all?
  • Setting file syncing to WebDAV with empty fields looks to be blocking other sync operations. We'll see what we can do to fix that.

    Needless to say, though, yours is very much not a supported configuration, so you should not expect help from us for most issues.
  • I might be misunderstanding the exact setup, but any reason not just to set this to sync files with Zotero? If you're using linked files, there won't actually be any files syncing with Zotero, so this won't do anything, but you don't have that awkward empty WebDAV (which also appears to break things).
  • edited June 27, 2023
    The setup entails targeting a folder specified in this write-up:

    I've got to admit, as soon as I wrote it on the forum (which I kind of think now I shouldn't have), I had an idea that I could be targeting the wrong folder. That I should be working with a folder where the WebDAV files would be populated. But then I thought if the files need to be zipped (as I still have them on Box), I am not going to zip 3.5k PDF's...

    So when you say I should sync with Zotero, you see the files are there and 300MB will run out quickly (the Robin Hood I am, I don't own a bank account anywhere so official sync is out). Granted, the files are linked to under the `custom_my_library` folder, but physically available to sync, because that's the folder the iOS app uses for downloads from Safari.
  • edited June 27, 2023
    All right, I moved all my files out of the synced folder on iOS with Filza and left two files only. I turned on Zotero file sync. I received errors for items not able to be found, of course. But this time the data (when I moved these files around to different collections on PC) was synced both on 1.0.15 and 1.0.17 as well.

    So it looks like it is how Adam said.
    There should be a setting on iPad that bypasses the need for file sync with either Zotero or WebDAV. Which setting obviously will not be a top priority todo on the devs’ shelf, for one guy from the oak tree.

    Thanks, peeps anyway
  • edited June 27, 2023
    Okay, now I moved all items back and this time I filled in the WebDAV details for Box that no longer can be validated...
    There were two files giving errors (SSL error). They were added separately – probably on iOS – in the last two weeks or so. After deleting those I still have the WebDAV error but at least data sync is back to normal (1.0.17).
    Now what I need to find out 1) what was wrong with those PDFs I added separately after the Folder import of 3.6k files 2) whether it is the iOS side addition that no longer works…
  • edited June 27, 2023
    Yep. If you have WebDAV fields at least filled in, data sync works, but then PDF added on iOS side cannot be uploaded to the remote and will throw an SSL error, which consequently stops making further changes on the data sync side working.
    So solution: add all files on PC side.

    But what’s the difference between a non-functioning WebDAV with credentials given or nothing given? Strange…
  • Just to note, we tested syncing with file syncing set to WebDAV with empty credentials and couldn't reproduce any problem. Remote changes were downloaded.
  • edited June 28, 2023
    Thanks, Dan.

    Indeed, credentials or no credentials don't seem to make a difference.

    Upon further review, I found that after adding a file on the iOS side when synced locally with Resilio, it will appear on the PC, but the icon will be faded as if the file was not really there but clicking it makes it open the PDF anyway.
    That wouldn't be a big issue.

    The issue is when I e.g. rename the iOS downloaded item on PC, and go back to iOS (having synced with Resilio of course in the meantime), the item is not found:

    Unable to upload attachment: NameofPDF.pdf (UniqueID) Please try removing and re-adding the attachment."

    It will throw a WebDAV error and I can go back to (almost) normal if I delete the item in question.

    I say almost because I still have the old standby error (which doesn't stop data syncing though):
    Couldn't delete files from your WebDAV server: "The operation couldn't be completed. (Zotero.WebDavError.Verification error 2.)"

    - Of course, I know why the error is shown, but as I said, data sync is successful if only this 1 error is shown.

    So again, my conclusion is that I need to be careful where to add files and how to proceed with renames as such.


    Now that we mentioned earlier that my use case is special... I don't think it should be that special because people use Syncthing and Mobius Sync local sync as well but of course, they don't symlink the download folder like me.

    For other topics that I found worth mentioning, I will duly open new issues, if I may.


Sign In or Register to comment.