Zotero 7 beta: Missing title bar

edited June 27, 2023
Today the program suddenly became unresponsive to the mouse:
1. To switch between Tabs you need to double click, otherwise nothing happens.
2. The Windows icons (minimize, maximize and close) disappeared. Here I attach a screenshot: https://app.box.com/s/vjdi93biwuizuot7dkr11emgxwcbtmst. This had been reported before, but it didn't happen to me at that time.

The contextual menus do work, in fact it is the only way to close the program (File->Exit).

This error started to appear today for the first time. I thought there was an update pending, so I closed the program, and when I restarted it did install version 7.0-beta.9, but these errors continue to occur.

Windows 10
Zot 7.0-beta.9
  • Have you tried restarting your computer?
  • Yes, I did, but it does not change anything.
  • I don't believe we've received any other reports of this, so this is likely due to something else installed on your system.
  • There is a similar report a couple of weeks ago:


    I will unistall and reinstall Zotero 7, and let you know
  • No, it seems to me it is something in Zotero 7.
    This is what I just did:

    1. Uninstalled z7-beta.9, and re-installed a "fresh" downloaded instaler of Z7: the problem continued

    2. Uninstalled the 7 again, but installed the last available Zotero 6: it was Ok!!!

    3. Uninstalled Zotero 6, and reintall the 7-beta.9: the problem is back
  • That doesn't necessarily mean it's a problem in Zotero, though, just that it only shows up in Zotero 7. Either way, since this isn't happening for most people, or for us, you'll likely need to do some debugging on your own system to figure out what about your system is causing it to occur.
  • Yes, I understand you, but it is very strange. This is an almost new PC.

    In that case, since I don't know how to debug the OS, I am going back to Z6. Lets hope that a solution could be found in the future.
  • Same problem with no Window Controls started happening to me on beta 9 yesterday. This is a university computer running on Windows 10, so no changes to the system as far as I know. Sad that there isn't a way to debug or suggestions from the dev. Tried uninstalling, clearing up any settings from my computer and restarting, but the only solution was move back to 6.0.26. I was excited about version 7, but apparently, we will have to wait and see if this eventually shows up to more people then.
  • edited June 9, 2023
    Yes, this is just my situation. University computer also, with no changes or updates to the system.

    Yesterday I came back to Zotero 6 as well, and I noticed that what are missing are not the Windows controls on the right only, it's actually the whole top bar of the program window... apart from what I originally mentioned about the switching between tabs.
  • I had the same problem - missing whole top bar of the program - when using Z7. I uninstalled it completely, reinstalled it and the problem was gone. No idea why.
  • @bentle: Is that Windows 10 as well?
  • @dstillman Yes, that was Windows 10.
  • edited June 13, 2023
    Hello everyone, I unfortunately have the same problem (starting today). No minimize/maximize/close buttons and double click only to change tabs.
    The PC has not received any updates, I have not installed anything new (work PC in the hospital). Restarting did not resolve this.
    I am running Zotero 7.0.0-beta.10 (64-bit) and Windows 10
  • If you're experiencing this, can you try in a new Zotero profile?
  • This worked!!
    It actually worked so well that now both profiles (the default and the new) display the program normally...
  • edited June 13, 2023
    Then it was likely just restarting that fixed it. Profiles are totally separate, so creating a new profile wouldn't have an effect on an existing profile.

    In any case, you should delete the new profile (and any new data directory that was created) to avoid future confusion.
  • Update: when I deleted the new profile and ticked "use the selected profile without asking" the problematic interface came back!
    This also happens whether I have one (default) or more profiles
  • edited June 13, 2023
    I don't know if what I am about to comment can help to solve this bug.

    I was using beta.8 and the program worked without problems. The day the problems started, it was just the moment when Zotero detected that there was a new update (beta.9) and automatically started the download (without me noticing it).
    At that moment the bug appeared (still running beta.8), and that's when I realized that there was a new update. I thought it was some process of the update and decided to close the program so that it would be updated, and eventually everything would return to normality. But no, the program was updated to beta.9 and the bug did not disappear.

    I am commenting this because I have noticed that while we all have Windows 10, the problem has appeared at different times:

    @bentle reported it with beta.5
    @gustms and me: beta.9
    @delastic: beta.10

    Perhaps the problem is related to one of the update processes, rather than the program itself.

    An apology if I'm talking some nonsense, ha, ha, ha, ha!
  • edited June 14, 2023
    No, it wouldn’t be related to an update.
  • edited June 14, 2023
    @delastic: So you're saying it never happens when you start up with the Profile Manager first? And if you start up without that, it happens in any profile?

    For everyone, if you close Zotero, go to your Zotero profile directory, and delete xulstore.json, does that make a difference? What if you open prefs.js in a text editor and delete the extensions.zotero.pane.persist line?

    Also, just to confirm, I assume everyone who is seeing this has tried disabling all third-party plugins?
  • edited June 14, 2023
    Edit: Sorry, looks like is currently broken in Zotero 7. We'll fix this and ask again.

    If you're seeing this, can you go to Tools → Developer → Run JavaScript, run Zotero.openInViewer('about:support'), click "Copy text to clipboard", paste the text into an email, and send it to us at support@zotero.org with a link to this thread? We'd like to see if there's some common system configuration (graphics drivers, etc.) that might be causing this.
  • @dstillman
    1) yes, that is exactly the case, only when I start through the profile manager I get a normal interface (in any profile, I currently only have one, the default)
    2) when I start without profile manager:
    -deleting xulstore.json did not do anything
    -deleting the extensions.zotero.pane.persist line did not do anything (and the line reappeared when I closed the program which is expected I assume)

    3) I have no active plugins since the update to 7
  • only when I start through the profile manager I get a normal interface
    OK, so for others, while we're debugging this, it sounds like a workaround would be to first start Zotero from the Run dialog with the -P flag:

    C:\Program Files\Zotero\zotero.exe -P

    And then uncheck "Use the selected profile without asking at startup".

    You can then start Zotero normally and it will open the Profile Manager, after which you can select the profile and use Zotero without this problem.
  • edited June 14, 2023
    OK, so for others, while we're debugging this, it sounds like a workaround would be to first start Zotero from the Run dialog with the -P flag...
    @dstillman I didn't need to do that. To follow the instructions you gave, I first uninstalled Zotero 6, installed the new beta.11 and the bug just disappeared! The UI is normal and Zotero works without problems.
  • Unfortunately the update to .11 did not solve it for me... (did not do a clean install though)
  • edited June 15, 2023
    Again, it has nothing to do with which beta version you're running.
  • edited June 16, 2023
    Today again... the same beta.11 that yesterday and the day before yesterday worked fine, not today. Indeed it has nothing to do with the beta-version.

    Then I followed the steps indicated with the Profile Manager, and yes, the problem disappeared. I have started the program several times (Profile Manager always appears first), but it works fine.

    By the way, the bug coincidentally reappeared when a new version was available.
  • Just a hand up to say I had the same issue, -P flag avoids it so thanks for the workaround.
  • @cjb Do you also use Windows 10?
  • Yes, windows 10 on a University laptop
Sign In or Register to comment.