WebDAV sync no longer working

My last successful WebDAV sync with was August 1. For at least the past week, my database has synched with Zotero but the WebDAV upload/retrieval portion has stopped working. When clicking either the normal "Sync with" green button or "Verify server" on the Preferences > Sync tab, it tried to connect indefinitely and does not time out.

I know that discontinued support (link below) some years ago, but its WebDAV had been working consistently through this month. I'm not sure whether this is a temporary issue or if WebDAV is finally kaput.

Has anyone else been having this issue lately? Looks like @zyzzz was in another thread (linked below).
  • edited August 29, 2022
    Same issue (EDIT: also with, noticed it the first time on August 20)
  • the same goes for Hope the Zotero team can look into it.
  • It has nothing to do with us. Nothing has changed about Zotero’s WebDAV support in years. Zotero works with properly functioning WebDAV servers.
  • Same problem here... In my case, Zotero does not synchronize since August 12. I tried to sync with other clouds (pCloud and Yandex Disk) and I didn't succeed either, it tells me that the servers could not connect (as if I had misplaced the username and password, but it's not the case).
  • interesting, I am using to connect to my OneDrive for Business and Google drive accounts. Google Drive succeeded but OneDrive failed.
  • Yes, Box works normally until Aug. 16. Both Zotero on Macbook and iPad cannot connect to the Box dav server. Besides, as @ow described, the green button keeps spinning in circles, and the resource manager on my Macbook shows that Zotero occupies about 1m of bandwidth, but the sync process never completes.
  • @zyzzz: It certainly shouldn't use lots of bandwidth regardless. If you're still seeing that, can you generate a Debug ID for Zotero startup through a minute of this happening, using the "Restart with Logging Enabled…" option, and post that to a new thread?
  • I have the same issue. My last sync with was in August 15. In my case, I prove by entering options and checking the server but I never get a response. Debug ID: D271873930.
  • OK, if you’re trying to connect to Box, you should definitely stop trying. They’re returning a 502 Bad Gateway error — which might just mean they’ve taken down the service — and Zotero seems to have a bug where it’s repeatedly retrying an a 502 error without any delay, causing the high bandwidth usage that @zyzzz referred to. We’ll fix the lack of a retry delay for 6.0.14, but the underlying problem of Box returning an error would remain.
  • Hey @dstillman, I tried to send a file using curl to and it seems to be working correctly. I could even re-download my file from

    This started to happen to me after I updated Zotero to the latest version, though I don´t remember what version I was using previously.

    I think this might indicate this is an issue with Zotero.

  • It's not an issue with Zotero. Again, Zotero's WebDAV support hasn't changed in years, and it works with all properly functioning WebDAV servers — you can set up Apache with WebDAV on a server and test it yourself if you like.

    Box is returning a server error — not a client error — for an HTTP OPTIONS request. Perhaps PUT requests are still working. But given that Box ended official WebDAV support in 2019, I'm not sure why you would expect that this would continue working indefinitely.
  • edited August 29, 2022
    I tried to downgrade Zotero a few versions back and the sync with Box still doesn't work.

    Just to correct my previous post, then, this is probably not an issue on Zotero's end, but on Box's.

    Just wanted to clarify it so my previous post wouldn't make more people ask for Zotero to fix this issue.

    Thank you @dstillman for clarifying it more. Sorry for the trouble.
  • This is what I expected, but just to clarify for anyone following along, it looks like the answer to my original question is that this is finally the end of's unsupported WebDAV continuation. Seems like this coincided with the launch of Box Notes. This is purely on and has nothing to do with Zotero.
  • same here. Box does not work for this anymore?
  • Is there any other good option for WebDAV since we have more than 5000 files in Zotero?
  • Here is a list of potential services (may not be up to date)

    You could also set up your own WebDAV server using OwnCloud
    Get lifetime account on stacksocial
  • By way of update, WebDAV sync is working again. I haven't seen an explanation of what happened (i.e., it is still considered "unsupported" by Box), but FYI.

    If this happens again, the best alternative is transitioning to Zotero's paid sync hosting services. It is easy to set up, though I personally had significant difficulties downloading my full library from Box and performing a full upload to Zotero. But that's a discussion for another thread.
  • Just was using iPad and received the error and saw the bad news.
    Oh dear.
Sign In or Register to comment.