Zotero 6.0 notes disable autocorrect apostrophe into single quotes - accute accent don't work

Hi Forum,

I usually write notes in Portuguese and couldn't find a way to stop the new Notes program to autocorrect the apostrophe - that I use to make the acute accent in Portuguese like in "é" or "água". (acute accent: https://en.wikipedia.org/wiki/Acute_accent)

The note is always changing the ' to curved single quote, and then the words with these acute accents don't work. The result is, for example:

instead of água I get ‘gua, or criança I get crian’a.

This is completely annoying since many many words in Portuguese use this accent.

And it happens only when I use the International English keyboard, because the key I press to make the accent is the same for the single and double quotes.

PLEASE - could someone help me to fix this??
  • Could you say which international keyboard you're referring to? The standard English INTL keyboard has á as altGr + a and ç as altGr + c and both work fine in the new note editor.

    FWIW, I'm also able to write á on a German keyboard by typing ´ + a in the note editor.

    I've never seen single quote ' used to make accented characters and it's certainly not a standard input feature I'm aware of, though it's possible (likely, given that you seem to be used to it) that some programs support it

  • Hi, thanks for the quick response and for trying to help!

    I'll try to explain it better:

    On my keyboard (Macbook US English but sometimes also called US-international), I just press the ' key (it is between the ;: key and the return key with the symbols " and ' ) + the letter to have á é í ó ú or ç.
    It seems the same on your German keyboard, isn't it? ' + e = é

    But in the note editor, sometimes when I'm super fast pressing both keys it works, most of the time it doesn't - I couldn't find a pattern to make it work. Then I realized that it changes the ' for this 'curved single quote' and also doesn't type the letter.

    and the result is like this:

    correla’ão no n’vel da esp’cie
    instead of
    correlação no nível da espécie

    Then I thought that the problem might be some autocorrection from the ' (apostrophe) to a single quote. But maybe not...

    I really don't know what to do :(
    And I didn't have this problem in the previous version of Zotero note
  • edited February 20, 2022
    Ah I see -- I'm not having any problems with that on windows -- works just fine
    correlação a nível da espécie -- copied straight from the note in Word. But one thing you write isn't quite right:
    There's a different between a US English keyboard and an English INTL keyboard. Their layout is the same, but their behavior is different. What you're describing is standard behavior in rich text editors -- across all software I test, with the keyboard set to US English, so the first thing is to make sure that you actually have your keyboard set to English INTL and note English US and that you can type á elsewhere, e.g. here in the browser.

    edit: ignore & see below
  • edited February 20, 2022
    On my keyboard (Macbook US English but sometimes also called US-international), I just press the ' key (it is between the ;: key and the return key with the symbols " and ' ) + the letter to have á é í ó ú or ç.
    @melinatarituba: This is a special "U.S. International - PC" input source that (I guess?) mirrors some behavior from Windows. It's not generally how one inserts accented letters on a Mac, and it doesn't work with how the note editor currently handles typographical quotes.

    There are two primary methods of inputting accented characters on macOS:

    1) The traditional method, where you press Option plus a particular key, followed by a letter. E.g., Option+e (for an acute accent) + e to type é.

    2) A more recent method where you press and hold a letter key to bring up a popup with a list of accent options. E.g., press and hold e to bring up a popup and type 2 or use the mouse to select é.

    (You can also use the Keyboard Viewer, but that's more tedious.)

    Both of these work fine in the Zotero 6 note editor.

    We can look into whether we can better support the U.S. International input source, but the other two methods are far more standard and how pretty much any article online will tell you how to insert accented characters on macOS.
  • On the Mac US English keyboard, the way to type á, é, í, etc. is by option-e followed by our vowel of choice. And option-i for â, ê, ..., option-u for ä, ë, ..., and option-` for à, è, ..., option-n for ã, ñ, ..., etc. For ç, simply option-c gets you ç. These work for me here in the browser and in the new Zotero Note Editor. Summarized here: https://www.bu.edu/geddes/files/2011/04/accents-mac.pdf

    The way you describe is not a standard way to write accented characters on Macs.
  • (That U.S. International method also seems extremely annoying, since if you want actual quotation marks it seems like you have to press space bar after the mark to prevent it from — potentially, unpredictably — auto-converting the next letter. I'd strongly recommend just learning the standard Mac methods for accents.)
  • Hi everyone, thanks for the comments!

    I made the confusion:
    my physical keyboard: magic keyboard - US English (btw, the same as in the laptop)
    BUT in the keyboard settings of my mac (System Preferences) is US - international PC

    I've always used this way (' + e = é) in all the programs I use, including Zotero 5.0.
    Maybe this is the standard way to write accented characters in macOS in Portuguese?? I mean, I don't remember changing those settings.

    It is good to know that there are (at least 2) options! I've never heard about them but indeed (option + e = é) works well in the Zotero Notes. And I can try to use that there.

    However, because in Portuguese this accent is VERY common and the way (' + e) is much easier in terms of finger movements, changing the way I've always typed just for Zotero notes seems "un-optimal", do you agree?

    Well, I, and some others that write notes in Portuguese in a MacOS with Portuguese language settings, would benefit a lot if you guys could find a way to "support the U.S. International input source"!! :D

    @dstillman you are right, for the quotations (single or double) I have to press space - but I'm so used to that that I don't even realize it...

    And there is also this weird behavior in Zotero Notes, that sometimes the accent appears correctly if I press the keys very quickly!!

    Thanks again to you all!
  • edited April 23, 2022
    Hi, I have the same problem, but using the Slovak keyboard layout. I have been using this way of entering accents (letters like á, é, í, ó, etc.) for over 12 years on various versions of Mac OS X and in various programs. I am convinced that this is a standard way of entering diacritics. Zotero 6 is the only program I have had a problem with this so far, so I think it alters the standard behavior in a disturbing and user-unfriendly way.
  • This behaviour of auto converting to curly quotes is also causing me problems.

    Double quotation mark as " (U+0022) are converted to “ (U+201C) and ” (U+201D) automatically on typing in the note editor (Zotero 6.0.4).
    I completely hate this, and I found no way to prevent this behaviour – except with ctrl+Z after typing the character, but I'm using quotation marks the whole day and I'm not intending to press three keyboard keys to type a single quotation mark every time.

    There are more than 31 quotation mark types in the Unicode, each language has different conventions (e.g. English, French and German quotation marks are not the same), hence my policy is to use " every single time for consistency and to avoid formatting headache (also when copy-pasting between documents).

    I really do love Zotero (but I do not like very much the new note editor to be honest, the previous one was more straightforward, I don't like when software make obfuscating formatting decisions I did not ask for) and I really would like to have an option to control this behaviour.
  • In Zotero 6.0.6, available now, we've added a hidden pref, note.smartQuotes, to disable smart quotes. You'll need to reload the note editor after changing the pref for it to take effect. We'll make this a visible pref in a future version.
  • Great, thank you very much! It works seamlessly.
    It would be nice to have it as a visible pref, since I discovered another issue - with Slovak keyboard layout it is not possible to enter some accented letters even by using the alternative method with ALT+e following the character (like ŕ, for example).
  • Thank you very much, @dstillman!! It works great now!!! :D
  • Same feedback here: thanks for the option!
  • Ok, thank you! I toggled the smart quotes off and now the letters work as supposed. Still I think it's a bug since it works without problems and tinkling in Annotations. Thanks anyway, problem solved!
  • edited April 18, 2023
    Yes, we're going to see if we can fix this so people using keyboard modes that do this can leave smart quotes enabled.
  • edited April 18, 2023
    Actually, no need — this is already fixed in Zotero 7, which will be available in beta soon.
Sign In or Register to comment.