Word add-on disappeared, all troubleshooting steps failed :(


I am using Zotero on a PC with MS Word 365. Sometime between 3/14/23 and today, my Zotero add-on disappeared from Word. I have tried all the troubleshooting steps listed here (https://www.zotero.org/support/word_processor_plugin_troubleshooting#zotero_toolbar_doesn_t_appear), including fiddling with Word Trust Center, reinstalling the add-on, doing a totally fresh install of Zotero, etc. No dice.

This is an institutional computer. I checked with my SysAdmins and they assured me that nothing should've happened on their end to break it.

I noticed the there was an O365 security update on 3/14, so I'm wondering if that broke something (https://learn.microsoft.com/en-us/officeupdates/current-channel?redirectSourcePath=%2farticle%2f95c8d81d-08ba-42c1-914f-bca4603e1426). But it is beyond my skill level to fix this.

Any thoughts would be appreciated.


  • edited March 19, 2023
    We'd want to know exactly what you tried from the troubleshooting steps, in your own words, and exactly what happened at each step.
  • Thanks for the quick response. I will try to be succinct. Note, for most of these steps I am restarting zotero and word between each step.

    1. Rebooted both programs and then the computer.

    2. Went to Zotero preferences -> word processors and clicked "reinstall microsoft word add-in"

    3. Went through the manual installation procedure. zotero.dotm was already located in C:\Users\::username::\AppData\Roaming\Microsoft\Word\STARTUP with a last-modified date of 3/12/23, but I overwrote it anyway.

    4. Went to Zotero -> tools -> add-ons and tried disabling, then re-enabling, word for windows integration

    5. In Word, went to File -> Options -> Add-ins and I can see Zotero.dotm in the "Active Application Add-ins" list. I also went to "Manage Word Add-ins" and confirmed that zotero is in that list and checked.

    6. In Word, went to file -> Options -> Trust Center -> Trust Center Settings -> Add-ins and confirmed that NONE of the checkboxes are checked (there are 3, one greyed out).

    7. Also in the above, went to Macro Settings and confirmed that "disable all macros with notifications" is ticked (this is the default setting for me). I do get a yellow bar in Word that states "Security Warning: Marcos have been disabled." Clicking "enable" doesn't change anything. I had never seen this bar until a few days ago so it may be related to this issue.

    8. Changing the above setting to "enable all macros" makes the yellow bar disappear but doesn't bring up the Zotero ribbon.

    9. Deleting zotero.dotm from the startup folder ALSO makes this yellow bar disappear, even with "disable all macros with notifications" checked.

    10. Totally deleted zotero via Windows. Also manually deleted the zotero.dotm file in Word/startup. Reinstalled Zotero and ensured the add-in was installed via steps 2 and 3 above.

    11. Ran a repair on MS Office via Windows. I don't have the ability to do a clean install.

    12. I have another computer also running MS office (personal, not Enterprise), and I installed zotero on there to check. It works fine there!

    I think that covers it. Open to other suggestions. I'm still not totally convinced that my institution didn't do something to break things, but I don't have a way to confirm/deny.


  • OK, thanks. That all sounds fine — and the fact that you're getting the notification when you check "Disable all macros with notifications" and that the banner goes away when you delete Zotero.dotm suggests that the .dotm is being loaded. It's definitely possible that your IT department is doing something to prevent all macros, though I'd be a little surprised that you're getting the banner at all in that case.

    Just to confirm, you're looking for the Zotero tab at the end of the ribbon, and there's not a faint » symbol at the end where it's just not showing you all the tabs (e.g., if your window is unusually narrow)?
  • Yes, correct. I am on a wide screen, and normally "Zotero" appears in between "View" and "Help." Also, I don't see the options I normally see when right-clicking on a zotero-embedded reference.

    I will continue following up with my institution. Sometimes they push policies and don't tell the SysAdmins . . . we can fly helicopters on Mars, but Word plug-ins are hard.
  • Facing the same issue on a Mac with Word Version 16.71 (23031200) on an MS 365 subscription.
  • After reinstalling Word and Zotero from scratch, I have got the Zotero add-in back.
Sign In or Register to comment.